Jump to content

ubertooth + linux on vmware player


proxypirate
 Share

Recommended Posts

Hello hak5 members,

Well this is my first post on this forum and I am really hoping that someone here can help point me in the right direction...

So I ordered my ubertooth last week from the hakshop after having so much fun with the pineapple markV! I should have done my research because after i ordered the ubertooth i see that people are having trouble getting ubertooth to work on linux as a virtual guest os. I hope this is still not the case...

Can anyone tell me if they were able to get the ubertooth to work in either vmware player or virtualbox? If so how did you do it?...

If possible could someone point me to a link or hopefully some kind of tutorial on how to get the ubertooth working in a virtual guest environment

I really hope I can get this to work...Both my laptops have windows 7 as the host os and one has bt5r3 and the other Kali linux. It doesn't matter with virtual program will work either vmware player or vbox just as long as it will work!!

I thank you all for your time and assistance...

ProxyPirate

Link to comment
Share on other sites

  • 2 weeks later...

Okay so first off...I just wanted to let everyone know that I was able to get the ubertooth to work in vmware player without any issue. I tested this on the latest version of vmware player which is version 6 -> 6.0.1 build-1379776 and I tested this on the latest version of Kali Linux as well.

It was quite simple to get ubertooth-one working in VMware Player + Kali Linux i just followed the guide over at sourceforge and it worked just fine. In fact in the Kali Linet ux repo's there is an ubertooth package that installs all of the tools that come from downloading the .tar.xz file from sourceforge. Here is the tutorial in case anyone is looking for it -> http://ubertooth.sourceforge.net/usage/build/#ubuntu

I was able to get the ubertooth plugin to work with Kismet to work just fine and I have tested this also to confirm that it does in fact work.

As for the wireshark plugin you have to use libwireshark2 instead of libwireshark1 with Kali Linux but it will work all the same. When you get to the cmake build part of the tutorial for the wireshark plugin you will just run this command -> cmake -DCMAKE_INSTALL_LIBDIR=/usr/lib/wireshark/libwireshark2/plugins

I will be writting a very indepth tutorial on how to get ubertooth-one working in vmware player but i just wanted to get a quick response on this just in case anyone was wondering...

proxypirate

Link to comment
Share on other sites

Okay so one problem I have noticed with the ubertooth tools is sometimes after some usage it seems that the ubertooth tools get overwhelmed with data in a certain buffer **i think** and I have to restart Kali Linux in order to get programs such as ubertooth-lap or ubertooth-specan-ui to work properly.

Here is one of the error message i get when trying to rerun the ubertooth-specan-ui program after i have previously used it.

Traceback (most recent call last):
File "./ubertooth-specan-ui", line 260, in <module>
window = Window()
File "./ubertooth-specan-ui", line 227, in __init__
self._device = self._open_device()
File "./ubertooth-specan-ui", line 250, in _open_device
return Ubertooth(device)
File "/root/ubertooth_tools/ubertooth-2012-10-R1/host/specan_ui/specan/Ubertooth.py", line 38, in __init__
self._device.set_configuration()
File "/usr/lib/python2.7/dist-packages/usb/core.py", line 554, in set_configuration
self._ctx.managed_set_configuration(self, configuration)
File "/usr/lib/python2.7/dist-packages/usb/core.py", line 92, in managed_set_configuration
self.backend.set_configuration(self.handle, cfg.bConfigurationValue)
File "/usr/lib/python2.7/dist-packages/usb/backend/libusb1.py", line 503, in set_configuration
_check(_lib.libusb_set_configuration(dev_handle, config_value))
File "/usr/lib/python2.7/dist-packages/usb/backend/libusb1.py", line 403, in _check
raise USBError(_str_error[ret], ret, _libusb_errno[ret])
usb.core.USBError: [Errno None] Unknown error

If anyone has any ideas on why this happening I would really appreciate any response!

I am going to install Kali Linux on VirtualBox and see if ubertooth runs any better on that virtual os software. I have been told by another hak5 member that ubertooth works better on VMWare Workstation which i will be purchasing next week when i get paid. For now I will be testing it on virtualbox and report back on how it works with that virutal os software.

If anyone knows why I am getting this error I would really appreciate any input...

Thanks again,

-proxypirate

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...