Jump to content

Recommended Posts

I attempted a first boot setup today with no luck. When I try to connect 172.16.42.1:1471 through Firefox, I receive the message "Unable to Connect: Firefox can't establish a connection to the server at 172.16.42.1:1471." I cannot access the pineapple's user interface.

Edit: I am attempting to connect to the pineapple solely through an ethernet connection.

I am using a Macbook Pro Retina, OS 10.8.5

I insterted the MicroSD card supplied, powered on the pineapple (power cord), waited 6 minutes, and attempted to browse to http://172.16.42.1:1471. No luck.

My Macbook ethernet settings:

Configure IPv4: Manually

IP Address: 172.16.42.42

Subnet Mask: 255.255.255.0

Router: (left blank)

DNS Server: 8.8.8.8

Internet Connection Sharing: Off

I can ping 172.16.42.1 with no packet loss. I am also able to ping 172.16.42.1 from a local Kali VM, but Iceweasel is similarly unable to access the user interface at 172.16.42.1:1471.

If I browse to 172.16.42.1, I am able to see Index of /, with a message of:

1. ../

modified: Thu, 01 Jan 1970 00:00:29 GMT

directory - 0.00 kbyte

I tried the unbricking procedure here: https://wifipineapple.com/?flashing. I was able to set the DIP switches, set my Mac's static IP to 192.168.1.2, power up the pineapple and navigate to 192.168.1.1. I was able to upload the stager.bin file to the pineapple succesfully, reset the DIP switches, power down the pineapple, insert the MicroSD card, and power up the pineapple.

After resetting my Mac's ethernet to 172.16.42.42 (etc), I am still unable to access the user interface for the pineapple.

I would really appreciate any help anyone might be able to offer. I'm really stuck here.

Again, thank you for any help or advice anyone can offer.

Edit: nmap port scan from local Kali VM;

root@kali:~# nmap -p 1-1500 172.16.42.1

Starting Nmap 6.25 ( http://nmap.org ) at 2014-01-18 12:15 CST
Nmap scan report for 172.16.42.1
Host is up (0.00080s latency).
Not shown: 1497 filtered ports
PORT STATE SERVICE
22/tcp open ssh
53/tcp open domain
80/tcp open http

Nmap done: 1 IP address (1 host up) scanned in 7.43 seconds

So, I'm a bit confused here. If 1471 isn't open, how do I browse to it? What am I missing here?

Edited by StringJunky
Link to comment
Share on other sites

I'm following your thread as well. Are you getting similar results with ping and nmap?

I haven't tried it on Kali yet, it looks like it's more of a server issue than OS. Surprised there aren't more posts about it, there aren't any older ones that address this that I can see. Ping works fine for me as well.

Edited by haknakpdywak
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...