Jump to content

Channel "-1" Issue


Xcellerator
 Share

Recommended Posts

Not sure exactly where this should go, not an issue with a particular infusion, but a general one.

Has anyone else had trouble with the "-1" channel problem? I've been getting it when using Bully and Airodump. Bully in particular won't let me do anything at all. I get an error about being unable to set channel on mon0.

I had the same problem with the aircrack-ng suite on my laptop, but I just compiled the bleeding edge version which has a --ignore-negative-one. That solved it in the sense that I could use the program, but it still said "CH: -1" at the top.

Anyone else had anything like this?

Link to comment
Share on other sites

You need to down the interface, and then run airmon-ng start wlan1. Downing the interface before creating the monitor interface should fix your issue.

I also found this problem weird, but by bringing wlan1 down and doing airmon-ng start wlan1 solved the problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...