Jump to content

Micro SD not Detected


SICKFREDO
 Share

Recommended Posts

Hi guys Just recently purchased a MKV, while playing witt it i noticed it got a little slow, so i did a firmware reset (flash) accidentally i had the Micro SD card out and now it does not detect it, i tried re-flashing with it on but it still doesnt detect it. I was able to mount a USB but i am unable to see the micro SD card, I did try a SD card but it was not detected. im out of ideas as to how to fix it. Any help appreciated!

Current Disk Usage:
Filesystem                Size      Used Available Use% Mounted onrootfs                    4.1M    408.0K      3.7M  10% //dev/root                11.0M     11.0M         0 100% /romtmpfs                    30.2M    116.0K     30.1M   0% /tmptmpfs                   512.0K         0    512.0K   0% /dev/dev/mtdblock3            4.1M    408.0K      3.7M  10% /overlayoverlayfs:/overlay        4.1M    408.0K      3.7M  10% //dev/sda1                11.1G    296.3M     10.3G   3% /mnt/sda1/dev/sda2                 3.7G    121.1M      3.4G   3% /mnt/sda2
Current Memory Usage:
             total         used         free       shared      buffersMem:         61804        37720        24084            0         6176-/+ buffers:              31544        30260Swap:      1000164            0      1000164
Attached USB devices:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 001 Device 003: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
Bus 001 Device 004: ID 0781:556b SanDisk Corp.
Bus 001 Device 005: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader

Fstab Configuration:

config global automount
option from_fstab 1
option anon_mount 1

config global autoswap
option from_fstab 1
option anon_swap 0

config mount
option target /sd
option device /dev/sdcard/sd1
option fstype auto
option options rw,sync
option enabled 1
option enabled_fsck 0

config swap
option device /dev/sdcard/sd2
option enabled 1

Link to comment
Share on other sites

  • 3 weeks later...

I just got a 32GB SDcard for my MarkV too, and it would not recognize the card. I played with several different options until I found the right solution. The answer was to format the SD card as an ext2 filesystem.

To make this work, I had to SSH into the MarkV ... login as root, and run:

# mkfs.ext2 /dev/sdcard/sd1

When you look at the fstab it shows that the device node /dev/sdcard/sd1 is supposed to mount on the mountpoint /sd. However, there were already files in /sd and mounting the SD card there would effectively make those files inaccessible. So I first copied those files to the SD card after formatting it ... THEN mounted it.

For 32GB, this took a while, but when completed, I created a new directory (so as not to overwrite the existing directory, /sd) and then mounted the card:

# mkdir /sd1

# mount -w /dev/sdcard/sd1 /sd1

Then I copied the files from /sd (which was part of the root filesystem) over to the SDcard (so I could then mount the sdcard where it belongs)

# cp -a /sd/* /sd1

Next unmount the SD card and remount it where it belongs:

# umount /sd1

# mount -w /dev/sdcard/sd1 /sd

Finally ... clean up the extra directory that was created for copying:

# rmdir /sd1

Now I am able to see the full space available under the Status window, and am able to download large infusions to the 32Gb SD card.

Hopefully that helps some of you who may have seen the same problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...