Jump to content

Support for Sierra Wireless 320U USB LTE Dongle


BigDook
 Share

Recommended Posts

  • 7 months later...

I was able to get the Sierra Wireless Aircard 330u to work on my Mark V; assuming the 320u is not far off. The driver is unfortunately not included by default in the factory Mark V firmware image. Luckily, the Makefile for the sierra_net module is included in the firmware source bundle and has already been adapted to use OpenWrt's Makefile syntax. It is located in the /package/sierra-directip/ directory of the Mark V source bundle. You gotta compile it though. Hope you've access to a Linux machine!

Is your device modeswitching, or appearing at all when you issue an lsusb?

If it is and you'd like to get more detail about its connection status / what band its locking onto, you can issue some AT commands to it via picocom (or some other means). Just add "src/gz attitude_adjustment http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/packages" to your /opkg/opkg.conf, and then run "opkg install picocom"...

#install picocom
opkg install picocom
picocom -b 9600 -f n -p n -d 8 -r /dev/ttyUSB3 #swap 0 with whatever your command port is

#run picocom, then issue a AT!GSTATUS?
root@Pineapple:~# picocom -b 9600 -f n -p n -d 8 -r /dev/ttyUSB3
picocom v1.7

port is        : /dev/ttyUSB3
flowcontrol    : none
baudrate is    : 9600
parity is      : none
databits are   : 8
escape is      : C-a
local echo is  : no
noinit is      : no
noreset is     : yes
nolock is      : no
send_cmd is    : sz -vv
receive_cmd is : rz -vv
imap is        : 
omap is        : 
emap is        : crcrlf,delbs,


FATAL: cannot lock /dev/ttyUSB3: File exists
root@Pineapple:~# picocom -b 9600 -f n -p n -d 8 -r /dev/ttyUSB
ttyUSB0  ttyUSB1  ttyUSB2  ttyUSB3  ttyUSB4  ttyUSB5
root@Pineapple:~# ifdown wwan
root@Pineapple:~# picocom -b 9600 -f n -p n -d 8 -r /dev/ttyUSB3
picocom v1.7

port is        : /dev/ttyUSB3
flowcontrol    : none
baudrate is    : 9600
parity is      : none
databits are   : 8
escape is      : C-a
local echo is  : no
noinit is      : no
noreset is     : yes
nolock is      : no
send_cmd is    : sz -vv
receive_cmd is : rz -vv
imap is        : 
omap is        : 
emap is        : crcrlf,delbs,

Terminal ready
AT!GSTATUS?
!GSTATUS: 
Current Time:  7019		Temperature: 29
Bootup Time:   1		Mode:        ONLINE         
System mode:   WCDMA      	PS state:    Attached     
WCDMA band:    WCDMA 850  
WCDMA channel: 1037
GMM (PS) state:REGISTERED     	NORMAL SERVICE 
MM (CS) state: IDLE           	NORMAL SERVICE 

WCDMA L1 State:L1M_PCH_SLEEP  	RRC State:   DISCONNECTED   
RX level C0:   -86		LAC:         DBEC (56300)
RX level C1:   -106		Cell ID:     ---omitted--


OK

... so this tells me that its locking onto the WCDMA 850 channel... aka 3G.

To get the thing to work, here is more or less what I did.

Grab the source from... http://wiki.wifipineapple.com/uploads/source.tar.gz

Follow the guide here to set up your environment for cross-compilation, set compilation target to linux-ar71xx_generic, etc...

Before you build, do a double-check of the .config file in the base directory of the source-code bundle, to ensure that the line "# CONFIG_PACKAGE_kmod-usb-net-sierrawireless=is not set" has been replaced with "CONFIG_PACKAGE_kmod-usb-net-sierrawireless=y".

Issue the "make" command in the base directory of the source-code bundle.

After some time, the build should complete and file will be located at {source code root}/build_dir/linux-ar71xx_generic/linux-3.3.8/drivers/net/usb/sierra_net.ko

Copy that file by whatever means is preferable, to /lib/modules/sierra_net.ko on your Pineapple. So using scp for example...

scp {source code root}/build_dir/linux-ar71xx_generic/linux-3.3.8/drivers/net/usb/sierra_net.ko root@172.16.41.1:/lib/module/sierra_net.ko

On your PIneapple, add "sierra_net" on a new line in the /etc/modules.d/61-usb-serial-wwan, below "usb_wwan".

Create a symlink to that file from /etc/modules-boot.d/61-usb-serial-wwan.

ln -s /etc/modules.d/61-usb-serial-wwan /etc/modules-boot.d/61-user-serial-wwan

Add this to your /etc/config/network file on the Pineapple:

config interface 'wwan'
	option proto '3g'
        option device '/dev/ttyUSB3' #swap with the path to the command port of your card...
        option apn 'lteinternet.apn' #swap with your APN
        option service 'umts'

Note that I set the service to UMTS above... My card is locking to the

Then just do ifup wwan... Should show up as something like "3g-wwan" in your ifconfig output.

Edited by GarrettVD
Link to comment
Share on other sites

  • 7 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...