Jump to content

AP121u-64mb Kernelpanic


mex23
 Share

Recommended Posts

Dear HAK5 Community,

me and a friend of mine wanted to build our own Mark IV.

We bought a AP121u-64mb and Serial TTL Cable.

We have flashed it like it´s discripted in the 'Performing a clean flash' tutorial at wifipineapple.com, this worked fine but the saveenv command didnt work. (Unknown command 'saveenv' - try 'help').

Now we have the problem, when AP121u boots we get an kernel panic.

Hear is the output we see after sysupgrade reboot

root@Hornet:/# sysupgrade -n -v /tmp/upgrade-3.0.0.bin
Sending TERM to remaining processes ... {multiwan} {multiwan} {multiwan} uhttpd {rcS} syslogd udhcpc logger klogd sleep sleep sleep mini_httpd dnsmasq mini_snmpd Sep  8 16:05:53 mini_snmpd[1400]: stopped

hotplug2
Sending KILL to remaining processes ...
Switching to ramdisk...
Performing system upgrade...
Unlocking firmware ...

Writing from <stdin> to firmware ...
Upgrade completed
Rebooting system...
Restartin▒

U-Boot 1.1.4 (Apr 25 2013 - 14:01:10)

AP121 (ar9331) U-boot

DRAM:  64 MB
Top of RAM usable for U-Boot at: 84000000
Reserving 149k for U-Boot at: 83fd8000
Reserving 192k for malloc() at: 83fa8000
Reserving 44 Bytes for Board Info at: 83fa7fd4
Reserving 36 Bytes for Global Data at: 83fa7fb0
Reserving 128k for boot params() at: 83f87fb0
Stack Pointer at: 83f87f98
Now running in RAM - U-Boot at: 83fd8000
Flash Manuf Id 0xc2, DeviceId0 0x20, DeviceId1 0x18
flash size 16777216, sector count = 256
Flash: 16 MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag7240_enet_initialize...
Fetching MAC Address from 0x83ff0608
Fetching MAC Address from 0x83ff0608
: cfg1 0x5 cfg2 0x7114
eth0: 00:c0:ca:77:58:55
eth0 up
: cfg1 0xf cfg2 0x7214
eth1: 00:c0:ca:77:58:54
athrs26_reg_init_lan
ATHRS26: resetting s26
ATHRS26: s26 reset done
eth1 up
eth0, eth1
Hit any key to stop autoboot:  0
## Booting image at 9fe50000 ...
   Image Name:   Linux Kernel Image
   Created:      2013-04-25   6:01:19 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    772455 Bytes = 754.4 kB
   Load Address: 80002000
   Entry Point:  8019c240
   Verifying Checksum at 0x9fe50040 ...OK
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 8019c240) ...
## Giving linux memsize in bytes, 67108864

Starting kernel ...

Booting AR9330(Hornet)...
Linux version 2.6.31--LSDK-9.2.0_U10.1020 (Nelson@localhost.localdomain) (gcc version 4.3.3 (GCC) ) #1 Thu Apr 25 14:00:31 CST 2013
flash_size passed from bootloader = 16
arg 1: console=ttyS0,115200
arg 2: root=31:02
arg 3: rootfstype=squashfs
arg 4: init=/sbin/init
arg 5: mtdparts=ar7240-nor0:256k(u-boot),64k(u-boot-env),14336k(rootfs),1600k(uImage),64k(NVRAM),64k(ART)
arg 6: python
arg 7: mem=64M
CPU revision is: 00019374 (MIPS 24Kc)
Determined physical RAM map:
 memory: 02000000 @ 00000000 (usable)
User-defined physical RAM map:
 memory: 04000000 @ 00000000 (usable)
Zone PFN ranges:
  Normal   0x00000000 -> 0x00004000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00004000
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
Kernel command line: console=ttyS0,115200 root=31:02 rootfstype=squashfs init=/sbin/init mtdparts=ar7240-nor0:256k(u-boot),64k(u-boot-env),14336k(rootfs),1600k(uImage),64k(NVRAM),64k(ART) python mem=64M
PID hash table entries: 256 (order: 8, 1024 bytes)
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
Writing ErrCtl register=00000000
Readback ErrCtl register=00000000
Memory: 62632k/65536k available (1654k kernel code, 2832k reserved, 419k data, 112k init, 0k highmem)
NR_IRQS:128
plat_time_init: plat time init done
Calibrating delay loop... 266.24 BogoMIPS (lpj=532480)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
===== ar7240_platform_init: 0
bio: create slab <bio-0> at 0
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 2048 (order: 2, 16384 bytes)
TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
TCP reno registered
NET: Registered protocol family 1
AR7240 GPIOC major 0
squashfs: version 4.0 (2009/01/31) Phillip Lougher
msgmni has been set to 122
io scheduler noop registered (default)
Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
ttyS0: detected caps 00000000 should be 00000100
serial8250.0: ttyS0 at MMIO 0xb8020000 (irq = 19) is a 16550A
console [ttyS0] enabled
brd: module loaded
6 cmdlinepart partitions found on MTD device ar7240-nor0
Creating 6 MTD partitions on "ar7240-nor0":
0x000000000000-0x000000040000 : "u-boot"
0x000000040000-0x000000050000 : "u-boot-env"
0x000000050000-0x000000e50000 : "rootfs"
0x000000e50000-0x000000fe0000 : "uImage"
0x000000fe0000-0x000000ff0000 : "NVRAM"
0x000000ff0000-0x000001000000 : "ART"
usbmon: debugfs is not available
TCP cubic registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
arch/mips/ar7240/gpio.c (ar7240_simple_config_init) AP_RESET_GPIO: 12
arch/mips/ar7240/gpio.c (ar7240_simple_config_init) JUMPSTART_GPIO: 11
ar7240wdt_init: Registering WDT success
List of all partitions:
1f00             256 mtdblock0 (driver?)
1f01              64 mtdblock1 (driver?)
1f02           14336 mtdblock2 (driver?)
1f03            1600 mtdblock3 (driver?)
1f04              64 mtdblock4 (driver?)
1f05              64 mtdblock5 (driver?)
No filesystem could mount root, tried:  squashfs
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,2)

We found out with thease stepts we get pinapple boot proertly

1. Connect via serial

2. hit enter at boot (drop into uboot shell)

3. type bootm 0x9f650000

we think the problem is, that the boot env will be lost after reboot

sorry for my bad english, please help !

Link to comment
Share on other sites

thank you sebkinne for your answer

would it be possible to use the 64mb version with some changes?

or do i have to buy a new AP121u with 32mb?

You'd need the 8mb flash version.

It's not possible to just change a setting or similar. We'd need to recompile the firmware with the correct flash layout, but this is not going to happen any time soon - sorry.

Best Regards,

Sebkinne

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...