Jump to content

sslstrip missing openssl


boob00
 Share

Recommended Posts

Hello everyone, im using Linux Mint 16 Petra and apt-get'ed sslstrip, however when i run sslstrip i get this error

Traceback (most recent call last):
  File "/usr/bin/sslstrip", line 30, in <module>
    from sslstrip.StrippingProxy import StrippingProxy
  File "/usr/share/sslstrip/sslstrip/StrippingProxy.py", line 20, in <module>
    from ClientRequest import ClientRequest
  File "/usr/share/sslstrip/sslstrip/ClientRequest.py", line 25, in <module>
    from twisted.internet import ssl
  File "/usr/lib/python2.7/dist-packages/twisted/internet/ssl.py", line 25, in <module>
    from OpenSSL import SSL
ImportError: No module named OpenSSL

my nooby mind leads me to believe that it means i dont have openssl installed, but i do. I have tried removing sslstrip and re-installing, and removing openssl and reinstalling it, updating my machine to make sure my packages are up to date, just about everything i can think to do. Any help is greatly appreciated!!

-boob00

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...