Jump to content

[Support] WiFi Manager


chputney
 Share

Recommended Posts

I am having trouble understanding why Wifi Manager is adding radio configurations. I am seeing several things that I don’t understand.

I start with a clean configuration by:

rm /etc/config/wireless

wifi detect > /etc/config/wireless

reboot

First issue – new radio configurations

Now I use the Wifi Manager option Random Mac to scramble the mac accress for radio0. This shows me a new mac address. I use “Save” and “Commit” to make this permanent. Looking at the /etc/wireless/config file, a new line “option macaddr '2C:AC:41:8D:45:A8'” has been added to the file under radio0. Now I reboot – expecting to see the new mac address on radio0.

After reboot, looking at the Wifi Manager panel, I see a new configuration called radio2 has been added with the original assigned mac address. The random mac is not working. (I don’t think the mac address option in /etc/config/wireless works.) Looking at the /etc/config/wireless file, I see that it is disabled but Wifi Manager says it is enabled. What is going on ?

Second issue – cannot delete configurations

Now I try to get rid of this new configuration. I use “Remove config” in the Wifi Manager window, then “Save” and “Commit”. Looking at the /etc/config/wireless file, the radio2 configuration is gone. Now I reboot – and the radio2 configuration is back!

Third issue- Auto Detect

I think that “Auto-Detect” is intended to reset the wifi configuration to defaults. When I perform “Auto-Detect” “Save” and “Commit”, it seems to have no effect sometimes. The /etc/wireless/config file is unchanged. If the /etc/wireless/config file is deleted manually, it can restore an original configuration. One time I tried it and it restored a configuration with the radios swapped. Is there a “right” way to use this ?

Link to comment
Share on other sites

I think that I understand the issue with "Random mac". When you click on this, it gives the new mac address to wlan0 or wlan1 okay. The problem is that if you "Save" after this, then the /etc/wireless/config file is updated with the "option macaddr xx:xx:...". This is a problem because during boot if the wireless mac address is not found in the etc/config/wireless file, a new configuration is added. This could be fixed by not saving the mac address in the configuration file.

Link to comment
Share on other sites

  • 1 month later...
Hello, I wanted to comment a little problem with wlan1 (RTL8187) as much as the active interface change never get another access point. I have found that works because if I look that interface with any access point if you find it, but if in AP mode never shows me the name of the access point as does wlan0 (AR9331).
Not to be happening, but the handling is easy and the Wifi-Manager infusion more.
Still I edited my /etc/wireless settings and this seems to work only for wlan1 again

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11ng'
	option macaddr '00:00:00:00:15:c6'
	option htmode 'HT20'
	list ht_capab 'SHORT-GI-20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option disabled '0'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'WIFI_AP1'
	option hidden '0'
	option key '41CH3ldfKAS79'
	option encryption 'mixed-psk+tkip+aes'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option macaddr '00:00:00:00:d9:cb'
	option disabled '0'

config wifi-iface
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'Pineapple5_D9CB'
	option hidden '0'
	option key 'Z0002FCDBFF6D'
	option encryption 'wep'

Even copying of settings radio1 still work. Can you help? Thank you.

Edited by Hits_s
Link to comment
Share on other sites

Hits_s,

If I read your posts correctly you are trying to create an Access Point on wlan1. That is not going to work. The wlan1 RTL8187 is used for Client mode only. Well, also it can do deauthing... but it cannot be used as an AP. That's been stated several times here in the forums.

Link to comment
Share on other sites

Hits_s,

If I read your posts correctly you are trying to create an Access Point on wlan1. That is not going to work. The wlan1 RTL8187 is used for Client mode only. Well, also it can do deauthing... but it cannot be used as an AP. That's been stated several times here in the forums.

Yes you understand well: D Thanks for answering.

Anyway I'm sorry I missed that part in forums that say that you can not make access point, so I conclude that I could perhaps use an external antenna to create another access point. (TP-link or Alfa Network).

I do not understand very well because I can not use RTL for a new access point, if I reported some of the forum threads you comment learn to appreciate it.

Thank you very much for answering my call for help.

Edited by Hits_s
Link to comment
Share on other sites

  • 2 weeks later...

lunokhod,

Need a little more detail in order to understand what you are seeing and where you are seeing it. Can you do copy and pastes of outputs from the commands you're running or perhaps screenshots if it's in an infusion?

Link to comment
Share on other sites

It's the basic ifconfig up/down commands. The same thing happens when I click enable/disable in the Logical Interfaces section of WiFi Manager.

Issue "ifconfig wlan0 down"

There is no output on the terminal after issuing the command. When I check WiFi Manager I see this (MAC partially blanked!) :-

Physical Interface radio0 [eth0] - HWAddr [00:13:37:xx:xx:xx]

After "ifconfig wlan0 up" (still no output in SSH terminal), I see this in WiFi manager :-

Physical Interface radio0 [wlan0] - HWAddr [00:13:37:xx:xx:xx]

When wlan1 is disabled with the same method "ifconfig wlan1 down"... WiFi Manager shows this :-

Physical Interface radio1 [-] - HWAddr [00:13:37:xx:xx:xx]

It's not really a problem as such... I just want to know if this behavior is normal or not.

Below is a separate observation not directly linked to WiFi Manager...

I also notice that starting wlan0 (ifconfig wlan0 up or enabling wlan0 in WiFi Manager) does not start the access point on wlan0 (no blue LED and also confirmed by running airodump-ng on a Raspberry Pi & Alfa 036H).

I have to uncheck the radio0 enable tick box, then "save" and "commit"... then recheck radio0 enable tick box and "save" and "commit" before the access point becomes "alive" and blue LED illuminates.

Enabling and Disabling wlan0 via the Network Tile does appear to start and stop both the wlan0 interface and the access point operation as expected.

Starting wlan0 via "ifconfig wlan0 up" or clicking enable in WiFi Manager also shows that wlan0 is enabled in the Network Tile. But until you disable and then enable in the Network Tile the wlan0 access point (and blue LED) does not operate.

Lunokhod

Edited by lunokhod
Link to comment
Share on other sites

For the first part I'm just guessing but it might have to do with the use of br-lan and how they are connected. For the second the WiFi Manger infusion works that way on purpose. It does not execute the changes until you save and commit but that seems to be a feature and not a flaw. :)

Link to comment
Share on other sites

I should mention that I am connecting to the WiFi Pineapple in a slightly different way. Instead of a fixed IP address for eth0, I have modified the network file to allow eth0 to get an address via DHCP from my home network.

I will change it back to the "factory default" fixed IP address and see if the same WiFi Manager behavior is seen.

Link to comment
Share on other sites

  • 3 weeks later...
  • 6 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...