Jump to content

Pineapple connecting to OS X Mavericks issues


Recommended Posts

OK.. I have been on this for about 12 hours now trying to setup my Pineapple. I..Think..I..Need..help..

I'm breaking down my setup/connection so you all get the gist.

Computer Hardware: 15" Retinal MBP

Pineapple hardware Version: MarkV

Pineapple Firmware Version: 1.0.4

OS used to connect to the Pineapple: OS X Mavericks

Network Layout: Pineapple is supplied power from wall outlet. I have my wifi pineapple connected to my Mac via USB to ethernet, ethernet cable connected into pineapple. My Mac is connected via WiFi from my personal Access Point. I have manually configured the settings per the booklet that came with the Pineapple.-- IP address: / subnet mask / DNS server: (I have toggled this on and off) . I have set the connection service order Wi-Fi FIRST and then USB ethernet SECOND.

REMINDER: (no I'm not forgetting the part where I turn on ICS in the sharing tab inside system preferences.. I'll get to that part in just a moment)

After the hardware is set up you go to sign in and essentially when setting up the pineapple you have to create a password, accept the terms and then you're in. Walla, right?! not so much. Here's what happened...

After the "first boot setup" I Looked at the pineapple hardware and noticed I got a solid green. "POWERED" and secondly I get Yellow "ETHERNET". I got in and played around checking out the WiFi Pineapple - Management interface. Went to set up Karma it was as easy as typing in your personal access point name and then clicking START from the main menu. The newly named AP would show up in the "looking for WiFi networks" menu. AWESOME. Went to connect to the device with another computer to start this party and no connection. Bummer. Then I noticed that I had not turned on ICS. Turned that on in system preferences / sharing tab and toggled USB Ethernet check box then checked internet sharing and POW we should have connection right? nope. This is where it all went down hill.

After I did this I tried to connect back to the site and it would not. Turned off ICS and rebooted my computer and I get connection. weird. I thought something went wrong so I reset the Pineapple to system defaults.

Went through everything again and same issue occurred.

Went to try and run updates and no connection. This is with ICS turned OFF.

Here's where things get weird..

After the 3rd or 4th default reset (using the dip switches, AWESOME) I noticed a solid blue light on the pineapple "ARN331"... Not sure what caused that but I got something different.

Went to run updates and randomly I could! (at this point the pineapple could connect to run updates and install infusions but not give off any wifi to have other clients connect) I ran all my updates and even did the firmware update 1.0.4 and I thought surly I was good to go. At this point I downloaded infusions and getting everything set up. Went to have some fun and tried to connect a computer to Karma's "made up AP" that I created and stillllll no connection.

Frustrated I reset back to defaults and tried everything over again. Firmware is still at 1.0.4 (latest update as of 11/23/2013)

This time I get ALL LIGHTS on my pineapple! green yellow blue and red! (this is still with no ICS on.. because IF I do that I can't even connect to it just times out on my web browser) Went to connect a device to my Karam "made up AP" and walla I had it made. Don't know what I did different but I had connection. Just to make sure it was not a fluke. I unplugged the Pineapple and connected it back up and now I only get green yellow blue lights.


My setup: I have not changed a thing. Everything is still the same, yet I got different results after a power cycle. I tried a different ethernet cable but they both responded the same. Rebooted my computer multiple times to make sure connection was clear.

ERRORS I get right now: When I go to Pineapple bar I get "Error connecting. Please check your internet connection!" (but remember I got into here to run updates before.. with the same exact settings before) I also get the error under Network tab Internet IP: "error connecting"... although randomly when I could connect to the pineapple bar/ run updates but NOT have karma working I got a internet IP (obviously)

My Question is: What should my settings be? I had full connection but lost it. I have read and re read all the OS X Setup forums. The youtube videos. None of them work.. suggestions?

I'm willing to do anything, to start all over, to order a new one whatever at this point.. I just want this thing to work..

what should my settings be?

Link to comment
Share on other sites

yeah. I've read this thread a million times. Mine still does not connect.

"Simple. Don't use it with the Mk 5. And I mean OSX ICS not a Mac. I use Mavericks on my Air with the pineapple all the time. I just use wlan1 on the pineapple to connect to an AP for Internet. Then just connect my laptop to the pineapples AP. Nothing else needed at that point. Your pineapple will be able to update and you'll also be able to browse websites etc. If your intended use of the Mk 5 differs from this and absolutely needs to use the eth0 connection your going to have to make several tweaks."

What did you mean by "I just use wlan1 on the pineapple to connect to an AP for Internet. Then just connect my laptop to the pineapples AP." -- How do I do this? This seems to be the answer.. I just need some guidance. And what will I not be able to do? Is this just connecting via client mode using wlan1?

I have Kali setup running with Parallels.. I've tried it on there multiple times.. I get through the ./wp5.sh command line but get no connection. I go to configure in Parallels network settings to bridge the connection and still cannot seem to get it connected. I'd love to run it on Kali as a VM but I've fought that battle tooooo long as well.

Link to comment
Share on other sites

Yes, the Mk5 has two wifi adapters in it now. wlan0 is where the pineapples broadcasted AP comes from and wlan1 is specifically made for Client Mode. You go into the Network Tile and there is a Client Mode Tab. Let it refresh and show you a drop down list of the APs that wlan1 sees. You choose the one you want to supply internet to the pineapple itself and to anyone connected to the pineapple via wlan0. Enter the pass phrase and click connect. For me the Pineapple image never stops spinning but down below you will see that it has connected. You can click to another tab and go back to the Client Mode Tab if you wish. Connecting this way is the new default and does not require a direct connection via eth0 nor does it require setting up ICS in OSX.

Your explanation of what you were doing above was excellent but it made it very clear what you were doing wrong and that you don't know that turning on ICS in OSX changes the IP range away from what you manually entered. It doesn't tell you it does this but it does. Barry is correct in that there are several threads on this where it's been asked an answered. ( Assuming you read all this in one of the other threads why would you have the expectation of reaching after turning on ICS in OSX?)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...