Jump to content

Unpeelable fresh pineapple


trevor3
 Share

Recommended Posts

I was a pineapple virgin until yesterday (and still haven't really gone

all the way).

I unpacked my new pineapple.

Followed the First Boot Setup.

Connected to ethernet port.

Set the password.

After "Continue" appeared,

supplied the password,

answered by the fruit with "Invalid username / password".

Followed the Factory Reset procedure ( up-down-down-up-up ).

Seemed to be successful.

Followed the First Boot Setup.

exactly the same result as first time.

Tried Web Recovery Interface ( up-up-up-up-down ).

(Suspect problems: not a normal-seeming boot sequence.

LEDs went to solid green and solid red in just a few seconds.)

Connected to ethernet port.

No DHCP response.

Configured computer as 172.16.42.42/24, gateway: 172.16.42.1

No response browsing to http://172.16.42.1 or http://172.16.42.1:1471

Configured computer as 192.168.1.2/24, gateway: 192.168.1.1

No response browsing to http://192.168.1.1 or http://192.168.1.1:1471

Tried Recovery Stager ( up-down-down-down-up ).

(Seemed like reasonable time for POST and self-test.)

Computer: 172.16.42.42.

http://172.16.42.1 goes to ~/redirect.php, but no further.

Browser responds at http://172.16.42.1:1471 with previously seen login page.

Once again, "Invalid username / password".

I'm speculating that the MicroSD image might have a problem,

so I'm about to fetch the current firmware and try putting it on

another MicroSD.

All suggestions are welcome.

Is there something else I should know about?

Thanks in advance.

Link to comment
Share on other sites

Thanks for the quick response Mr-Protocol.

https://wifipineapple.com/?flashing helped me find stager.bin, and I think it's where I

first came across the Recovery Web Interface, which sounds like it would be really neat.

But when I try to boot with DIPS up-up-up-up-down, the fruit is mute. LEDs are on

(solid green & solid red), but nobody's home, at 172.16.42.1:80 or :1471 nor either

of those ports at 192.168.1.1.

And I'm not yet seeing anything resembling either stager.bin or sd.bin on the microSD.

(I must be overlooking something embarrassingly obvious.)

Thanks

Link to comment
Share on other sites

I formatted another MicroSD with an MBR partition map and an ext4 partition,

copied upgrade.bin and stager.bin to the root directory (everything 777—just

to curb other possible problems).

After another factory reset and first boot sequence, everything's great.

The MicroSD that came with it seems to be MBR/ext4, but not a file in sight.

(What was happenning while it acted like it was reflashing earlier?)

All my remaining questions aside, it's now a nice ripe pineapple.

Thanks again, Mr-P

t3

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...