Jump to content

Java acting up - possibly a layer 8 issue /facepalm


>script_kiddie
 Share

Go to solution Solved by Sitwon,

Recommended Posts

Hey all, This is my first post on the Hak5 so if im not providing enough info please let me know and i will add it in.

firstly,

I'm runniing Kali linux just updated today ( VMware )

I'v updated Java to 7-45

As of now im limited to Simple Ducky ( great easy to use program ) it works perfect.

The problem that is across three OS's I have not been able to get duckencoder to work (OSX, MAC and Windows )

Windows cmd irritates me to much to keep trying.

Iv been bashing my head over Kali Linux getting it to work.

and the MAC for some reason just fails when i try to install the new Java - which is a separate monster in itself so i'll tackle that one later.

In Kali it was working one day...stopped working the next

now all i get is this ( refer to images ), and the commands are not copy and pasted so that is not the issue.

Iv ran the command while in the Java dir and elsewhere.

note: I'm not the most intelligent when it comes to this stuff, I have about 2 months of experience with Linux so please keep the bashing light lol

Thanks in advance, also - sorry if the file name offends anyone.

post-45768-0-79266800-1385130950_thumb.j

post-45768-0-42347800-1385130959_thumb.j

post-45768-0-64532000-1385131674_thumb.j

Link to comment
Share on other sites

Well, I certainly feel stupid - if you notice i was trying to run "duckencoder.jar" its called "duckencode.jar" super fail on my end BUT now im to a new issue.

Has anyone ran into this message? Anyone know how to fix?

again, Java is up to date

post-45768-0-66193500-1385134367_thumb.j

Link to comment
Share on other sites

  • Solution

That looks like it's probably another typo in your input, however the duckencode application should be giving you a better error message. If you can point me towards the source code, or failing that the jar file itself, I can audit the code and perhaps improve the error messages to be more meaningful.

Link to comment
Share on other sites

Well I hate to answer this way, but im a complete newb, i know how to find source code of a webpage but as far running a command that results in error and then trying to find the error, I think im miles from understanding that aspect.

my apology i took that screen shot before i finished editing the command to " java -jar duckencode.jar -i ~/Desktop/ball***.txt" after i ran that, I didn't see a little string showing that anything happened. A new line started so I assumed it still worked as normal and now there is "inject.bin" in the java dir.

If you want to school me a bit on finding the source code it would be appreciated, however im sure that's no 2 line explanation so if no that's fine to.

Thank you.

Overall my issue has been fixed

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...