Jump to content

sslstrip works just for https pages but blocks http pages


Recommended Posts

I have teh MK5 and just started to use it I did all the updates.

No errors

I then installed the sslstip to the local device and it works I get all the https traffic in the log window but when I try like www.google.com on the pc that is logged into the wifi of the mk5 it will time out but if I change the address to https://www.google.com it works the page will load and the MK5 will log the traffic.

Link to comment
Share on other sites

Please try the following and report back:

Comment out lines 97 and line 98 of /usr/lib/python2.7/site-packages/sslstrip/ServerConnection.py file by adding a "#" to the beginning of each line:

# elif (key.lower() == 'set-cookie'):

# self.client.responseHeaders.addRawHeader(key, value)

Do you still get the error after that?

I had the same problem with non https traffic. If you login via ssh, run sslstrip via command line and then attempt to surf, and you see errors - try the above solution posted by Garland in the 1.03 Firmware thread. Probably, try it regardless. it solved my problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...