Jump to content

Pineapple RTL8187 temperatures


wolfdale
 Share

Recommended Posts

I was using reaver today for about an hour and the pineapple had a burn smell to it. I measured temperatures (with the case off) with my IR thermometer and the heat seems to come from the RTL8187 chipset (about 50 degrees celsius) and I couldn't keep my finger on it for more than 2 seconds... I then measured idle temps (i gave ifconfig wlan1 down command) and it was 40 degrees. Measurements were taken with the case off so the temperatures would get higher with the case.

Whats the operational temperature of the chip? Should i be concerned ( plastic burn smell..) about the temperatures?

Thanks in advance.

Link to comment
Share on other sites

Got it working.

ifconfig wlan1 down

iw reg set IT

ifconfig wlan1 up

Since Italy allows only 20 dbm transmit power, when the interface comes back up its at 20 dbm. I'll test temps now.

Edit: temps are 5 degrees cooler (45) but wash doesn't seem to work correctly with the new regulatory domain.. airodump works fine though.

Maybe Seb or Darren want to hop in and tell us what they think about these temps :)

Edited by wolfdale
Link to comment
Share on other sites

wolfdale,



This is how I do it:



1) Connect to your Pineapple via ethernet cable or WiFi



2) SSH into your Pineapple - "ssh root@172.16.42.1"



3) Put wlan1 down - "ifconfig wlan1 down"



4) Set the region to United States - "iw reg set US"



5) Confirm that the region was changed - "iw reg get"



Note: You should see "Country US:"



6) Set wlan1's TX-Power to 20dBm or whatever power level you want - "iwconfig wlan1 txpower 20dBm"



7) Put wlan1 up - "ifconfig wlan1 up"



8) Now confirm the TX-Power change - "iwconfig wlan1"


Edited by chriswhat
Link to comment
Share on other sites

Yes, those are the exact steps that I take on my Mk V, and I never have any issues. Not sure why you're having a problem. Make sure wlan1 isn't associated with any access points.

ifconfig wlan1 down
dhclient -r wlan1 

Then complete the steps I gave you above.

Link to comment
Share on other sites

Question are you using

iwconfig wlan1 txpower 20

or

iwconfig wlan1 txpower 20dBm

the dBm part is important...

Yeah i specified dBm. I used to do these same steps on my alfa

Yes, those are the exact steps that I take on my Mk V, and I never have any issues. Not sure why you're having a problem. Make sure wlan1 isn't associated with any access points.

ifconfig wlan1 down
dhclient -r wlan1 

Then complete the steps I gave you above.

I get can't find dhclient. I even did a reset of the pineapple today, and still nothing. I'm on firmware version 1.0.1, maybe thats the cause?

Yes, the rtl does get very hot. But it's rated fine for even higher temperatures, so nothing to worry about.

Thanks thats a bit reassuring :)

Edited by wolfdale
Link to comment
Share on other sites

I did

nano /etc/config/wireless

And added the line

option txpower '20'

To wlan0. I also added the line to wlan1 and wlan2 for '22'. wlan1 is the only one that will change. wlan0 and wlan2 (my Alfa) both remained 18 and 27dBm.

I haven't had much luck at all getting tX power to change with the pineapple. I've also tried the process of taking a radio down, changing txpower (with dBm) radio up, and no luck. I tried lots of different numbers. (before I made the changes to the config)

Link to comment
Share on other sites

  • 2 months later...

Little update on the topic. I know it's probably not neeed but I added a little RAM heatsink on the chip, and now it's not even warm to the touch!

Now it looks really cool :D

http://it.tinypic.com/r/dcgbyo/5

Very "cool" wolfdale........pun intended.

Great mod.........Thanks....

I need to go find a few heatsinks, no need to up my tx power, but one would think being cooler would extend the life of the product.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...