Jump to content

Format SD doesnt actaully format SD?


Geoff0ne
 Share

Recommended Posts

Reboot and try again. We have an issue with the USB driver for the SD that sometimes causes issues on remount and therefore formatting.

You can however ssh into the pineapple and use fdisk to format the device and then run mkfs.ext4 /dev/sdaX to format ext4 etc.

Link to comment
Share on other sites

Hi guys,

I'm also experiencing some issues with the SD card on the device. It works fine for sometime after the card is formatted in ext3, but after 5 hours the SD card is not longer detected, even if I reboot the machine, when I tried to re-mount the card I have the following error message:

root@Pineapple:~# mount /dev/sda1
mount: mounting /dev/sda1 on /sd failed: Invalid argument

When i tried to re-create the partition I have this error message.

Last cylinder or +size or +sizeM or +sizeK (1-1007, default 1007): Using default value 1007

Command (m for help): w
The partition table has been altered.
Calling ioctl() to re-read partition table
fdisk: WARNING: rereading partition table failed, kernel still uses old table: Invalid argument

Any help or tip is going to be very appreciated.

-----------------------------

This has been solved, I realize that I was using a partition (sda1) and not the whole disk. (sda).

Edited by m0r4g0n
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...