Jump to content

Fawk@#@$ no connection STILL


keyzer
 Share

Recommended Posts

I am on a linux box and the wp5 script "seems" to run fine, but I still cannot connect my Pineapple to the internet. The host computer coonnecting on wlan0 still has a connection. Any ideas?? I've spent three hours looking at posts and nothing says anything different than what I've done. I've tried 172.16.42.42 as the IP of eth0 on the host, and that set as the gateway, I've tried the wlan0 working router of 10.0.0.1 as the gateway. Nothing works to get out for the pineapple even thought he wp5.sh throws no errors when I set the gateway to t my wlan0 host computers router.... Connecting to the pineapple via ssh/http isn't a problem, so it is all gateway related. Thanks for any help

Pineapple interfaces:

==============

br-lan Link encap:Ethernet HWaddr 00:13:37:A5:0B:2A
inet addr:172.16.42.1 Bcast:172.16.42.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:149013 errors:0 dropped:272 overruns:0 frame:0
TX packets:115358 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:14105986 (13.4 MiB) TX bytes:13579368 (12.9 MiB)
eth0 Link encap:Ethernet HWaddr 00:13:37:A5:0B:2A
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:131814 errors:0 dropped:0 overruns:0 frame:0
TX packets:125607 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:15238005 (14.5 MiB) TX bytes:13983933 (13.3 MiB)
Interrupt:4
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:30678 errors:0 dropped:0 overruns:0 frame:0
TX packets:30678 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2473003 (2.3 MiB) TX bytes:2473003 (2.3 MiB)
wlan0 Link encap:Ethernet HWaddr 00:13:37:A5:0B:2A
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:17208 errors:0 dropped:0 overruns:0 frame:0
TX packets:13636 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:954607 (932.2 KiB) TX bytes:1035178 (1010.9 KiB)
Pineapple Route
=================
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
172.16.42.0 * 255.255.255.0 U 0 0 0 br-lan
host computer interface
=====================
eth0 Link encap:Ethernet HWaddr 00:90:f5:d9:3a:31
inet addr:172.16.42.245 Bcast:172.16.42.255 Mask:255.255.255.0
inet6 addr: fe80::290:f5ff:fed9:3a31/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1041 errors:0 dropped:0 overruns:0 frame:0
TX packets:1088 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:117712 (117.7 KB) TX bytes:126886 (126.8 KB)
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:384 errors:0 dropped:0 overruns:0 frame:0
TX packets:384 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:30224 (30.2 KB) TX bytes:30224 (30.2 KB)
vmnet1 Link encap:Ethernet HWaddr 00:50:56:c0:00:01
inet addr:10.0.1.1 Bcast:10.0.1.255 Mask:255.255.255.0
inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:67 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
wlan0 Link encap:Ethernet HWaddr c8:f7:33:0d:55:34
inet addr:10.0.0.18 Bcast:10.0.0.255 Mask:255.255.255.0
inet6 addr: 2601:a:4980:3f8:fdcf:1190:3638:3a78/64 Scope:Global
inet6 addr: fe80::caf7:33ff:fe0d:5534/64 Scope:Link
inet6 addr: 2601:a:4980:3f8:caf7:33ff:fe0d:5534/64 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:937 errors:0 dropped:0 overruns:0 frame:0
TX packets:890 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:571968 (571.9 KB) TX bytes:200458 (200.4 KB)
Link to comment
Share on other sites

Where's your wlan1 and why are you even using the script? Is there some particular reason you want to hook up using the eth0 port? The new paradigm with the Mark 5 is to use wlan1 for Client Mode and have it connect to your internet enabled AP. I'm not saying you can't use the script but if you haven't even tried the new way you're causing yourself the headache...

Link to comment
Share on other sites

Valid question... It just hangs at "Connection initiated" on my WPA2 access point which is just the standard Comcast router, I had disabled the interface. No idea what the problem is... That signal is -36dBm and 70/70 for quality.

Hi there, I had a similiar problem, I guess. In my case, using wpa2 on my airport extreme, the problem was my AP passphrase. It was 24 characters long and I reduced it to 10. All worked fine after that. Still wonder why...hope that helps

Link to comment
Share on other sites

host computer interface
=====================
eth0 Link encap:Ethernet HWaddr 00:90:f5:d9:3a:31
inet addr:172.16.42.245 Bcast:172.16.42.255 Mask:255.255.255.0
inet6 addr: fe80::290:f5ff:fed9:3a31/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1041 errors:0 dropped:0 overruns:0 frame:0
TX packets:1088 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:117712 (117.7 KB) TX bytes:126886 (126.8 KB)
wlan0 Link encap:Ethernet HWaddr c8:f7:33:0d:55:34
inet addr:10.0.0.18 Bcast:10.0.0.255 Mask:255.255.255.0
inet6 addr: 2601:a:4980:3f8:fdcf:1190:3638:3a78/64 Scope:Global
inet6 addr: fe80::caf7:33ff:fe0d:5534/64 Scope:Link
inet6 addr: 2601:a:4980:3f8:caf7:33ff:fe0d:5534/64 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:937 errors:0 dropped:0 overruns:0 frame:0
TX packets:890 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:571968 (571.9 KB) TX bytes:200458 (200.4 KB)

You need to manually set your eth0 to 172.16.42.42 for your script to work. Also turn off any network managers, or you'll lose your connection later on when it does a dhcp renew.

Where's your wlan1 and why are you even using the script? Is there some particular reason you want to hook up using the eth0 port? The new paradigm with the Mark 5 is to use wlan1 for Client Mode and have it connect to your internet enabled AP. I'm not saying you can't use the script but if you haven't even tried the new way you're causing yourself the headache...

I still use the wp4.sh script. I don't really want to set up a testing wifi network at the moment, and my test network is completely seperated from my home network.

Edited by barry99705
Link to comment
Share on other sites

See, now that is a valid reason. But I question folks when they show up and it appears that they are just trying to do things the old Mrk4 way. I'm not saying the script won't work… just saying it's not the normal way to hook things up these days.

Link to comment
Share on other sites

Hrmph, I have tried it with a static *.42, or a dhcp address which is always *.245. Neither prevent me from having a connection to the Pineapple, it's getting out the gateway that isn't happening. That's really weird that the passphrase lengthy seemed to do that. Upgrading to 1.0.1 right now, fingers crossed. Thanks for all the ideas guys.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...