Jump to content

Cannot input option in Serial flash


Soviet
 Share

Recommended Posts

Can't input option while flashing through serial.

Flow control is off. Speed is set to 115200. Pairity none. 8 bits. 1 stop bit.

here is copy paste log from console


U-Boot 1.1.4-g971cc15e-dirty (Sep  7 2011 - 11:44:55)

AP121-8MB (ar9331) U-boot
DRAM:  32 MB
Top of RAM usable for U-Boot at: 82000000
Reserving 248k for U-Boot at: 81fc0000
Reserving 192k for malloc() at: 81f90000
Reserving 44 Bytes for Board Info at: 81f8ffd4
Reserving 36 Bytes for Global Data at: 81f8ffb0
Reserving 128k for boot params() at: 81f6ffb0
Stack Pointer at: 81f6ff98
Now running in RAM - U-Boot at: 81fc0000
id read 0x100000ff
flash size 8388608, sector count = 128
Flash:  8 MB
In:    serial
Out:   serial
Err:   serial
Net:   ag7240_enet_initialize...
Fetching MAC Address from 0x81feb688
Fetching MAC Address from 0x81feb688
: cfg1 0x5 cfg2 0x7114
eth0: 00:c0:ca:64:7e:b1
eth0 up
: cfg1 0xf cfg2 0x7214
eth1: 00:c0:ca:64:7e:b0
athrs26_reg_init_lan
ATHRS26: resetting s26
ATHRS26: s26 reset done
eth1 up
eth0, eth1

Please choose the operation:
   1: Entr boot command line interface.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).                                   0


 System Boot system code via Flash.
## Booting image at 9f650000 ...
   Image Name:   MIPS OpenWrt Linux-3.3.8
   Created:      2012-09-01  20:27:49 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    907254 Bytes = 886 kB
   Load Address: 80060000
   Entry Point:  80060000
   Verifying Checksum at 0x9f650040 ...OK
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 80060000) ...
## Giving linux memsize in bytes, 33554432

Starting kernel ...

[    0.000000] Linux version 3.3.8 (sebkinne@ubuntu) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #49 Sat Sep 1 16:27:13 EDT 2012
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR9330 rev 1
[    0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone PFN ranges:
[    0.000000]   Normal   0x00000000 -> 0x00002000
[    0.000000] Movable zone start PFN for each node
[    0.000000] Early memory PFN ranges

...

[   12.770000] jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x004e001c: 0x89d9 instead
[   12.770000] jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x004e0020: 0x2778 instead
[   12.780000] jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x004e0024: 0xf884 instead
[   12.790000] Further such events for this erase block will not be printed
[   12.870000] JFFS2 notice: (1) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 8 of xref (0 dead, 0 orphan) found.
[   12.890000] VFS: Mounted root (jffs2 filesystem) readonly on device 31:2.
[   12.890000] Freeing unused kernel memory: 204k freed
[   12.900000] Kernel panic - not syncing: No init found.  Try passing init= option to kernel. See Linux Documentation/init.txt for guidance.

Tried in both linux and windows. Putty on windows and minicom on linux. Tried flow control on and off. Using this USB to UART TTL.

Any help would be appreciated.

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...