Jump to content

reboot = lost all infusions on sd card


Mit0s1s
 Share

Recommended Posts

had everything working pretty awesome, shut down for couple hours, then came back and fired it up, but all the infusions that I had installed to sd card were gone. they showed up in the installed section in the bar but had nothing displayed for installed size. ssh'd in and they were not in the infusion folder in /sd. I tried uninstalling them and reinstalling them through the pineapple bar but can't install anything to the sd card, only to internal storage. factory reset and still same thing, can only install to internal storage. if I try to install to sd card it just sits at 0% and does not move.

Link to comment
Share on other sites

I have had the same problem.

Tried to reformat my sd card with gparted then and my card couldn't even been detected.

It took me a few attemps to format it again with my pineapple and now all is working fine again. have no idea what happened there.

keep trying!

Link to comment
Share on other sites

For some reason I had the idea that the "internal storage" was actually just another partition on the sd card so I didn't want to wipe it untill I had to. Now I know that internal is actually on board storage, awesome! So I just reformated from within the pineapple and all is well. Good job guys making things easy for us.

Link to comment
Share on other sites

I've seen this as well…. Try popping out the SD card while the pineapple is running. Plug it back in then reboot. When this happens reformatting is not needed. They will still be on the sd card, or at least mine stayed in place. I'm curious if you guys experiencing this problem are running the stock 2Gig SD cards or bigger ones (32Gig) like I am… I'm not sure if this has anything to do with it or not but I've switched to a different power supply, just waiting to see if the infusion tiles disappear again. If they do, I'll switch back and assume it's in the pineapple.

Link to comment
Share on other sites

I had similar issues with my SD card. Formatting would fix it temporarily, but usually by the next day (hard to say how long) something would be funky again. I ended up swapping out the stock 2gb for a spare 4gb that I had laying around, and as far as I can tell it's been smoother sailing since.

Note also (and maybe everyone knows this) - if you notice some infusions not running that you thought were installed - and you load up the list of Infusions and some of them don't display their size or version number correctly, - CHECK the "Available Infusions" tab for any infusion updates. The Pineapple Bar Tile only shows system updates (AFAIK). If there's an infusion update ready the "install" link will change to something like "update".

Link to comment
Share on other sites

  • 2 weeks later...

I am also having this issue with the mark V

I have tried multiple sd cards of different brands.

formatted via pa ui.

This makes my pineapple very unstable, and autostarts on infusions useless since i have all the data on the sdcard.

Filesystem                Size      Used Available Use% Mounted onrootfs                    4.3M      2.0M      2.3M  47% //dev/root                10.8M     10.8M         0 100% /romtmpfs                    30.2M    116.0K     30.1M   0% /tmptmpfs                   512.0K         0    512.0K   0% /dev/dev/mtdblock3            4.3M      2.0M      2.3M  47% /overlayoverlayfs:/overlay        4.3M      2.0M      2.3M  47% //dev/sdb1                28.7G    564.2M     26.7G   2% /mnt/sdb1

It is mounted, but after a reboot the infusions wont work.

The only thing to make it work is to format again and factory settings, doing everything all over.

sometimes it can work for a brief time if i pop out the sd and put it back in, but in the end it will always fail after some time.

everything seems ok when i ssh into the box.

Anyone found any solution to this ?

Link to comment
Share on other sites

NOTE: This is NOT needed in 1.0.4 anymore and could harm your device.

For anyone having issues with the SD card not mounting to /sd because it shows up as /dev/sdb, please follow the instructions below. Please note that this is just a fix for anyone having issues, a real fix in terms of USB drivers is coming soon. Bear with us on that one.

//make sure to have a working internet connection on your pineapple. Otherwise you will be left without the mount command.

//remove the old mount utils by busybox
rm /bin/mount
rm /bin/umount

//Install the new mount utils with UUID support
opkg update
opkg install mount-utils

Now that you have the new mount installed, run the "blkid" command. The output should look something like this:

root@Pineapple:~# blkid
/dev/mtdblock2: TYPE="squashfs" 
/dev/sda1: UUID="bfeae94e-79bd-4ed4-af0d-eed86f666df9" TYPE="ext4" 

Make note of that UUID.

Now, edit the file /etc/config/fstab and remove the entire "mount" section. It should contain references to sda1 and /sd.

Also edit the /etc/fstab file and remove the line that references /sd and sda1.

Once you have done that, simply edit your /etc/rc.local file and add the following line:

mount UUID=bfeae94e-79bd-4ed4-af0d-eed86f666df9 /sd

Make sure you swap my UUID for yours found in the previous step.

Save the /etc/rc.local file and reboot. You should now have access to everything, no matter if your device is sda, sdb, sdc etc.

Remember, this is a temporary fix. While UUID mounting is great, it is a bit flaky to automate the process for our users. That is why we are modifying the USB drivers to prevent this from being needed.

Best Regards,

Sebkinne

Link to comment
Share on other sites

  • 2 months later...

Hi i got same problem but i dont get UUID

root@Pineapple:~# rm /bin/mount
root@Pineapple:~# rm /bin/unmount
rm: can't remove '/bin/unmount': No such file or directory
root@Pineapple:~# rm /bin/umount
root@Pineapple:~# opkg update
Downloading http://cloud.wifipineapple.com/mk5/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/pineapple_packages.
root@Pineapple:~# opkg install mount-utils
Installing mount-utils (2.21.2-1) to root...
Downloading http://cloud.wifipineapple.com/mk5/packages/mount-utils_2.21.2-1_ar71xx.ipk.
Installing libmount (2.21.2-1) to root...
Downloading http://cloud.wifipineapple.com/mk5/packages/libmount_2.21.2-1_ar71xx.ipk.
Configuring libmount.
Configuring mount-utils.
root@Pineapple:~# blkid
/dev/mtdblock2: TYPE="squashfs"
root@Pineapple:~#

Is that menas my sd card is dead?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...