Jump to content

[Support] Occupineapple


Recommended Posts

I'm enjoying playing with my Mark V, and I infused it with Occupineapple, only to get the error

mdk3 not installed

I tried installing it using SSH with some instructions I found on the wonderful world of google, but the message came up that it was already installed... which seemed odd given the error message.

root@Pineapple:~# opkg install mdk3
Package mdk3 (v6-1) installed in sd is up to date.

Is Occupineapple not working on the V?

Or it just by noobie-freshness causing issues?

Edited by Tommo
Link to comment
Share on other sites

It's actually super simple. Click on the title of the small tile to view the Large Tile for occupineapple.

Then in there you should have a link to install mdk3, either to internal storage or USB. (I've noticed there's no option for the SD card just yet, so I've used internal storage...)

Once that's done, the tile should refresh with all the occupineapple goodness.

Link to comment
Share on other sites

I got this working in the end, I've responded to the comment on my blog here: https://scotthelme.co.uk/wifi-pineapple-occupineapple/#comment-1097547220

Via SSH:

root@Pineapple:/# opkg remove mdk3
Removing package mdk3 from sd...

After this, refresh your web interface, open the occupineapple infusion and install mdk3 to local storage. Once that's done, select the SSID list you want and hit Start.

mdk3 is running with list SSID_with_MAC.mlist...

Link to comment
Share on other sites

  • 8 months later...

ok so I'm having a problem with Occupineapple and I've tried using nano as has been suggested to me but it hasn't helped no matter what I do when I start Occupineapple it says it's using list: Random and I don't even have a list random I've set it to other lists but to no avail and this is really getting frustrating any help would be much apreciated


Link to comment
Share on other sites

  • 2 weeks later...

I've been tinkering for days and love the pineapple.

But for some reason I can't correctly get occupinapple to correctly boot up from an assigned dip switch.

Can somebody suggest the correct command sequence to assign a dip switch to boot occupinapple infusion with certain list?

I'm a newbie but have read through everything i can find.

Link to comment
Share on other sites

  • 5 months later...

Updated to firmware 2.2.0 WFP MKV and when I use Occupinapple, it works....sort of.

It does broadcast a variety of SSIDs as it should, but it then essentially locks up wifi. It continues to broadcast but wifi is now unusable. If I set Occupinapple to WLAN0, it works, but then my wifi pineapple SSID (my legit one) disappears completely and drops my connection, but it continues to broadcast the phony SSIDs. Then I can not login to turn it off without either using eth0, or rebooting.

So...I tried WLAN1 instead...it works as it should...and continues to broadcast my legit SSID, I can connect, but the WIFI is unusable...I can not contact anything via wifi...no internet, not even the pineapple to turn off Occupinapple.

So it seems, Occupineapple is only useful if you don't mind losing your wifi connection, or control it entirely from eth0. Is this correct, or am I doing something wrong?

Link to comment
Share on other sites

  • 2 months later...
  • 6 months later...


After seting and selecting lists in occupineaplle, it shows unreadable caracters on SSIDs names broadcasted.

I have checked the .list file with nano, everything looks fine.

Pineapple MARK V

Firmware 2.4.0

Occupineapple 1.9

Thanks for help.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...