Jump to content

Network & AutoSSH Issues


chriswhat
 Share

Recommended Posts

I'm having some issues that began immediately after performing a factory reset. My issues pertain primarily to connectivity, client mode, and AutoSSH.

Connectivity issues:

1) I cannot connect to my Pineapple AP when I use my Alfa AWUS036NHA (ar9271) USB network adapter with Kali Linux; however, I am able to connect with my Netgear (rtl8187) USB network adapter with Kali Linux. I'm also able to connect with my MacBook Pro, MacBook, and iMac's built-in network adapters. Only when trying to connect with my Alfa, I receive the error- "Unable to obtain an IP address." I've rebooted Kali, rebooted the Pineapple, factory reset the Pineapple, enabled/disabled the radios, changed my Alfa's MAC, and various other things.

2) Prior to performing the first factory reset, I did not have any problems with client mode. After the reset, however, I had the following problems:

As soon as I'd use client mode, wlan0 would stop broadcasting permanently and wlan1 would not connect to the wireless network that I selected. To get wlan0 up again, I had to perform a factory reset. Eventually I found that both radios had the same MAC address, so I changed the MACs (in /etc/config/wireless) and the radios began to function again. Now the issue is that all of my Pineapple clients, with the exception of Mac OS X clients (VERY STRANGE), are disconnected immediately after enabling client mode.

Issues with AutoSSH:

1) AutoSSH doesn't start on boot or remain persistent

2) If I manually use client mode to connect to a network after a fresh reboot, AutoSSH will not connect to my server although it indicates that it's connected. To get AutoSSH working, here's the procedure that I have to perform:

a- Use the client mode tab to connect to the wireless network that I need for internet

b- Reboot the Pineapple

c- The Pineapple will automatically enable client mode and reconnect to the wireless network that I connected to prior to reboot.

d- Click Connect in the AutoSSH tile

This gets me connected to my server. However, when managing the Pineapple remotely, I depend on AutoSSH to start on boot and automatically connect after switching between networks in client mode.

These issues are very frustrating. Insight is appreciated. Thanks.

Edited by chriswhat
Link to comment
Share on other sites

1: If everything else is working it's probably not a Pineapple issue. Most like a Kali problem. Try BT5r3 with that Alfa and see what happens.

2: I'm noticing a trend of people having issues with wireless after a factory reset. It seems to swap the antennas sometimes. If you post your wireless file I can tell if they are set correctly.

3: Your Auto SSH issue may be tied to number 2.

Link to comment
Share on other sites

1: If everything else is working it's probably not a Pineapple issue. Most like a Kali problem. Try BT5r3 with that Alfa and see what happens.

2: I'm noticing a trend of people having issues with wireless after a factory reset. It seems to swap the antennas sometimes. If you post your wireless file I can tell if they are set correctly.

3: Your Auto SSH issue may be tied to number 2.

thesugarat,

Thanks for your response. I've noticed that lots of people are have wireless issues as well.

1: I've already tried what you suggested but I haven't been able to determine that the OS is a factor. It seems to be a conflict strictly between the Pineapple and my Alfa adapter because I receive the same results when I try connecting from BT5 R3. When using my Alfa, I can connect to other networks but not the Pineapple. When using my Netgear adapter (with Kali and BT5), I can connect to the Pineapple and other networks.

2: I've already adjusted my wireless file to reflect the correct MAC addresses but I could be overlooking another issue.

Here are the contents of my /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11ng'
        option macaddr '00:13:37:xx:xx:xx'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '0'

config wifi-iface
        option device 'radio0'
        option hidden '0'
        option ssid 'Pineapple5'
        option mode 'ap'
        option network 'lan'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option macaddr '00:13:37:xx:xx:xx'
        option disabled '0'

config wifi-iface
        option device 'radio1'
        option mode 'sta'
        option hidden '1'
        option network 'wan'
        option ssid 'HackDroid'

As shown, I'm currently connecting to an unencrypted network. If I connect to an encrypted network, "option encryption" is added near the bottom of the wireless file as expected.

I've hidden the seond half of my MAC addresses for security purposes, but the second half of each MAC is different.

Also, I've elminiated power issues because I'm connected to the wall, not battery. Same results when connected to the battery.

Link to comment
Share on other sites

Only three things looked funny for wlan1... Channel was the same for both radios... added encryption line and isn't the 'option hidden' n/a for Client mode? You could try the following...

config wifi-device 'radio1'
option type 'mac80211'
option channel '6'
option hwmode '11g'
option macaddr '00:13:37:xx:xx:xx'

option disabled '0'

config wifi-iface
option device
'radio1'
option mode 'sta'
option hidden '0'
option network 'wan'
option ssid 'HackDroid'

option encryption 'none'

Link to comment
Share on other sites

Only three things looked funny for wlan1... Channel was the same for both radios... added encryption line and isn't the 'option hidden' n/a for Client mode? You could try the following...

...

thesugarat,

I appreciate the help.

I see what you're saying. "option hidden" should be irrelevant to radio1 since I'm using it for client mode. Although it doesn't broadcast (as intended) when "option hidden" is set to '0' I'll try setting "option hidden" to '1' just to see what happens. Then, maybe I'll try completely removing "option hidden".

Isn't "option encryption 'none'" equivalent to not specifying "option encryption" at all?

I'll try setting radio1 to channel 6, but I don't think it should be causing a conflict.

Link to comment
Share on other sites

You already had option hidden set to 1 on wlan1 which is enabled.... right? It's Friday afternoon my brain is fried. I just thought turning it off or 0 might do something... And I have no clue on the encryption line. I've seen it set to none in other configs. Again, just throwing out some options to try. I'm not at home and can't test it for myself.

Link to comment
Share on other sites

You already had option hidden set to 1 on wlan1 which is enabled.... right? It's Friday afternoon my brain is fried. I just thought turning it off or 0 might do something... And I have no clue on the encryption line. I've seen it set to none in other configs. Again, just throwing out some options to try. I'm not at home and can't test it for myself.

Sorry, too many 1's and 0's bouncing around my head right now. I meant to say I'll change "option hidden" to '0' since it's already set at '1'. Again, I appreciate the ideas. Really regretting that initial factory reset.

Link to comment
Share on other sites

  • 2 weeks later...

I'm having some issues that began immediately after performing a factory reset. My issues pertain primarily to connectivity, client mode, and AutoSSH.

Connectivity issues:

1) I cannot connect to my Pineapple AP when I use my Alfa AWUS036NHA (ar9271) USB network adapter with Kali Linux; however, I am able to connect with my Netgear (rtl8187) USB network adapter with Kali Linux. I'm also able to connect with my MacBook Pro, MacBook, and iMac's built-in network adapters. Only when trying to connect with my Alfa, I receive the error- "Unable to obtain an IP address." I've rebooted Kali, rebooted the Pineapple, factory reset the Pineapple, enabled/disabled the radios, changed my Alfa's MAC, and various other things.

2) Prior to performing the first factory reset, I did not have any problems with client mode. After the reset, however, I had the following problems:

As soon as I'd use client mode, wlan0 would stop broadcasting permanently and wlan1 would not connect to the wireless network that I selected. To get wlan0 up again, I had to perform a factory reset. Eventually I found that both radios had the same MAC address, so I changed the MACs (in /etc/config/wireless) and the radios began to function again. Now the issue is that all of my Pineapple clients, with the exception of Mac OS X clients (VERY STRANGE), are disconnected immediately after enabling client mode.

Issues with AutoSSH:

1) AutoSSH doesn't start on boot or remain persistent

2) If I manually use client mode to connect to a network after a fresh reboot, AutoSSH will not connect to my server although it indicates that it's connected. To get AutoSSH working, here's the procedure that I have to perform:

a- Use the client mode tab to connect to the wireless network that I need for internet

b- Reboot the Pineapple

c- The Pineapple will automatically enable client mode and reconnect to the wireless network that I connected to prior to reboot.

d- Click Connect in the AutoSSH tile

This gets me connected to my server. However, when managing the Pineapple remotely, I depend on AutoSSH to start on boot and automatically connect after switching between networks in client mode.

These issues are very frustrating. Insight is appreciated. Thanks.

I have about the same thing going on with AutoSSH. Did you ever work out a fix? I'm also having really slow throughput. My browsers either drag ass or crash.

Link to comment
Share on other sites

I have about the same thing going on with AutoSSH. Did you ever work out a fix? I'm also having really slow throughput. My browsers either drag ass or crash.

I manually configured my autossh file and then restarted SSH. I also made some correction to my wireless file. Now, my Pineapple auto connects to my server on boot. Are you having problems with client mode as well? Or just autossh?

Link to comment
Share on other sites

Just did a factory reset fro the first time and... not good!

Same issues as @chriswhat.

wlan0 disables immediately when i try connecting to wifi with wlan1, and wlan1 never ends up connecting.

I have to do a factory reset again to get wlan0 to broadcast again.

Ssh, of course, can't login.

How did you fix your problem.

Link to comment
Share on other sites

I manually configured my autossh file and then restarted SSH. I also made some correction to my wireless file. Now, my Pineapple auto connects to my server on boot. Are you having problems with client mode as well? Or just autossh?

Just AutoSSH so far. wlan1 connects to my AP with the setting in the wifi manager infusion.

Incidentally, My first attempt to fix autossh was putting a script together to just start the tunnel and throw it in a cronjob. However after SCPing the file in and changing permissions, the terminal returns a file not found error. Needless to say cron wont run it either.

So i shifted to try and figure out WTF with the script.

LOL this is exactly why we buy these though. I haven't touched Battlefield 4 all weekend :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...