Jump to content

Wlan1 will not enable, no red LED


ScottHelme
 Share

Recommended Posts

I have similar issues right now also with wlan1. I can get it to come up and I can use it for airmon and air dump via command line, but it will not associate with any wireless network or create a wireless network through the wifi manager infusion. I also get errors where sometimes after reboots wlan1 will not even be a recognized interface.

Link to comment
Share on other sites

I have deleted configs from both wlan0 and 1, saved and commited the changes.

there were a couple of times where I hit auto detect on it because it didn't recognize wlan1 as a radio(but on the "network" tile I could see wlan1 as being enabled, but doing this didnt seem to do anything).

Link to comment
Share on other sites

So to answer your question thesugarat, I have done those things but not necessarily in that order. I should also mention that I did factory reset it today because I had lost wlan1 entirelly for a while after some more testing of features (out of ifconfig, iwconfig, cli and gui.) after factory reset it reappeared on gui and cli

Link to comment
Share on other sites

It seems to have done that. I see both of them as AP and not client and both have the pineappleX_XXXX essid.

After this was completed here is what I tried.

First off I noticed that only the wlan0 Pineapple essid was observable on my 'wireless networks' list from my laptop and phone. So what I did was try to join my home network through client mode(on the pineapple obviously). The pineapple did in fact join my home network, but it joined through the wlan1 interface. Up until this attempt right now, it has never connected via wlan1 and I have never seen the red LED blink for this long. When I would attempt to connect via client mode previously it would always use wlan0. After joining client mode I now see the red LED blinking vigerously.

I used the client tab to join my home network. NOT configure the network parameters in the wifi management tab manually. Once it had successfully joined my home network, the settings were replicated to the wifi management tab. I am not sure if these two tiles are fighting with one another behind the scenes or not.

the clearing and re detecting of the wireless configs has resolved this issue for me thus far. I will do further testing and let you know if I experience anything else concerning this.

The last and final test I performed was rebooting the pineapple one last time and everything came back exactly how it should.

sorry for hijacking your thread buddy! lol

hopefully this helps you out!

Link to comment
Share on other sites

When working on the WPA client fix I noticed that if you use the WiFi Manager infusion and remove/save/commit wlan1 and then use auto detect it created a line in the etc/config/wireless file that needed to be removed in order to reenable it.

Also, the other lines it created didn't have the quotations. Not sure if that mattered but I changed it all to quoted and it worked. It also set wlan1 to its default ssid Pineapple+Mac Address.

Edited by thesugarat
Link to comment
Share on other sites

OK so it's connecting now and I'm getting a red LED :-)

It's showing the IP address as 172.16.42.204 though, should it not be assigned an IP from the DHCP server on my network?

Did you blacklist the MAC of wlan1? Might have pineapple'd yourself. Unless of course your network runs on 172.16.42.0/24 as well...

Link to comment
Share on other sites

I tried the command Mr-Protocol posted and still no luck, when in the client mode tab of the network tile, i can see my pineapples SSID as an option to connect to whitch leads me to believe its using wlan1, but when i try to connect to my home SSID, the wlan0 blue light shuts off and comes back on and it says connection established when clearly its not.

Here is my /etc/config/wireless

config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11ng
option macaddr 00:13:37:a5:08:73
option htmode HT20
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
# option disabled 1

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid Pineapple5_0873
option encryption none

config wifi-device radio1
option type mac80211
option channel 11
option hwmode 11g
option macaddr 00:13:37:81:42:73

# REMOVE THIS LINE TO ENABLE WIFI:
# option disabled 1

config wifi-iface
option device radio1
option network lan
option mode ap
option ssid Pineapple5_4273
option encryption none

Edited by BOOB00
Link to comment
Share on other sites

BOOB00,

That's the kind of output I got when I removed wlan1 via the WiFi Manager infusion. I had to clean it up a bit then to make it work… Here's how I think yours should look.

config wifi-device 'radio0'


option type 'mac80211'


 option channel '11'


option hwmode '11ng'


option macaddr '00:13:37:a5:08:73'


option htmode 'HT20'


list ht_capab 'SHORT-GI-20'


list ht_capab 'SHORT-GI-40'


 list ht_capab 'RX-STBC1'


 list ht_capab 'DSSS_CCK-40'


 option disabled '0'



config wifi-iface


 option device 'radio0'


 option network 'lan'


option mode 'ap'


option ssid 'Pineapple5_0873'


option encryption 'none'



config wifi-device 'radio1'


 option type 'mac80211'


 option channel '11'


option hwmode '11g'


option macaddr '00:13:37:81:42:73'


 option disabled '0'





config wifi-iface


 option device 'radio1'


option network 'wan'


 option mode 'sta'


option ssid 'Pineapple5_4273'


 option encryption 'none'

Edited by thesugarat
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...