Jump to content

Recommended Posts

  • Replies 159
  • Created
  • Last Reply

Top Posters In This Topic

ExigentCircumstance, I'm not sure if you know how forums work, but you totally posted in the wrong section. Please review all the threads to post in the correct spot.

I think what leg3nd said may be true with module developers using /usb instead of /sd. A quick test would be plug in a properly formatted USB flash drive and try installing to that.

What are the parameters for a properly formatted usb using Linux.

Link to comment
Share on other sites

WORKING! :D

#1 Install Sslstrip in pineapple bar

#2 SSH into the pineapple and do opkg remove sslstrip

#3 Then do opkg install sslstrip --dest sd

#4 Then do opkg install sslstrip --dest sd again to see if its installed and all done :)
A good test site is http://www.mpgh.net/ login and see if you get info in sslstrip

Also like my post if this worked for you please and thanks :)

291cbaq.jpg

Edited by mrgray
Link to comment
Share on other sites

Traceback (most recent call last):

File "/sd/usr/bin/sslstrip", line 27, in <module>

from twisted.web import http

ImportError: No module named web


Thats what i get after the update... :-(



OK I had to remove and install twisted-web again.

Now its running like it should!

Thanx Wistlemaster and midnitesnake

Edited by Tlows
Link to comment
Share on other sites

Are you talking about replacing the current log destination directory with a symlink to a similarly named log directory on the sd card. So that when sslstrip believe it's writing to the original log location it's actually writing to the sd card... I'm guessing you installed sslstrip to internal not to the SD card? That might work. Or a maybe a cron job?

Link to comment
Share on other sites

Yes. I installed it internal and when I tried to remove and re-install it went back to internal. I noticed if you do verbose they get big quick. And I have this space over on the SD card I would prefer to use. SO if I used a SYMLink then as it writes it would actually be writing to the SD card verses internal.

Link to comment
Share on other sites

In 1.0.1 I'm just going to have to wait for the cleanup script Seb is working on. I've messed with it enough that I can get it to start (and collect info) but I can't get it to stop and it only allows traffic through to https sites. All common issues before the firmware update.. but none of the fixes used before has worked so far. A reboot sets everything back to normal routing.

Link to comment
Share on other sites

Is there a reason that sslstrip version 0.6 is installed instead of version 0.9? Did anyone try to update this?

Already found out myself. Version 0.9 can be used:

opkg update
opkg install pyopenssl
wget http://www.thoughtcrime.org/software/sslstrip/sslstrip-0.9.tar.gz -O /sd/sslstrip-0.9.tar.gz
cd /sd
tar zxvf sslstrip-0.9.tar.gz
cd sslstrip-0.9
python ./setup.py install

Install the sslstrip infusion (1.4) after this. Sslstrip will then run with version 0.9 instead of 0.6 from the Web UI.

Link to comment
Share on other sites

  • 2 weeks later...

when given a variety of data from different clients! would not it be great to be able to email the file when it has reached a certain size!!

I thought as a possible proposal for an addition!

Link to comment
Share on other sites

First off the infusion is working great, but... It only strips traffic connected to the pineapple. When I connect the pineapple to a wireless network on wlan1 and run the infusion nothing shows up in the logs. I'm guessing the infusion doesn't use ettercap or arpsoof to redirect the traffic? Or is it sslstrip running on the wrong interface? I know I can ssh into the pineapple and do it manually, but I'd really like be able to use the infusion to ssl strip another network. Any help in achieving this would be greatly appreciated.

Edited by zz2Fac3zz
Link to comment
Share on other sites

  • 1 month later...

Having issues with sslstrip....

I've been trying for 2 weeks to get this working, but just being ignorant!

As soon as I start sslstrip, the webpages don't show on first attempt - I have to refresh the page for the page to show... Even this doesn't always work!. sslstrip also sometimes crashes (see capture) I get a line of:

0Q0O0M0K0I0 +

I'm then forced to reboot the pineapple. I find this always happens on twitter.com, and randomly when it feels like it. I also find that when I reinstall the sslstrip infusion, it KIND OF works to begin with, as I have had it work on a couple of ssl sites but then goes all crappy after 5-10 minutes of usage.

Hmmmmm......

post-46072-0-41134900-1389018015_thumb.p

Edited by pabo2uk
Link to comment
Share on other sites

I'm on version 1.0.5. As soon as I start the sslstrip if I try to surf the web, gives "Network Error", weird. Pineapple little slow, but after as couple seconds, it works well.

Great Infusion :)

Edited by qw3rtify
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...