Jump to content

Client Mode Connect to WPA2-Personal Access Point Fails


Oli
 Share

Recommended Posts

I was unable to connect my MKV to a WPA2-Personal access point using the 'Client Mode' page. I could connect to access points with open authentication just fine though...

Are there any known bugs/issues here? The settings in /etc/config/wireless seem fine.

Any ideas / good places to look for clues as to what is causing the problem?

Link to comment
Share on other sites

OK, so now I can't even client mode connect to open networks - even after a 'factory reset'.

Addtionally, even attempting to client mode connect to any network kills the Pineapple5_xxxx access point and it doesn't work again until I do another factory rest.

Something doesn't seem right to me...

Are there any diagnostics I can run to make sure both radios are working properly and/or make sure that a factory reset is working properly?

I tried the WiFi Manager infusion and couldn't get things working either! Is anybody else having issues or is it just me?

Link to comment
Share on other sites

Same here.

MK5 Failed to connect to two different access points / WPA2-PSK

The first access point I tried to connect to was a picostation

The second AP was a mikrotik.

I changed the security on the mikrotik to open, and I was able to connect... ??

I'm not sure what's going on yet, but both my laptop and my cell can connect to these APs, but the RTL8187 failes every single time.

Link to comment
Share on other sites

If you have a micro SD card inserted, try removing it.

I was having a similar problem with client mode. If I insert the micro SD card, wlan1 will not scan for available access points. If I remove the micro SD card, wlan1 will scan and connect fine.

Link to comment
Share on other sites

I don't have my pineapple with me at the moment, but here is the content of the relevant files from a backup I made the other day (with sensitive information changed):

network:

# Copyright (C) 2006 OpenWrt.org

config interface loopback
	option ifname	lo
	option proto	static
	option ipaddr	127.0.0.1
	option netmask	255.0.0.0

config interface lan
	option ifname	eth0
	option type 	bridge
	option proto	static
	option ipaddr	172.16.42.1
	option netmask	255.255.255.0
	option gateway  172.16.42.42
	option dns	8.8.8.8

config interface wan
	option ifname wlan1
	option proto dhcp

config interface usb
	option ifname usb0
	option proto dhcp

config interface wan2
	option ifname ' '
	option proto ' '
	option service ' '
	option device ' '
	option apn ' '
	option username ' '
	option password ' '
	option defaultroute ' '
	option ppp_redial ' '
	option peerdns ' '
	option dns ' '
	option keepalive ' '
	option pppd_options ' '

Wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11ng'
	option macaddr '00:13:37:xx:xx:xx'
	option htmode 'HT20'
	list ht_capab 'SHORT-GI-20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'Pineapple5_xxxx'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option macaddr '00:13:37:xx:xx:xx'

config wifi-iface
	option device 'radio1'
	option mode 'sta'
	option network 'wan'
	option ssid 'hello'
	option key 'world'
	option encryption 'mixed-psk+ccmp'


Edited by Oli
Link to comment
Share on other sites

"cat /etc/config/*" before enabling Client Mode:

config autossh
option ssh '-i /etc/dropbear/id_rsa -N -T -R 2222:localhost:22 user@host'
option gatetime '0'
option monitorport '20000'
option poll '600'

config 'dnsmasq'
option 'domainneeded' '1'
option 'boguspriv' '1'
option 'filterwin2k' '0'
option 'localise_queries' '1'
option 'rebind_protection' '1'
option 'rebind_localhost' '1'
option 'local' '/lan/'
option 'domain' 'lan'
option 'expandhosts' '1'
option 'nonegcache' '0'
option 'authoritative' '1'
option 'readethers' '1'
option 'leasefile' '/tmp/dhcp.leases'
option 'resolvfile' '/tmp/resolv.conf.auto'

config 'dhcp' 'lan'
option 'interface' 'lan'
option 'start' '100'
option 'limit' '150'
option 'leasetime' '12h'
option 'ignore' '0'
list 'dhcp_option' '3,172.16.42.42'
list 'dhcp_option' '3,172.16.42.1'
list 'dhcp_option' '6,172.16.42.1,8.8.8.8'
list 'dhcp_option' '6,172.16.42.1,208.67.222.222'
config dropbear
option PasswordAuth 'on'
option RootPasswordAuth 'on'
option Port '22'
# option BannerFile '/etc/banner'
config defaults
option syn_flood 1
option input ACCEPT
option output ACCEPT
option forward REJECT
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1

config zone
option name lan
option network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT

config zone
option name wan
option network 'wan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
option masq 1
option mtu_fix 1

config zone
option name usb
option network 'usb'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
option masq 1
option mtu_fix 1

config zone
option name wan2
option network 'wan2'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
option masq 1
option mtu_fix 1


config forwarding
option src lan
option dest wan

config forwarding
option src wan
option dest lan

config forwarding
option src lan
option dest usb

config forwarding
option src usb
option dest lan

config forwarding
option src lan
option dest wan2

config forwarding
option src wan2
option dest lan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4

# Allow IPv4 ping
config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
option name Allow-DHCPv6
option src wan
option proto udp
option src_ip fe80::/10
option src_port 547
option dest_ip fe80::/10
option dest_port 546
option family ipv6
option target ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Forward
option src wan
option dest *
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
option limit 1000/sec
option family ipv6
option target ACCEPT

# include a file with users custom iptables rules
config include
option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
# option src lan
# option src_ip 192.168.45.2
# option dest wan
# option proto tcp
# option target REJECT

# block a specific mac on wan
#config rule
# option dest wan
# option src_mac 00:11:22:33:44:66
# option target REJECT

# block incoming ICMP traffic on a zone
#config rule
# option src lan
# option proto ICMP
# option target DROP

# port redirect port coming in on wan to lan
#config redirect
# option src wan
# option src_dport 80
# option dest lan
# option dest_ip 192.168.16.235
# option dest_port 80
# option proto tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
# option src wan
# option src_dport 22001
# option dest lan
# option dest_port 22
# option proto tcp

# allow IPsec/ESP and ISAKMP passthrough
#config rule
# option src wan
# option dest lan
# option protocol esp
# option target ACCEPT

#config rule
# option src wan
# option dest lan
# option src_port 500
# option dest_port 500
# option proto udp
# option target ACCEPT

### FULL CONFIG SECTIONS
#config rule
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 80
# option dest wan
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
# option target REJECT

#config redirect
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 1024
# option src_dport 80
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
config global automount
option from_fstab 1
option anon_mount 1

config global autoswap
option from_fstab 1
option anon_swap 0

config mount
option target /sd
option device /dev/sda1
option fstype auto
option options rw,sync
option enabled 1
option enabled_fsck 0

config swap
option device /dev/sda2
option enabled 1
# Copyright © 2006 OpenWrt.org

config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr 172.16.42.1
option netmask 255.255.255.0
option gateway 172.16.42.42
option dns 8.8.8.8

config interface wan
option ifname wlan1
option proto dhcp

config interface usb
option ifname usb0
option proto dhcp

config interface wan2
option ifname ' '
option proto ' '
option service ' '
option device ' '
option apn ' '
option username ' '
option password ' '
option defaultroute ' '
option ppp_redial ' '
option peerdns ' '
option dns ' '
option keepalive ' '
option pppd_options ' '

config system
option hostname 'Pineapple'
option timezone 'UTC'

config timeserver 'ntp'
list server '0.openwrt.pool.ntp.org'
list server '1.openwrt.pool.ntp.org'
list server '2.openwrt.pool.ntp.org'
list server '3.openwrt.pool.ntp.org'
option enable_server '0'

config led
option name 'ethernet'
option sysfs 'mk5:amber:lan'
option trigger 'netdev'
option dev 'eth0'
option mode 'link tx rx'

config led
option name 'wlan0'
option sysfs 'mk5:blue:wlan0'
option trigger 'netdev'
option dev 'wlan0'
option mode 'link tx rx'

config led
option name 'wlan1'
option sysfs 'mk5:red:wlan1'
option trigger 'netdev'
option dev 'wlan1'
option mode 'link tx rx'

config timeserver
option hostname ptbtime1.ptb.de

config timeserver
option hostname time-a.nist.gov

config timeserver
option hostname ntp.xs4all.nl

config timeserver
option hostname ptbtime2.ptb.de

config timeserver
option hostname time-b.nist.gov
# Server configuration
config uhttpd main

option 'index_page' 'index.php'
option 'error_page' '/index.php'
# HTTP listen addresses, multiple allowed
list listen_http 0.0.0.0:80
# list listen_http [::]:80

# HTTPS listen addresses, multiple allowed
list listen_https 0.0.0.0:443
# list listen_https [::]:443

# Server document root
option home /www

# Reject requests from RFC1918 IP addresses
# directed to the servers public IP(s).
# This is a DNS rebinding countermeasure.
option rfc1918_filter 1

# Certificate and private key for HTTPS.
# If no listen_https addresses are given,
# the key options are ignored.
option cert /etc/uhttpd.crt
option key /etc/uhttpd.key

# CGI url prefix, will be searched in docroot.
# Default is /cgi-bin
option cgi_prefix /cgi-bin

# List of extension->interpreter mappings.
# Files with an associated interpreter can
# be called outside of the CGI prefix and do
# not need to be executable.
list interpreter ".php=/usr/bin/php-cgi"
# list interpreter ".cgi=/usr/bin/perl"


# Lua url prefix and handler script.
# Lua support is disabled if no prefix given.
# option lua_prefix /luci
# option lua_handler /usr/lib/lua/luci/sgi/uhttpd.lua

# CGI/Lua timeout, if the called script does not
# write data within the given amount of seconds,
# the server will terminate the request with
# 504 Gateway Timeout response.
option script_timeout 60

# Network timeout, if the current connection is
# blocked for the specified amount of seconds,
# the server will terminate the associated
# request process.
option network_timeout 30

# TCP Keep-Alive, send periodic keep-alive probes
# over established connections to detect dead peers.
# The value is given in seconds to specify the
# interval between subsequent probes.
# Setting this to 0 will disable TCP keep-alive.
option tcp_keepalive 1

# Basic auth realm, defaults to local hostname
# option realm OpenWrt



# Certificate defaults for px5g key generator
config cert px5g

# Validity time
option days 730

# RSA key size
option bits 1024

# Location
option country DE
option state Berlin
option location Berlin

# Common name
option commonname OpenWrt

config uhttpd pineapple
list listen_http 0.0.0.0:1471
option home /pineapple
option index_page index.php
option 'error_page' '/index.php'

# Configuration file in busybox httpd format
option config /etc/config/httpd.conf
option rfc1918_filter 1

# Certificate and private key for HTTPS.
# If no listen_https addresses are given,
# the key options are ignored.
option cert /etc/uhttpd.crt
option key /etc/uhttpd.key

# CGI url prefix, will be searched in docroot.
# Default is /cgi-bin
option cgi_prefix /cgi-bin

# List of extension->interpreter mappings.
# Files with an associated interpreter can
# be called outside of the CGI prefix and do
# not need to be executable.
list interpreter ".php=/usr/bin/php-cgi"

# CGI/Lua timeout, if the called script does not
# write data within the given amount of seconds,
# the server will terminate the request with
# 504 Gateway Timeout response.
option script_timeout 60

# Network timeout, if the current connection is
# blocked for the specified amount of seconds,
# the server will terminate the associated
# request process.
option network_timeout 30

# TCP Keep-Alive, send periodic keep-alive probes
# over established connections to detect dead peers.
# The value is given in seconds to specify the
# interval between subsequent probes.
# Setting this to 0 will disable TCP keep-alive.
option tcp_keepalive 1

config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11g
option macaddr 00:13:37:xx:xx:xx

# REMOVE THIS LINE TO ENABLE WIFI:
# option disabled 1

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid Pineapple5_4237
option encryption none

config wifi-device radio1
option type mac80211
option channel 11
option hwmode 11ng
option macaddr 00:13:37:xx:xx:xx
option htmode HT20
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
# option disabled 1

config wifi-iface
option device radio1
option network lan
option mode ap
option ssid Pineapple5_0818
option encryption none

"cat /etc/config/*" after trying to enable Client Mode:

config autossh
option ssh '-i /etc/dropbear/id_rsa -N -T -R 2222:localhost:22 user@host'
option gatetime '0'
option monitorport '20000'
option poll '600'

config 'dnsmasq'
option 'domainneeded' '1'
option 'boguspriv' '1'
option 'filterwin2k' '0'
option 'localise_queries' '1'
option 'rebind_protection' '1'
option 'rebind_localhost' '1'
option 'local' '/lan/'
option 'domain' 'lan'
option 'expandhosts' '1'
option 'nonegcache' '0'
option 'authoritative' '1'
option 'readethers' '1'
option 'leasefile' '/tmp/dhcp.leases'
option 'resolvfile' '/tmp/resolv.conf.auto'

config 'dhcp' 'lan'
option 'interface' 'lan'
option 'start' '100'
option 'limit' '150'
option 'leasetime' '12h'
option 'ignore' '0'
list 'dhcp_option' '3,172.16.42.42'
list 'dhcp_option' '3,172.16.42.1'
list 'dhcp_option' '6,172.16.42.1,8.8.8.8'
list 'dhcp_option' '6,172.16.42.1,208.67.222.222'
config dropbear
option PasswordAuth 'on'
option RootPasswordAuth 'on'
option Port '22'
# option BannerFile '/etc/banner'
config defaults
option syn_flood 1
option input ACCEPT
option output ACCEPT
option forward REJECT
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1

config zone
option name lan
option network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT

config zone
option name wan
option network 'wan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
option masq 1
option mtu_fix 1

config zone
option name usb
option network 'usb'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
option masq 1
option mtu_fix 1

config zone
option name wan2
option network 'wan2'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
option masq 1
option mtu_fix 1


config forwarding
option src lan
option dest wan

config forwarding
option src wan
option dest lan

config forwarding
option src lan
option dest usb

config forwarding
option src usb
option dest lan

config forwarding
option src lan
option dest wan2

config forwarding
option src wan2
option dest lan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4

# Allow IPv4 ping
config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
option name Allow-DHCPv6
option src wan
option proto udp
option src_ip fe80::/10
option src_port 547
option dest_ip fe80::/10
option dest_port 546
option family ipv6
option target ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Forward
option src wan
option dest *
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
option limit 1000/sec
option family ipv6
option target ACCEPT

# include a file with users custom iptables rules
config include
option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
# option src lan
# option src_ip 192.168.45.2
# option dest wan
# option proto tcp
# option target REJECT

# block a specific mac on wan
#config rule
# option dest wan
# option src_mac 00:11:22:33:44:66
# option target REJECT

# block incoming ICMP traffic on a zone
#config rule
# option src lan
# option proto ICMP
# option target DROP

# port redirect port coming in on wan to lan
#config redirect
# option src wan
# option src_dport 80
# option dest lan
# option dest_ip 192.168.16.235
# option dest_port 80
# option proto tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
# option src wan
# option src_dport 22001
# option dest lan
# option dest_port 22
# option proto tcp

# allow IPsec/ESP and ISAKMP passthrough
#config rule
# option src wan
# option dest lan
# option protocol esp
# option target ACCEPT

#config rule
# option src wan
# option dest lan
# option src_port 500
# option dest_port 500
# option proto udp
# option target ACCEPT

### FULL CONFIG SECTIONS
#config rule
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 80
# option dest wan
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
# option target REJECT

#config redirect
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 1024
# option src_dport 80
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
config global automount
option from_fstab 1
option anon_mount 1

config global autoswap
option from_fstab 1
option anon_swap 0

config mount
option target /sd
option device /dev/sda1
option fstype auto
option options rw,sync
option enabled 1
option enabled_fsck 0

config swap
option device /dev/sda2
option enabled 1
# Copyright © 2006 OpenWrt.org

config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr 172.16.42.1
option netmask 255.255.255.0
option gateway 172.16.42.42
option dns 8.8.8.8

config interface wan
option ifname wlan1
option proto dhcp

config interface usb
option ifname usb0
option proto dhcp

config interface wan2
option ifname ' '
option proto ' '
option service ' '
option device ' '
option apn ' '
option username ' '
option password ' '
option defaultroute ' '
option ppp_redial ' '
option peerdns ' '
option dns ' '
option keepalive ' '
option pppd_options ' '

config system
option hostname 'Pineapple'
option timezone 'UTC'

config timeserver 'ntp'
list server '0.openwrt.pool.ntp.org'
list server '1.openwrt.pool.ntp.org'
list server '2.openwrt.pool.ntp.org'
list server '3.openwrt.pool.ntp.org'
option enable_server '0'

config led
option name 'ethernet'
option sysfs 'mk5:amber:lan'
option trigger 'netdev'
option dev 'eth0'
option mode 'link tx rx'

config led
option name 'wlan0'
option sysfs 'mk5:blue:wlan0'
option trigger 'netdev'
option dev 'wlan0'
option mode 'link tx rx'

config led
option name 'wlan1'
option sysfs 'mk5:red:wlan1'
option trigger 'netdev'
option dev 'wlan1'
option mode 'link tx rx'

config timeserver
option hostname ptbtime1.ptb.de

config timeserver
option hostname time-a.nist.gov

config timeserver
option hostname ntp.xs4all.nl

config timeserver
option hostname ptbtime2.ptb.de

config timeserver
option hostname time-b.nist.gov
# Server configuration
config uhttpd main

option 'index_page' 'index.php'
option 'error_page' '/index.php'
# HTTP listen addresses, multiple allowed
list listen_http 0.0.0.0:80
# list listen_http [::]:80

# HTTPS listen addresses, multiple allowed
list listen_https 0.0.0.0:443
# list listen_https [::]:443

# Server document root
option home /www

# Reject requests from RFC1918 IP addresses
# directed to the servers public IP(s).
# This is a DNS rebinding countermeasure.
option rfc1918_filter 1

# Certificate and private key for HTTPS.
# If no listen_https addresses are given,
# the key options are ignored.
option cert /etc/uhttpd.crt
option key /etc/uhttpd.key

# CGI url prefix, will be searched in docroot.
# Default is /cgi-bin
option cgi_prefix /cgi-bin

# List of extension->interpreter mappings.
# Files with an associated interpreter can
# be called outside of the CGI prefix and do
# not need to be executable.
list interpreter ".php=/usr/bin/php-cgi"
# list interpreter ".cgi=/usr/bin/perl"


# Lua url prefix and handler script.
# Lua support is disabled if no prefix given.
# option lua_prefix /luci
# option lua_handler /usr/lib/lua/luci/sgi/uhttpd.lua

# CGI/Lua timeout, if the called script does not
# write data within the given amount of seconds,
# the server will terminate the request with
# 504 Gateway Timeout response.
option script_timeout 60

# Network timeout, if the current connection is
# blocked for the specified amount of seconds,
# the server will terminate the associated
# request process.
option network_timeout 30

# TCP Keep-Alive, send periodic keep-alive probes
# over established connections to detect dead peers.
# The value is given in seconds to specify the
# interval between subsequent probes.
# Setting this to 0 will disable TCP keep-alive.
option tcp_keepalive 1

# Basic auth realm, defaults to local hostname
# option realm OpenWrt



# Certificate defaults for px5g key generator
config cert px5g

# Validity time
option days 730

# RSA key size
option bits 1024

# Location
option country DE
option state Berlin
option location Berlin

# Common name
option commonname OpenWrt

config uhttpd pineapple
list listen_http 0.0.0.0:1471
option home /pineapple
option index_page index.php
option 'error_page' '/index.php'

# Configuration file in busybox httpd format
option config /etc/config/httpd.conf
option rfc1918_filter 1

# Certificate and private key for HTTPS.
# If no listen_https addresses are given,
# the key options are ignored.
option cert /etc/uhttpd.crt
option key /etc/uhttpd.key

# CGI url prefix, will be searched in docroot.
# Default is /cgi-bin
option cgi_prefix /cgi-bin

# List of extension->interpreter mappings.
# Files with an associated interpreter can
# be called outside of the CGI prefix and do
# not need to be executable.
list interpreter ".php=/usr/bin/php-cgi"

# CGI/Lua timeout, if the called script does not
# write data within the given amount of seconds,
# the server will terminate the request with
# 504 Gateway Timeout response.
option script_timeout 60

# Network timeout, if the current connection is
# blocked for the specified amount of seconds,
# the server will terminate the associated
# request process.
option network_timeout 30

# TCP Keep-Alive, send periodic keep-alive probes
# over established connections to detect dead peers.
# The value is given in seconds to specify the
# interval between subsequent probes.
# Setting this to 0 will disable TCP keep-alive.
option tcp_keepalive 1


config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option macaddr '00:13:37:xx:xx:xx'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'Pineapple5_4237'
option encryption 'none'

config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr '00:13:37:xx:xx:xx'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'

config wifi-iface
option device 'radio1'
option mode 'sta'
option network 'wan'
option ssid 'The Fucking NSA'
option key 'password'
option encryption 'mixed-psk+ccmp'

dmesg Output:

[ 0.000000] Linux version 3.3.8 (sebkinne@buildtop) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #16 Fri Oct 11 21:42:39 PDT 2013
[ 0.000000] MyLoader: sysp=xxxxxxx, boardp=xxxxxxxx, parts=xxxxxxxx
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[ 0.000000] SoC: Atheros AR9330 rev 1
[ 0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 04000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Zone PFN ranges:
[ 0.000000] Normal 0x00000000 -> 0x00004000
[ 0.000000] Movable zone start PFN for each node
[ 0.000000] Early memory PFN ranges
[ 0.000000] 0: 0x00000000 -> 0x00004000
[ 0.000000] On node 0 totalpages: 16384
[ 0.000000] free_area_init_node: node 0, pgdat 802d8470, node_mem_map 81000000
[ 0.000000] Normal zone: 128 pages used for memmap
[ 0.000000] Normal zone: 0 pages reserved
[ 0.000000] Normal zone: 16256 pages, LIFO batch:3
[ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[ 0.000000] pcpu-alloc: [0] 0
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16256
[ 0.000000] Kernel command line: board=MK5 console=ttyATH0,115200 rootfstype=squashfs,jffs2 noinitrd
[ 0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[ 0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 61596k/65536k available (2124k kernel code, 3940k reserved, 405k data, 208k init, 0k highmem)
[ 0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:51
[ 0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[ 0.080000] pid_max: default: 32768 minimum: 301
[ 0.080000] Mount-cache hash table entries: 512
[ 0.090000] NET: Registered protocol family 16
[ 0.090000] gpiochip_add: registered GPIOs 0 to 29 on device: ath79
[ 0.100000] MIPS: machine is MK5 V1.0
[ 0.350000] bio: create slab at 0
[ 0.360000] Switching to clocksource MIPS
[ 0.360000] NET: Registered protocol family 2
[ 0.370000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.370000] TCP established hash table entries: 2048 (order: 2, 16384 bytes)
[ 0.380000] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.380000] TCP: Hash tables configured (established 2048 bind 2048)
[ 0.390000] TCP reno registered
[ 0.390000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.400000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.400000] NET: Registered protocol family 1
[ 0.410000] PCI: CLS 0 bytes, default 32
[ 0.430000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.430000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) © 2001-2006 Red Hat, Inc.
[ 0.440000] msgmni has been set to 120
[ 0.440000] io scheduler noop registered
[ 0.450000] io scheduler deadline registered (default)
[ 0.450000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[ 0.460000] ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11) is a AR933X UART
[ 0.460000] console [ttyATH0] enabled, bootconsole disabled
[ 0.480000] m25p80 spi0.0: found w25q128, expected m25p80
[ 0.480000] m25p80 spi0.0: w25q128 (16384 Kbytes)
[ 0.490000] 5 tp-link partitions found on MTD device spi0.0
[ 0.490000] Creating 5 MTD partitions on "spi0.0":
[ 0.500000] 0x000000000000-0x000000020000 : "u-boot"
[ 0.510000] 0x000000020000-0x000000102744 : "kernel"
[ 0.510000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.520000] 0x000000102744-0x000000ff0000 : "rootfs"
[ 0.530000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.540000] mtd: partition "rootfs" set to be root filesystem
[ 0.550000] mtd: partition "rootfs_data" created automatically, ofs=BB0000, len=440000
[ 0.550000] 0x000000bb0000-0x000000ff0000 : "rootfs_data"
[ 0.560000] 0x000000ff0000-0x000001000000 : "art"
[ 0.570000] 0x000000020000-0x000000ff0000 : "firmware"
[ 0.590000] ag71xx_mdio: probed
[ 0.590000] eth0: Atheros AG71xx at 0xb9000000, irq 4
[ 1.150000] ag71xx ag71xx.0: eth0: connected to PHY at ag71xx-mdio.1:04 [uid=xxxxxxxx, driver=Generic PHY]
[ 1.160000] TCP cubic registered
[ 1.160000] NET: Registered protocol family 17
[ 1.160000] Bridge firewalling registered
[ 1.170000] 8021q: 802.1Q VLAN Support v1.8
[ 1.180000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[ 1.180000] Freeing unused kernel memory: 208k freed
[ 3.630000] Registered led device: mk5:red:wlan1
[ 3.630000] Registered led device: mk5:blue:wlan0
[ 3.630000] Registered led device: mk5:amber:lan
[ 6.150000] eth0: link up (100Mbps/Full duplex)
[ 6.940000] JFFS2 notice: (419) jffs2_build_xattr_subsystem: complete building xattr subsystem, 3 of xdatum (0 unchecked, 2 orphan) and 26 of xref (0 dead, 9 orphan) found.
[ 7.950000] SCSI subsystem initialized
[ 8.240000] usbcore: registered new interface driver usbfs
[ 8.250000] usbcore: registered new interface driver hub
[ 8.250000] usbcore: registered new device driver usb
[ 8.810000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 8.820000] ehci-platform ehci-platform: Generic Platform EHCI Controller
[ 8.820000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[ 8.860000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[ 8.880000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[ 8.880000] hub 1-0:1.0: USB hub found
[ 8.880000] hub 1-0:1.0: 1 port detected
[ 9.010000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 9.140000] uhci_hcd: USB Universal Host Controller Interface driver
[ 9.260000] Initializing USB Mass Storage driver...
[ 9.270000] usbcore: registered new interface driver usb-storage
[ 9.270000] USB Mass Storage support registered.
[ 9.380000] usb 1-1: new high-speed USB device number 2 using ehci-platform
[ 9.530000] hub 1-1:1.0: USB hub found
[ 9.530000] hub 1-1:1.0: 4 ports detected
[ 9.810000] usb 1-1.1: new high-speed USB device number 3 using ehci-platform
[ 10.030000] usb 1-1.4: new high-speed USB device number 4 using ehci-platform
[ 10.160000] scsi0 : usb-storage 1-1.4:1.0
[ 11.160000] scsi 0:0:0:0: Direct-Access Multi Flash Reader 1.00 PQ: 0 ANSI: 0
[ 11.170000] sd 0:0:0:0: [sda] Attached SCSI removable disk
[ 29.750000] eth0: link down
[ 30.760000] Loading modules backported from Linux version master-2013-06-27-0-gdcfa6d5
[ 30.770000] Backport generated by backports.git backports-20130617-4-ge3220f5
[ 30.880000] cfg80211: Calling CRDA to update world regulatory domain
[ 30.880000] cfg80211: World regulatory domain updated:
[ 30.890000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 30.900000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 30.910000] cfg80211: (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 30.910000] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 30.920000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 30.930000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 32.500000] usbcore: registered new interface driver rt73usb
[ 32.550000] ath: EEPROM regdomain: 0x0
[ 32.550000] ath: EEPROM indicates default country code should be used
[ 32.550000] ath: doing EEPROM country->regdmn map search
[ 32.550000] ath: country maps to regdmn code: 0x3a
[ 32.550000] ath: Country alpha2 being used: US
[ 32.550000] ath: Regpair used: 0x3a
[ 32.560000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 32.560000] Registered led device: ath9k-phy0
[ 32.560000] ieee80211 phy0: Atheros AR9330 Rev:1 mem=0xb8100000, irq=2
[ 32.570000] cfg80211: Calling CRDA for country: US
[ 32.570000] cfg80211: Regulatory domain changed to country: US
[ 32.580000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 32.580000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[ 32.590000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[ 32.600000] cfg80211: (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 32.610000] cfg80211: (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 32.610000] cfg80211: (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 32.620000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[ 32.650000] usbcore: registered new interface driver rt2800usb
[ 33.060000] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[ 33.060000] ieee80211 phy1: hwaddr 00:13:37:xx:xx:xx, RTL8187vB (default) V1 + rtl8225z2, rfkill mask 2
[ 33.090000] rtl8187: Customer ID is 0x46
[ 33.090000] Registered led device: rtl8187-phy1::radio
[ 33.090000] Registered led device: rtl8187-phy1::tx
[ 33.090000] Registered led device: rtl8187-phy1::rx
[ 33.090000] rtl8187: wireless switch is on
[ 33.090000] usbcore: registered new interface driver rtl8187
[ 33.110000] Button Hotplug driver version 0.4.1
[ 33.330000] RPC: Registered named UNIX socket transport module.
[ 33.330000] RPC: Registered udp transport module.
[ 33.340000] RPC: Registered tcp transport module.
[ 33.340000] RPC: Registered tcp NFSv4.1 backchannel transport module.
[ 33.600000] PPP generic driver version 2.4.2
[ 33.630000] tun: Universal TUN/TAP device driver, 1.6
[ 33.640000] tun: © 1999-2004 Max Krasnyansky
[ 33.900000] ip_tables: © 2000-2006 Netfilter Core Team
[ 34.140000] NET: Registered protocol family 24
[ 34.280000] nf_conntrack version 0.5.0 (965 buckets, 3860 max)
[ 35.000000] xt_time: kernel timezone is -0000
[ 35.470000] usbcore: registered new interface driver ath9k_htc
[ 35.710000] usbcore: registered new interface driver usbserial
[ 35.710000] USB Serial support registered for generic
[ 35.720000] usbcore: registered new interface driver usbserial_generic
[ 35.720000] usbserial: USB Serial Driver core
[ 35.870000] usbcore: registered new interface driver asix
[ 35.990000] usbcore: registered new interface driver cdc_ether
[ 36.110000] Error: Driver 'gpio-keys-polled' is already registered, aborting...
[ 36.220000] usbcore: registered new interface driver rndis_host
[ 36.350000] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 41.050000] usbcore: deregistering interface driver usbserial_generic
[ 41.060000] USB Serial deregistering driver generic
[ 41.060000] usbcore: deregistering interface driver usbserial
[ 41.110000] usbcore: registered new interface driver usbserial
[ 41.110000] USB Serial support registered for generic
[ 41.120000] usbcore: registered new interface driver usbserial_generic
[ 41.120000] usbserial: USB Serial Driver core
[ 42.050000] usbcore: deregistering interface driver usbserial_generic
[ 42.060000] USB Serial deregistering driver generic
[ 42.060000] usbcore: deregistering interface driver usbserial
[ 42.320000] usbcore: registered new interface driver usbserial
[ 42.330000] USB Serial support registered for generic
[ 42.330000] usbcore: registered new interface driver usbserial_generic
[ 42.340000] usbserial: USB Serial Driver core
[ 42.810000] usbcore: deregistering interface driver usbserial_generic
[ 42.810000] USB Serial deregistering driver generic
[ 42.820000] usbcore: deregistering interface driver usbserial
[ 42.870000] usbcore: registered new interface driver usbserial
[ 42.870000] USB Serial support registered for generic
[ 42.880000] usbcore: registered new interface driver usbserial_generic
[ 42.880000] usbserial: USB Serial Driver core
[ 43.230000] usbcore: deregistering interface driver usbserial_generic
[ 43.230000] USB Serial deregistering driver generic
[ 43.240000] usbcore: deregistering interface driver usbserial
[ 43.280000] usbcore: registered new interface driver usbserial
[ 43.280000] USB Serial support registered for generic
[ 43.290000] usbcore: registered new interface driver usbserial_generic
[ 43.290000] usbserial: USB Serial Driver core
[ 43.710000] device eth0 entered promiscuous mode
[ 44.640000] eth0: link up (100Mbps/Full duplex)
[ 44.640000] br-lan: port 1(eth0) entered forwarding state
[ 44.650000] br-lan: port 1(eth0) entered forwarding state
[ 46.650000] br-lan: port 1(eth0) entered forwarding state
[ 52.240000] device wlan0 entered promiscuous mode
[ 52.280000] br-lan: port 2(wlan0) entered forwarding state
[ 52.290000] br-lan: port 2(wlan0) entered forwarding state
[ 54.290000] br-lan: port 2(wlan0) entered forwarding state
[ 176.890000] device wlan0 left promiscuous mode
[ 176.890000] br-lan: port 2(wlan0) entered disabled state
[ 181.950000] device wlan0 entered promiscuous mode
[ 182.090000] br-lan: port 2(wlan0) entered forwarding state
[ 182.090000] br-lan: port 2(wlan0) entered forwarding state
[ 184.090000] br-lan: port 2(wlan0) entered forwarding state
[ 425.750000] device wlan0 left promiscuous mode
[ 425.750000] br-lan: port 2(wlan0) entered disabled state

Command "wifi" via SSH output:

Failed to start hostapd for phy1
command failed: Device or resource busy (-16)
Successfully initialized wpa_supplicant

I did all this after a factory reset.

I also tried booting it up afterwards without the MicroSD card inserted.

Nothing seems to work.

This is a 2.4GHz WiFi - CISCO Router.

Edited by Paranoir
Link to comment
Share on other sites

I can connect to my home network (Airport Extreme N router) with WPA2 password but cannot connect to my iPhone 5. Just won't connect.. Oddly always connects to my Airport Extreme though.

Link to comment
Share on other sites

I'll write up a more detailed response soon, we are traveling to toorcon right now.

Client mode works, but it seems there is a bug somewhere with certain access points.

The red LED only turns on when connected to another network.

Bootloops after reset: check your dip switches.

Link to comment
Share on other sites

It's to do with how encryption is reported.

I am going to write up a small script or command that'll collect the information we need to debug this. Sit tight.

That's what I was thinking. Thanks Seb!

Link to comment
Share on other sites

So I got my MK5 today and had to poke around at this issue... Seb is spot on, of course, in that using the Network tile and Client Mode Tab to try to connect to an access point will in some cases result in the encryption option being set to an invalid configuration. But there is a way to fix it....

First off I was able to get the MK5 some internet via an AP that worked. You could try direct connect with the eth0 port or try an AP without encryption enabled. Either way you'll want to install Whistle Master's WiFi Manager infusion from the pineapple bar. Once you've done that you'll see a couple of new features that really helped me fix the problem... Check out the new Backup Tab. Create one and view it... Scroll down to the bottom and look what it says for 'option encryption'...

Below is what the Client Mode tab wrote to the etc/config/wireless file.

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr '00:13:37:a5:08:db'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'Pineapple5_08DB'
option hidden '0'

config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11g'
option macaddr '00:13:37:81:42:cb'
option disabled '0'
option channel 'auto'

config wifi-iface
option device 'radio1'
option network 'wan'
option hidden '0'
option mode 'sta'
option ssid 'Allen'\''s Network'
option key 'MyPassword'
option encryption 'mixed-psk+ccmp'

But by using the WiFi Manager infusion and changing the settings via the drop down to WPA2 Personal and TKIP and then saving and committing... I got the following written to the new etc/config/wireless file in the Backup Tab.

Backup [2013-10-18 07-27-32]

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr '00:13:37:a5:08:db'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'Pineapple5_08DB'
option hidden '0'

config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11g'
option macaddr '00:13:37:81:42:cb'
option disabled '0'
option channel 'auto'

config wifi-iface
option device 'radio1'
option network 'wan'
option hidden '0'
option mode 'sta'
option ssid 'Allen'\''s Network'
option key 'MyPassword'
option encryption 'psk2+tkip'

A subtle but important difference in that last line. Once I made the change it works great except that you can't disconnect! The DHCP Release doesn't work because the Network tile Client Mode tab is now in charge. I like the stock Client Mode tab idea but it would sure be nice to be able to disable it...

So hopefully this will help others get up and running until some fixes are worked.

And on a separate but related topic... I can't seem to get wlan1 to do anything else but the above. I tried to set it up as another AP instead of a Client but that's not working.

Link to comment
Share on other sites

So I got my MK5 today and had to poke around at this issue... Seb is spot on, of course, in that using the Network tile and Client Mode Tab to try to connect to an access point will in some cases result in the encryption option being set to an invalid configuration. But there is a way to fix it....

First off I was able to get the MK5 some internet via an AP that worked. You could try direct connect with the eth0 port or try an AP without encryption enabled. Either way you'll want to install Whistle Master's WiFi Manager infusion from the pineapple bar. Once you've done that you'll see a couple of new features that really helped me fix the problem... Check out the new Backup Tab. Create one and view it... Scroll down to the bottom and look what it says for 'option encryption'...

Below is what the Client Mode tab wrote to the etc/config/wireless file.

config wifi-device 'radio0'

option type 'mac80211'

option channel '11'

option hwmode '11ng'

option macaddr '00:13:37:a5:08:db'

option htmode 'HT20'

list ht_capab 'SHORT-GI-20'

list ht_capab 'SHORT-GI-40'

list ht_capab 'RX-STBC1'

list ht_capab 'DSSS_CCK-40'

option disabled '0'

config wifi-iface

option device 'radio0'

option network 'lan'

option mode 'ap'

option ssid 'Pineapple5_08DB'

option hidden '0'

config wifi-device 'radio1'

option type 'mac80211'

option hwmode '11g'

option macaddr '00:13:37:81:42:cb'

option disabled '0'

option channel 'auto'

config wifi-iface

option device 'radio1'

option network 'wan'

option hidden '0'

option mode 'sta'

option ssid 'Allen'\''s Network'

option key 'MyPassword'

option encryption 'mixed-psk+ccmp'

But by using the WiFi Manager infusion and changing the settings via the drop down to WPA2 Personal and TKIP and then saving and committing... I got the following written to the new etc/config/wireless file in the Backup Tab.

Backup [2013-10-18 07-27-32]

config wifi-device 'radio0'

option type 'mac80211'

option channel '11'

option hwmode '11ng'

option macaddr '00:13:37:a5:08:db'

option htmode 'HT20'

list ht_capab 'SHORT-GI-20'

list ht_capab 'SHORT-GI-40'

list ht_capab 'RX-STBC1'

list ht_capab 'DSSS_CCK-40'

option disabled '0'

config wifi-iface

option device 'radio0'

option network 'lan'

option mode 'ap'

option ssid 'Pineapple5_08DB'

option hidden '0'

config wifi-device 'radio1'

option type 'mac80211'

option hwmode '11g'

option macaddr '00:13:37:81:42:cb'

option disabled '0'

option channel 'auto'

config wifi-iface

option device 'radio1'

option network 'wan'

option hidden '0'

option mode 'sta'

option ssid 'Allen'\''s Network'

option key 'MyPassword'

option encryption 'psk2+tkip'

A subtle but important difference in that last line. Once I made the change it works great except that you can't disconnect! The DHCP Release doesn't work because the Network tile Client Mode tab is now in charge. I like the stock Client Mode tab idea but it would sure be nice to be able to disable it...

So hopefully this will help others get up and running until some fixes are worked.

And on a separate but related topic... I can't seem to get wlan1 to do anything else but the above. I tried to set it up as another AP instead of a Client but that's not working.

Woohoo!! You are my hero!! Thanks!

This works perfectly!

Hope that there will be an official update soon that will fix this bug for good! ;)

Link to comment
Share on other sites

So I got my MK5 today and had to poke around at this issue... Seb is spot on, of course, in that using the Network tile and Client Mode Tab to try to connect to an access point will in some cases result in the encryption option being set to an invalid configuration. But there is a way to fix it....

First off I was able to get the MK5 some internet via an AP that worked. You could try direct connect with the eth0 port or try an AP without encryption enabled. Either way you'll want to install Whistle Master's WiFi Manager infusion from the pineapple bar. Once you've done that you'll see a couple of new features that really helped me fix the problem... Check out the new Backup Tab. Create one and view it... Scroll down to the bottom and look what it says for 'option encryption'...

Below is what the Client Mode tab wrote to the etc/config/wireless file.

config wifi-device 'radio0'

option type 'mac80211'

option channel '11'

option hwmode '11ng'

option macaddr '00:13:37:a5:08:db'

option htmode 'HT20'

list ht_capab 'SHORT-GI-20'

list ht_capab 'SHORT-GI-40'

list ht_capab 'RX-STBC1'

list ht_capab 'DSSS_CCK-40'

option disabled '0'

config wifi-iface

option device 'radio0'

option network 'lan'

option mode 'ap'

option ssid 'Pineapple5_08DB'

option hidden '0'

config wifi-device 'radio1'

option type 'mac80211'

option hwmode '11g'

option macaddr '00:13:37:81:42:cb'

option disabled '0'

option channel 'auto'

config wifi-iface

option device 'radio1'

option network 'wan'

option hidden '0'

option mode 'sta'

option ssid 'Allen'\''s Network'

option key 'MyPassword'

option encryption 'mixed-psk+ccmp'

But by using the WiFi Manager infusion and changing the settings via the drop down to WPA2 Personal and TKIP and then saving and committing... I got the following written to the new etc/config/wireless file in the Backup Tab.

Backup [2013-10-18 07-27-32]

config wifi-device 'radio0'

option type 'mac80211'

option channel '11'

option hwmode '11ng'

option macaddr '00:13:37:a5:08:db'

option htmode 'HT20'

list ht_capab 'SHORT-GI-20'

list ht_capab 'SHORT-GI-40'

list ht_capab 'RX-STBC1'

list ht_capab 'DSSS_CCK-40'

option disabled '0'

config wifi-iface

option device 'radio0'

option network 'lan'

option mode 'ap'

option ssid 'Pineapple5_08DB'

option hidden '0'

config wifi-device 'radio1'

option type 'mac80211'

option hwmode '11g'

option macaddr '00:13:37:81:42:cb'

option disabled '0'

option channel 'auto'

config wifi-iface

option device 'radio1'

option network 'wan'

option hidden '0'

option mode 'sta'

option ssid 'Allen'\''s Network'

option key 'MyPassword'

option encryption 'psk2+tkip'

A subtle but important difference in that last line. Once I made the change it works great except that you can't disconnect! The DHCP Release doesn't work because the Network tile Client Mode tab is now in charge. I like the stock Client Mode tab idea but it would sure be nice to be able to disable it...

So hopefully this will help others get up and running until some fixes are worked.

And on a separate but related topic... I can't seem to get wlan1 to do anything else but the above. I tried to set it up as another AP instead of a Client but that's not working.

I will give it a try later today. Thanks for the findings

Link to comment
Share on other sites

Jmanuel,

It's true it won't release, I mentioned that above. What you can do is go back and erase the pass key or change the encryption back to the bad one, then hit save and commit. That should prevent you from attaching automatically after booting up. Not elegant but it will work. Just make sure to use that new Backup feature. Save a good version and a bad one and you can hit restore between them as needed.

Link to comment
Share on other sites

So here's an update...

First if you're on a Mac use Chrome... Safari gave me quite a few issues.

More importantly I may have found the fix for the Network Tile: Client Mode connection problem. You delete one character from one section in the functions.php file located at root@Pineapple:/pineapple/components/system/network/functions.php

What it is:

}elseif($ap->security->WPA2 != null && $ap->security->WPA2 != null){
$mode = "mixed-psk";
$cipher = "";
if($ap->security->WPA2->ccmp != null){
$cipher .= "+ccmp";
}
if($ap->security->WPA2->tkip != null){
$cipher .= "+tkip";
}
exec("uci set wireless.@wifi-iface[1].key=".$ap->key);
exec("uci set wireless.@wifi-iface[1].encryption=".$mode.$cipher);

What it probably should be for Mixed Mode:

}elseif($ap->security->WPA != null && $ap->security->WPA2 != null){
$mode = "mixed-psk";
$cipher = "";
if($ap->security->WPA2->ccmp != null){
$cipher .= "+ccmp";
}
if($ap->security->WPA2->tkip != null){
$cipher .= "+tkip";
}
exec("uci set wireless.@wifi-iface[1].key=".$ap->key);
exec("uci set wireless.@wifi-iface[1].encryption=".$mode.$cipher);

You guys let me know if I'm correct, but I tested it on my network and the etc/config/wireless file was edited correctly and it connected right up.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...