Jump to content

wp4 issues not able to share connection


Recommended Posts

I am working on Kali and i just got my pineapple yesterday. I was able to first use wp4 to share the laptop wifi connect and I would access the Web Gui to the pineapple. I am no longer able to see the "show ip" under network it just now just says loadings no errors just continues to say loading. It will not load the pineapple bar and I do not understand what is wrong. I reset the pineapple still the same problem wp4 is not sharing the connection anymore.

I am connected from the laptop to the POE/Lan port.

| | / (_) ____(_) / __ \(_)___ ___ ____ _____ ____ / /__
| | /| / / / /_ / / / /_/ / / __ \/ _ \/ __ '/ __ \/ __ \/ / _ \
| |/ |/ / / __/ / / / ____/ / / / / __/ /_/ / /_/ / /_/ / / __/
|__/|__/_/_/ /_/ /_/ /_/_/ /_/\___/\__,_/ .___/ .___/_/\___/
OWN the Network v.2.1

Pineapple Netmask [255.255.255.0]:
Pineapple Network [172.16.42.0/24]:
Interface between PC and Pineapple [eth0]:
Interface between PC and Internet [wlan0]:
Internet Gateway [172.16.42.1]: 192.168.1.1
IP Address of Host PC [172.16.42.42]:
IP Address of Pineapple [172.16.42.1]:

_ . ___ \||/ Internet: 192.168.1.1 - wlan0
( _ )_ <--> [___] <--> ,<><>, Computer: 172.16.42.42
(_ _(_ ,) \___\ '<><>' Pineapple: 172.16.42.0/24 - eth0
SIOCDELRT: No such process

Browse to

Route

Kernel IP routing tableDestination     Gateway         Genmask         Flags Metric Ref    Use Ifacedefault         172.16.42.42    0.0.0.0         UG    0      0        0 br-lan172.16.42.0     *               255.255.255.0   U     0      0        0 br-lan

Ifconfig

Kernel IP routing tableDestination     Gateway         Genmask         Flags Metric Ref    Use Ifacedefault         172.16.42.42    0.0.0.0         UG    0      0        0 br-lan172.16.42.0     *               255.255.255.0   U     0      0        0 br-lanbr-lan    Link encap:Ethernet  HWaddr          inet addr:172.16.42.1  Bcast:172.16.42.255  Mask:255.255.255.0          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1          RX packets:819 errors:0 dropped:12 overruns:0 frame:0          TX packets:788 errors:0 dropped:0 overruns:0 carrier:0          collisions:0 txqueuelen:0          RX bytes:59770 (58.3 KiB)  TX bytes:64527 (63.0 KiB)eth0      Link encap:Ethernet  HWaddr           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1          RX packets:829 errors:0 dropped:6 overruns:0 frame:0          TX packets:788 errors:0 dropped:0 overruns:0 carrier:0          collisions:0 txqueuelen:1000          RX bytes:73072 (71.3 KiB)  TX bytes:64527 (63.0 KiB)          Interrupt:5eth1      Link encap:Ethernet  HWaddr           UP BROADCAST MULTICAST  MTU:1500  Metric:1          RX packets:0 errors:0 dropped:0 overruns:0 frame:0          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0          collisions:0 txqueuelen:1000          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)          Interrupt:4lo        Link encap:Local Loopback          inet addr:127.0.0.1  Mask:255.0.0.0          UP LOOPBACK RUNNING  MTU:16436  Metric:1          RX packets:156 errors:0 dropped:0 overruns:0 frame:0          TX packets:156 errors:0 dropped:0 overruns:0 carrier:0          collisions:0 txqueuelen:0          RX bytes:12814 (12.5 KiB)  TX bytes:12814 (12.5 KiB)wlan0     Link encap:Ethernet  HWaddr           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1          RX packets:0 errors:0 dropped:0 overruns:0 frame:0          TX packets:83 errors:0 dropped:0 overruns:0 carrier:0          collisions:0 txqueuelen:1000          RX bytes:0 (0.0 B)  TX bytes:6564 (6.4 KiB)
Edited by iknox
Link to post
Share on other sites

This is from the laptop

ifconfig
eth0 Link encap:Ethernet HWaddr
inet addr:172.16.42.249 Bcast:172.16.42.255 Mask:255.255.255.0
inet6 addr: fe80::223:8bff:fe58:fd41/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:10805 errors:0 dropped:0 overruns:0 frame:0
TX packets:11226 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1086426 (1.0 MiB) TX bytes:1388354 (1.3 MiB)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:98 errors:0 dropped:0 overruns:0 frame:0
TX packets:98 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7026 (6.8 KiB) TX bytes:7026 (6.8 KiB)

wlan0 Link encap:Ethernet HWaddr
inet addr:192.168.1.14 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: 2002:468c:b287:e472:222:faff:fe14:f5d4/64 Scope:Global
inet6 addr: 2002:468c:b287:e472:3ccc:b647:972c:8119/64 Scope:Global
inet6 addr: fe80::222:faff:fe14:f5d4/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:17675 errors:0 dropped:0 overruns:0 frame:0
TX packets:10791 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:9902975 (9.4 MiB) TX bytes:1623556 (1.5 MiB)

Link to post
Share on other sites

Seems like a stupid question, but are you sure 192.168.1.1 is actually the router? and not 2.x?

well seeing as that is my gateway and that those numbers worked before just fine..... Can this have something to do with the wifipineapple.com site down?

Link to post
Share on other sites

Yes, it could... Try to SSH into your pineapple after you have done the WP4.sh script, then execute

ping -c 3 google.com
If you get replys, your online :)

Nope not getting replays I even tried hooking it to my router into the wan still no luck

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...