Jump to content

[question][payload]Reverse shell seems to not work right for me...


Scrag
 Share

Recommended Posts

Ive compiled Darren kitchen's reverse shell and loaded it onto my ducky. When I insert it into my win7 pc it does all kinds of strange things like open random programs. I do see it try to type out the code for the payload but I cant get this to work right. Ive gone through the script and tried to manually enter the commands to see where it appears to have the hangup. The 6th command down, MENU, seems to not work for me or maybe there is something i dont understand. Ive tried recompiling the inject.bin again and tried again but same issues. I have UAC turned off on my win7 PC.

Here's the link to the reverse shell im using:

https://github.com/hak5darren/USB-Rubber-Ducky/wiki/Payload---reverse-shell

Any thoughts?

Thank You!

Scrag

Link to comment
Share on other sites

  1. What Firmware are you using?
  2. Which Encoder are you using?

Your payload is using a duck-encoder version 1 script.

You may need to tweak the delays, and insert an initial long delay (eg DELAY 3000) on the first line of the ducky script payload. This is why your seeing the random programs open.

Alternatively , if your using Encoder v2+ search the forums for an updated script that is more compatible with the latest developments.

Edited by midnitesnake
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...