Jump to content

Internet Sharing Problem - Kali-Linux and Wifi Pineapple


Recommended Posts

Hi,

I know there seems to be a flood of this on here right now. I've tried a few things, I am clearly overlooking something though and could use another set of feedback.

OS: Kali-Linux

WP: Mark IV w/ 3.0

  1. ran the wp4.sh script and pretty much used all the default settings.
  2. made sure the wifi pineapple was plugged into my NIC on laptop POE on the WP
  3. my wireless card is connected to my home gateway
  4. I manually change the NIC card on the laptop to manually use 172.16.42.42

I can connect to the WP, but do not have internet.

I cannot use internet or even ping from my laptop when the rj45 is plugged into my laptop. As soon as I take it out, it will work fine again. This is the part that is getting me, It's like it's looking to the wired connection for internet when the wireless has it but it's not seeing it.

Any feedback to help me see what I'm overlooking here would be great.

Thanks,

ph33rgear

Link to post
Share on other sites

Try disabling network manager on Kali.

sudo service network-manager stop

So I tried that and it shutdown my nic cards.

I guess I'll try manually editing the .conf files?

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

to

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
#auto lo
#iface lo inet loopback

auto eth1

eth1 being my wireless card.

Trying it now, nothing to hurt or lose.

Link to post
Share on other sites

ok you didnt mention a very important step. you said youre connected the internet via your laptops wireless intrerface and youre connected to the pineapple via the rj45 interface but you never mentioned if you setup the internet connection sharing. youre supposed to share the wireless cards internet conection to the rj45 connection. have you done that?

Link to post
Share on other sites

Sorry for the late response, I haven't got a chance back at this until now.

Ok, so I tried un-checking the "Connect Automatically" on the wired connection ( to the WP ), still no go. Your version of kali did not look like mine, yours does say "Configure Automatically" not that the terminology used should matter much.

Eth0 - wired nic is manually set to 172.16.42.42

Eth1 is connected to my home router.

When I unplug the rj45 to the WP though, internet works again.

root@NAHost:~# ./wp4.sh
  _       ___ _______    ____  _                              __   
 | |     / (_) ____(_)  / __ \(_)___  ___  ____ _____  ____  / /__ 
 | | /| / / / /_  / /  / /_/ / / __ \/ _ \/ __ '/ __ \/ __ \/ / _ \
 | |/ |/ / / __/ / /  / ____/ / / / /  __/ /_/ / /_/ / /_/ / /  __/
 |__/|__/_/_/   /_/  /_/   /_/_/ /_/\___/\__,_/ .___/ .___/_/\___/ 
  OWN the Network                            /_/   /_/       v2.1

Pineapple Netmask [255.255.255.0]: 
Pineapple Network [172.16.42.0/24]: 
Interface between PC and Pineapple [eth0]: 
Interface between PC and Internet [wlan0]: eth1
Internet Gateway [172.16.42.1]: 
IP Address of Host PC [172.16.42.42]: 
IP Address of Pineapple [172.16.42.1]: 

     _ .           ___          \||/   Internet: 172.16.42.1 - eth1
   (  _ )_  <-->  [___]  <-->  ,<><>,  Computer: 172.16.42.42
 (_  _(_ ,)       \___\        '<><>' Pineapple: 172.16.42.0/24 - eth0
SIOCADDRT: Network is unreachable

Browse to http://172.16.42.1:1471  --  Happy Hacking!
Edited by ph33rgear
Link to post
Share on other sites

Sorry for the late response, I haven't got a chance back at this until now.

Ok, so I tried un-checking the "Connect Automatically" on the wired connection ( to the WP ), still no go. Your version of kali did not look like mine, yours does say "Configure Automatically" not that the terminology used should matter much.

Eth0 - wired nic is manually set to 172.16.42.42

Eth1 is connected to my home router.

When I unplug the rj45 to the WP though, internet works again.

root@NAHost:~# ./wp4.sh
  _       ___ _______    ____  _                              __   
 | |     / (_) ____(_)  / __ \(_)___  ___  ____ _____  ____  / /__ 
 | | /| / / / /_  / /  / /_/ / / __ \/ _ \/ __ '/ __ \/ __ \/ / _ \
 | |/ |/ / / __/ / /  / ____/ / / / /  __/ /_/ / /_/ / /_/ / /  __/
 |__/|__/_/_/   /_/  /_/   /_/_/ /_/\___/\__,_/ .___/ .___/_/\___/ 
  OWN the Network                            /_/   /_/       v2.1

Pineapple Netmask [255.255.255.0]: 
Pineapple Network [172.16.42.0/24]: 
Interface between PC and Pineapple [eth0]: 
Interface between PC and Internet [wlan0]: eth1
Internet Gateway [172.16.42.1]: 
IP Address of Host PC [172.16.42.42]: 
IP Address of Pineapple [172.16.42.1]: 

     _ .           ___          \||/   Internet: 172.16.42.1 - eth1
   (  _ )_  <-->  [___]  <-->  ,<><>,  Computer: 172.16.42.42
 (_  _(_ ,)       \___\        '<><>' Pineapple: 172.16.42.0/24 - eth0
SIOCADDRT: Network is unreachable

Browse to http://172.16.42.1:1471  --  Happy Hacking!

The issue is your internet gateway option.

You have to set that to your routers / gateways address. Your internet will work once that is done!

Best Regards,

Sebkinne

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...