Jump to content

Client connected to pineapple but no internet 3.0.0


levisiccard
 Share

Recommended Posts

Client does connect to the pineapple but has no internet.

Any adea where it went wrong? My wlan0 is connected to the internet and the eth0 is connected to the pineapple: I'm using Kali Linux and it's my second pineapple day. The firmware is the 3.0.0

| | / (_) ____(_) / __ \(_)___ ___ ____ _____ ____ / /__
| | /| / / / /_ / / / /_/ / / __ \/ _ \/ __ '/ __ \/ __ \/ / _ \
| |/ |/ / / __/ / / / ____/ / / / / __/ /_/ / /_/ / /_/ / / __/
|__/|__/_/_/ /_/ /_/ /_/_/ /_/\___/\__,_/ .___/ .___/_/\___/
OWN the Network /_/ /_/ v2.1

Pineapple Netmask [255.255.255.0]:
Pineapple Network [172.16.42.0/24]:
Interface between PC and Pineapple [eth0]:
Interface between PC and Internet [wlan0]:
Internet Gateway [192.168.1.1]:
IP Address of Host PC [172.16.42.42]:
IP Address of Pineapple [172.16.42.1]:

when doing a # route-n this is what I get (maybe its helpfull)

root@new-host-5:~# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 172.16.42.1 0.0.0.0 UG 0 0 0 eth0
172.16.42.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0

Always available for more information.

Regards!

Link to comment
Share on other sites

1) Are you connected to the internet on Kali?

2) what port on the pineapple are you plugged into the LAN or WAN - they are labelled

3) have you run the wp4.sh script on kali?

Please run these commands on the kali box (feel free to blank out MAC addresses) - then put them in code boxes in your reply here(this is very important for my sanity)

cat /proc/sys/net/ipv4/ip_forward

ifconfig

ping 172.16.42.1 -I eth0 -c 4
Link to comment
Share on other sites

Hey, hups, my kali machine is connected to the internet with my awus036 wich is wlan0

the port on the pineapple is the PoE LAN

and yes, i've run the wp4.sh script on kali.

Jump over to my kali machine now and do the kali commands

Link to comment
Share on other sites

here are the outputs of the commands. In this example i am using my wlan1 because the wlan0 is not connected but it gives me the same result

root@new-host-5:~# cat /proc/sys/net/ipv4/ip_forward
1
root@new-host-5:~# ifconfig
eth0 Link encap:Ethernet HWaddr 70:54:d2:93:a3:cb
inet addr:172.16.42.42 Bcast:172.16.42.255 Mask:255.255.255.0
inet6 addr: fe80::7254:d2ff:fe93:a3cb/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:376 errors:0 dropped:0 overruns:0 frame:0
TX packets:462 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:26040 (25.4 KiB) TX bytes:38563 (37.6 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:25 errors:0 dropped:0 overruns:0 frame:0
TX packets:25 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1508 (1.4 KiB) TX bytes:1508 (1.4 KiB)

wlan1 Link encap:Ethernet HWaddr 60:36:dd:66:2d:53
inet addr:192.168.1.11 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::6236:ddff:fe66:2d53/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4150 errors:0 dropped:0 overruns:0 frame:0
TX packets:4053 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3157782 (3.0 MiB) TX bytes:758787 (741.0 KiB)

root@new-host-5:~# ping 172.16.42.1 -I eth0 -c 4
PING 172.16.42.1 (172.16.42.1) from 172.16.42.42 eth0: 56(84) bytes of data.
64 bytes from 172.16.42.1: icmp_req=1 ttl=64 time=0.283 ms
64 bytes from 172.16.42.1: icmp_req=2 ttl=64 time=0.233 ms
64 bytes from 172.16.42.1: icmp_req=3 ttl=64 time=0.237 ms
64 bytes from 172.16.42.1: icmp_req=4 ttl=64 time=0.246 ms

--- 172.16.42.1 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 2999ms
rtt min/avg/max/mdev = 0.233/0.249/0.283/0.027 ms
root@new-host-5:~#

regards

Link to comment
Share on other sites

ERMAGHERD https://forums.hak5.org/index.php?/topic/29964-pineapple-enable-internet-for-un-phished-pages/

https://github.com/WiFiPineapple/web-interface/wiki/mk34quickstartguide

iptables -A FORWARD -i wlan0 -o eth0 -s 172.16.42.0/24 -m state –state NEW -j ACCEPT
iptables -A FORWARD -m state –state ESTABLISHED,RELATED -j ACCEPT
iptables -A POSTROUTING -t nat -j MASQUERADE
Link to comment
Share on other sites

  • 1 month later...

This seemed like the perfect topic unfortunatly this sollution is no longer possible

root@debian:/mnt/playground# iptables -A FORWARD -m state –state ESTABLISHED,RELATED -j ACCEPT
Bad argument `–state'

I have exactly the same problem as the previous poster i cant access the mk4 no problem but its seems like there is some sort of routing error.

I have run the wp4.sh couple of times and im running a firmware 3.0 mk4 device

Edited by swejonas
Link to comment
Share on other sites

Thanks that solved it, one of the problems was the the previous posters dash infont of "state" was not accepted i just missed it but at a closer glance you can see that its actually bigger than other dashes.

This worked

iptables -A FORWARD -i wlan0 -o eth0 -s 172.16.42.0/24 -m state --state NEW -j ACCEPT
iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A POSTROUTING -t nat -j MASQUERADE
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...