Jump to content

Huawei Linux Drivers - found


PaulK
 Share

Recommended Posts

HI guys, I note that many people seem to be having trouble with their Huawei 3g dongles.

I found this link to the Huawei site and it has a linux drivers for download. I'm not sure if they can be adapted for the pineapple or not, but thought it was useful info to share. I am struggling to get my E586 going at the moment, so sharing the knowledge.

Hope its useful

Paul

http://consumer.huawei.com/en/support/downloads/detail/index.htm?id=13971

Edited by PaulK
Link to comment
Share on other sites

We may be on to something here, I dont have a wan2 interface

root@Pineapple:/etc/config# cat network
# Copyright © 2006 OpenWrt.org

config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr 172.16.42.1
option netmask 255.255.255.0
option gateway 172.16.42.42
option dns 8.8.8.8

config interface wan
option ifname eth1
option proto dhcp

config switch eth0
option enable_vlan 1

config switch_vlan
option device eth0
option vlan 1
option ports "0 1"

config interface usb
option ifname usb0
option proto dhcp

root@Pineapple:/etc/config#

Edited by PaulK
Link to comment
Share on other sites

My log from startup, the modem is definitely being seen, and the sd card, I'm thinking I need to add a file to the /etc/usb_modeswitch.d for my modem (12d1:1c1f)

00:04:17 Pineapple user.notice ifup: Allowing Router Advertisements on wan (eth1)
00:04:16 Pineapple daemon.notice netifd: Interface 'wan' is now up
00:04:16 Pineapple daemon.info dnsmasq[1150]: using nameserver 8.8.8.8#53
00:04:16 Pineapple daemon.info dnsmasq[1150]: using local addresses only for domain lan
00:04:16 Pineapple daemon.info dnsmasq[1150]: reading /tmp/resolv.conf.auto
00:04:15 Pineapple daemon.notice netifd: wan (828): Sending select for 192.168.2.2...
00:04:15 Pineapple daemon.notice netifd: wan (828): Lease of 192.168.2.2 obtained, lease time 85536
00:04:12 Pineapple kern.info kernel: [ 252.520000] eth1: link up (100Mbps/Full duplex)
00:01:22 Pineapple user.notice fstab: mount: mounting /dev/sda1 on /usb failed: Invalid argument
00:01:21 Pineapple user.notice usb-modeswitch: 1-1:1.3: Manufacturer=HUAWEI Product=HUAWEI_Mobile Serial=?
00:01:21 Pineapple user.notice usb-modeswitch: 1-1:1.2: Manufacturer=HUAWEI Product=HUAWEI_Mobile Serial=?
00:01:21 Pineapple user.notice usb-modeswitch: 1-1:1.1: Manufacturer=HUAWEI Product=HUAWEI_Mobile Serial=?
00:01:21 Pineapple user.notice usb-modeswitch: 1-1:1.0: Manufacturer=HUAWEI Product=HUAWEI_Mobile Serial=?
00:01:16 Pineapple user.info sysinit: setting up led WLAN
00:01:16 Pineapple user.info sysinit: setting up led WAN
00:01:16 Pineapple user.info sysinit: setting up led USB
00:01:16 Pineapple user.info sysinit: setting up led LAN
00:01:16 Pineapple user.info sysinit: No lease, failing
00:01:13 Pineapple user.info sysinit: Sending discover...
00:01:10 Pineapple user.info sysinit: Sending discover...
00:01:07 Pineapple user.info sysinit: Sending discover...
00:01:06 Pineapple user.info sysinit: udhcpc (v1.19.4) started
00:01:06 Pineapple user.info sysinit: 1d6b:0002 12d1:1c1f
00:01:04 Pineapple user.notice root: 3G: Connection Script here, searching for modems-PK
00:01:04 Pineapple user.info sysinit: Selected interface 'wlan0'
00:01:04 Pineapple user.info sysinit: Searching for attached 3G Modems
00:01:04 Pineapple user.info sysinit: OK
00:01:03 Pineapple kern.info kernel: [ 63.990000] br-lan: port 2(wlan0) entered forwarding state
00:01:02 Pineapple kern.info kernel: [ 61.990000] br-lan: port 2(wlan0) entered forwarding state
00:01:02 Pineapple kern.info kernel: [ 61.990000] br-lan: port 2(wlan0) entered forwarding state
00:01:01 Pineapple kern.info kernel: [ 61.850000] device wlan0 entered promiscuous mode
00:01:00 Pineapple kern.info kernel: [ 60.740000] br-lan: port 2(wlan0) entered disabled state
00:01:00 Pineapple kern.info kernel: [ 60.730000] device wlan0 left promiscuous mode
00:01:00 Pineapple daemon.info dnsmasq[1150]: using nameserver 8.8.8.8#53
00:01:00 Pineapple daemon.info dnsmasq[1150]: using local addresses only for domain lan
00:01:00 Pineapple daemon.info dnsmasq[1150]: using local addresses only for domain lan
00:01:00 Pineapple daemon.info dnsmasq[1150]: started, version 2.62 cachesize 150
00:01:00 Pineapple daemon.info dnsmasq[1150]: reading /tmp/resolv.conf.auto
00:01:00 Pineapple daemon.info dnsmasq[1150]: read /etc/hosts - 1 addresses
00:01:00 Pineapple daemon.info dnsmasq[1150]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack
00:01:00 Pineapple daemon.info dnsmasq-dhcp[1150]: read /etc/ethers - 0 addresses
00:01:00 Pineapple daemon.info dnsmasq-dhcp[1150]: DHCP, IP range 172.16.42.100 -- 172.16.42.249, lease time 12h
00:00:57 Pineapple user.notice dnsmasq: DNS rebinding protection is active, will discard upstream RFC1918 responses!
00:00:57 Pineapple user.notice dnsmasq: Allowing 127.0.0.0/8 responses
00:00:54 Pineapple authpriv.info dropbear[1091]: Running in background
00:00:53 Pineapple cron.info crond[1074]: crond: crond (busybox 1.19.4) started, log level 5
00:00:52 Pineapple kern.info kernel: [ 52.010000] br-lan: port 2(wlan0) entered forwarding state
00:00:51 Pineapple daemon.notice netifd: wan (828): Sending discover...
00:00:50 Pineapple kern.info kernel: [ 50.010000] br-lan: port 2(wlan0) entered forwarding state
00:00:50 Pineapple kern.info kernel: [ 50.010000] br-lan: port 2(wlan0) entered forwarding state
00:00:49 Pineapple kern.info kernel: [ 49.960000] device wlan0 entered promiscuous mode
00:00:48 Pineapple daemon.notice netifd: wan (828): Sending discover...
00:00:47 Pineapple user.notice ifup: Enabling Router Solicitations on loopback (lo)
00:00:47 Pineapple kern.notice kernel: [ 47.100000] sd 2:0:0:0: [sda] Attached SCSI removable disk
00:00:47 Pineapple kern.notice kernel: [ 47.070000] sd 2:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
00:00:47 Pineapple kern.notice kernel: [ 47.070000] sd 2:0:0:0: [sda] Write Protect is off
00:00:47 Pineapple kern.notice kernel: [ 47.050000] sd 2:0:0:0: [sda] 30702592 512-byte logical blocks: (15.7 GB/14.6 GiB)
00:00:47 Pineapple kern.notice kernel: [ 47.050000] sd 2:0:0:0: Attached scsi generic sg1 type 0
00:00:47 Pineapple kern.notice kernel: [ 47.040000] scsi 2:0:0:0: Direct-Access HUAWEI SD Storage 2.31 PQ: 0 ANSI: 2
00:00:47 Pineapple kern.notice kernel: [ 47.030000] scsi 1:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
00:00:47 Pineapple kern.notice kernel: [ 47.030000] scsi 1:0:0:0: Attached scsi generic sg0 type 5
00:00:47 Pineapple kern.info kernel: [ 47.100000] sda: sda1
00:00:47 Pineapple kern.debug kernel: [ 47.070000] sd 2:0:0:0: [sda] Mode Sense: 0f 00 00 00
00:00:46 Pineapple user.notice ifup: Enabling Router Solicitations on lan (br-lan)
00:00:46 Pineapple kern.info kernel: [ 46.030000] scsi2 : usb-storage 1-1:1.3
00:00:46 Pineapple kern.info kernel: [ 46.030000] scsi1 : usb-storage 1-1:1.1
00:00:45 Pineapple kern.info kernel: [ 45.860000] usb 1-1: new high-speed USB device number 3 using ehci-platform
00:00:45 Pineapple daemon.notice netifd: wan (828): udhcpc (v1.19.4) started
00:00:45 Pineapple daemon.notice netifd: wan (828): Sending discover...
00:00:44 Pineapple kern.info kernel: [ 44.730000] device eth0 entered promiscuous mode
00:00:44 Pineapple daemon.notice netifd: Interface 'loopback' is now up
00:00:44 Pineapple daemon.notice netifd: Interface 'lan' is now up
00:00:43 Pineapple user.notice usb-modeswitch: 1-1:1.0: Selecting /etc/usb_modeswitch.d/12d1:14fe for mode switching
00:00:43 Pineapple user.notice usb-modeswitch: 1-1:1.0: Manufacturer=HUAWEI Product=HUAWEI_Mobile Serial=?
00:00:43 Pineapple syslog.notice usb_modeswitch: switching device 12d1:14fe on 001/002
00:00:43 Pineapple kern.info kernel: [ 43.520000] usb 1-1: USB disconnect, device number 2
00:00:42 Pineapple user.notice usb-modeswitch: 1-0:1.0: Manufacturer=Linux_3.3.8_ehci_hcd Product=Generic_Platform_EHCI_Controller Serial=ehci-platform
00:00:39 Pineapple kern.warn kernel: [ 0.680000] m25p80 spi0.0: found mx25l6405d, expected m25p80
00:00:39 Pineapple kern.warn kernel: [ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
00:00:39 Pineapple kern.warn kernel: [ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
00:00:39 Pineapple kern.notice kernel: [ 38.410000] scsi 0:0:0:0: Attached scsi generic sg0 type 5
00:00:39 Pineapple kern.notice kernel: [ 2.940000] Bridge firewalling registered
00:00:39 Pineapple kern.notice kernel: [ 0.750000] 0x0000007f0000-0x000000800000 : "art"
00:00:39 Pineapple kern.notice kernel: [ 0.750000] 0x000000050000-0x0000007e0000 : "firmware"
00:00:39 Pineapple kern.notice kernel: [ 0.740000] 0x0000007e0000-0x0000007f0000 : "nvram"
00:00:39 Pineapple kern.notice kernel: [ 0.740000] 0x000000650000-0x0000007e0000 : "kernel"
00:00:39 Pineapple kern.notice kernel: [ 0.730000] 0x000000550000-0x000000650000 : "rootfs_data"
00:00:39 Pineapple kern.notice kernel: [ 0.720000] mtd: partition "rootfs" set to be root filesystem
00:00:39 Pineapple kern.notice kernel: [ 0.710000] 0x000000050000-0x000000650000 : "rootfs"
00:00:39 Pineapple kern.notice kernel: [ 0.710000] 0x000000040000-0x000000050000 : "u-boot-env"
00:00:39 Pineapple kern.notice kernel: [ 0.700000] 0x000000000000-0x000000040000 : "u-boot"
00:00:39 Pineapple kern.notice kernel: [ 0.690000] Creating 7 MTD partitions on "spi0.0":
00:00:39 Pineapple kern.notice kernel: [ 0.690000] 7 cmdlinepart partitions found on MTD device spi0.0
00:00:39 Pineapple kern.info kernel: [ 38.280000] usbcore: registered new interface driver rndis_host
00:00:39 Pineapple kern.info kernel: [ 38.050000] usbcore: registered new interface driver cdc_ether
00:00:39 Pineapple kern.info kernel: [ 38.010000] usbserial: USB Serial Driver core
00:00:39 Pineapple kern.info kernel: [ 38.000000] usbcore: registered new interface driver usbserial_generic
00:00:39 Pineapple kern.info kernel: [ 38.000000] USB Serial support registered for generic
00:00:39 Pineapple kern.info kernel: [ 37.990000] usbcore: registered new interface driver usbserial
00:00:39 Pineapple kern.info kernel: [ 37.770000] usbcore: registered new interface driver ath9k_htc
00:00:39 Pineapple kern.info kernel: [ 37.280000] xt_time: kernel timezone is -0000
00:00:39 Pineapple kern.info kernel: [ 36.590000] nf_conntrack version 0.5.0 (458 buckets, 1832 max)
00:00:39 Pineapple kern.info kernel: [ 36.450000] NET: Registered protocol family 24
00:00:39 Pineapple kern.info kernel: [ 36.220000] ip_tables: © 2000-2006 Netfilter Core Team
00:00:39 Pineapple kern.info kernel: [ 35.970000] tun: Universal TUN/TAP device driver, 1.6
00:00:39 Pineapple kern.info kernel: [ 35.970000] tun: © 1999-2004 Max Krasnyansky
00:00:39 Pineapple kern.info kernel: [ 35.830000] PPP generic driver version 2.4.2
00:00:39 Pineapple kern.info kernel: [ 35.470000] RPC: Registered tcp NFSv4.1 backchannel transport module.
00:00:39 Pineapple kern.info kernel: [ 35.460000] RPC: Registered udp transport module.
00:00:39 Pineapple kern.info kernel: [ 35.460000] RPC: Registered tcp transport module.
00:00:39 Pineapple kern.info kernel: [ 35.460000] RPC: Registered named UNIX socket transport module.
00:00:39 Pineapple kern.info kernel: [ 2.960000] Freeing unused kernel memory: 208k freed
00:00:39 Pineapple kern.info kernel: [ 2.950000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
00:00:39 Pineapple kern.info kernel: [ 2.940000] 8021q: 802.1Q VLAN Support v1.8
00:00:39 Pineapple kern.info kernel: [ 2.930000] TCP cubic registered
00:00:39 Pineapple kern.info kernel: [ 2.930000] NET: Registered protocol family 17
00:00:39 Pineapple kern.info kernel: [ 2.920000] ag71xx ag71xx.0: eth1: connected to PHY at ag71xx-mdio.1:04 [uid=004dd041, driver=Generic PHY]
00:00:39 Pineapple kern.info kernel: [ 2.370000] eth1: Atheros AG71xx at 0xb9000000, irq 4
00:00:39 Pineapple kern.info kernel: [ 1.330000] eth0: Found an AR7240/AR9330 built-in switch
00:00:39 Pineapple kern.info kernel: [ 0.780000] eth0: Atheros AG71xx at 0xba000000, irq 5
00:00:39 Pineapple kern.info kernel: [ 0.780000] ag71xx_mdio: probed
00:00:39 Pineapple kern.info kernel: [ 0.720000] mtd: partition "rootfs_data" created automatically, ofs=550000, len=100000
00:00:39 Pineapple kern.info kernel: [ 0.680000] m25p80 spi0.0: mx25l6405d (8192 Kbytes)
00:00:39 Pineapple kern.info kernel: [ 0.660000] console [ttyATH0] enabled, bootconsole disabled
00:00:39 Pineapple kern.info kernel: [ 0.660000] ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11) is a AR933X UART
00:00:39 Pineapple kern.info kernel: [ 0.650000] io scheduler deadline registered (default)
00:00:39 Pineapple kern.info kernel: [ 0.650000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
00:00:39 Pineapple kern.info kernel: [ 0.640000] msgmni has been set to 56
00:00:39 Pineapple kern.info kernel: [ 0.640000] io scheduler noop registered
00:00:39 Pineapple kern.info kernel: [ 0.630000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
00:00:39 Pineapple kern.info kernel: [ 0.630000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) © 2001-2006 Red Hat, Inc.
00:00:39 Pineapple kern.info kernel: [ 0.600000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
00:00:39 Pineapple kern.info kernel: [ 0.600000] NET: Registered protocol family 1
00:00:39 Pineapple kern.info kernel: [ 0.590000] UDP hash table entries: 256 (order: 0, 4096 bytes)
00:00:39 Pineapple kern.info kernel: [ 0.590000] TCP reno registered
00:00:39 Pineapple kern.info kernel: [ 0.580000] TCP: Hash tables configured (established 1024 bind 1024)
00:00:39 Pineapple kern.info kernel: [ 0.570000] TCP established hash table entries: 1024 (order: 1, 8192 bytes)
00:00:39 Pineapple kern.info kernel: [ 0.570000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
00:00:39 Pineapple kern.info kernel: [ 0.570000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
00:00:39 Pineapple kern.info kernel: [ 0.560000] Switching to clocksource MIPS
00:00:39 Pineapple kern.info kernel: [ 0.560000] NET: Registered protocol family 2
00:00:39 Pineapple kern.info kernel: [ 0.550000] bio: create slab at 0
00:00:39 Pineapple kern.info kernel: [ 0.100000] MIPS: machine is ALFA NETWORKS Hornet-UB
00:00:39 Pineapple kern.info kernel: [ 0.090000] gpiochip_add: registered GPIOs 0 to 29 on device: ath79
00:00:39 Pineapple kern.info kernel: [ 0.090000] NET: Registered protocol family 16
00:00:39 Pineapple kern.info kernel: [ 0.080000] pid_max: default: 32768 minimum: 301
00:00:39 Pineapple kern.info kernel: [ 0.080000] Mount-cache hash table entries: 512
00:00:39 Pineapple kern.info kernel: [ 0.000000] Writing ErrCtl register=00000000
00:00:39 Pineapple kern.info kernel: [ 0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
00:00:39 Pineapple kern.info kernel: [ 0.000000] Readback ErrCtl register=00000000
00:00:39 Pineapple kern.info kernel: [ 0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
00:00:39 Pineapple kern.info kernel: [ 0.000000] NR_IRQS:51
00:00:39 Pineapple kern.info kernel: [ 0.000000] Memory: 29132k/32768k available (2102k kernel code, 3636k reserved, 404k data, 208k init, 0k highmem)
00:00:39 Pineapple kern.info kernel: [ 0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
00:00:39 Pineapple kern.info kernel: [ 0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
00:00:39 Pineapple kern.info kernel: [ 0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
00:00:39 Pineapple kern.err kernel: [ 38.170000] Error: Driver 'gpio-keys-polled' is already registered, aborting...
00:00:39 Pineapple kern.debug kernel: [ 6.320000] Registered led device: alfa:blue:lan
00:00:39 Pineapple kern.debug kernel: [ 0.610000] PCI: CLS 0 bytes, default 32

Link to comment
Share on other sites

3.0.0 or 2.8.1? I'm not seeing a config file for your particular modem in /etc/usb_modeswitch.d on the former.

What model Huawei?

You shouldn't have a wan2 network on 2.x until after dialing and on 3.x it's blank until you fill in the details from network > mobile broadband.

Link to comment
Share on other sites

I'm using a Hawei E586 MiFi connected over usb, which shows up in as 12d1:1c1f, It's a 3G dongle with micro-sd slot. Im using 2.8.1, Im happy to reflash if you think this will help or even upgrade. I was waiting for more scripts to be released and tested before upgrading though.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...