Jump to content

wp4.sh Error - Too Many Links


moxic
 Share

Recommended Posts

I'm running a fairly stock Ubuntu 13.04 and was attempting to setup ICS on the pineapple, but when I run the wp4.sh script, it chugs along happily until it gets to the iptables insctructions in the script and pukes out 'Too Many Links'. I know this is related to rules containing '-j CHAINTODELETE', but I just don't see why it's popping up, especially with the commands executed in the script. Any help here would be greatly appreciated.

Also, in an attempt to circumvent the issue for the time being and just set up NAT on the pineapple, I added a few lines to the WPS button config, but it doesn't even seem to attempt to apply them, although I can SSH in do it, althogth the rules still doesn't work. iptables -L and -S show them listed after typing it in (doesn't show up with a 2-4sec WPS press). I'm using:

iptables -A FORWARD -i eth1 -o wlan0 -s 172.16.42.0/24 -m state --state NEW -j ACCEPT
iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

Any insight on either of these two issues would be exceptionally welcome. I'm going to bash my head against a pillow now... -_-zzz

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...