Jump to content

Shiney new defcon pineapple - 3.0.0 bugs


sys
 Share

Recommended Posts

While considering my choices of defcon swag, checking out sexy (overpriced) shirts / hoodies and lockpick sets that I wasn't sure were allowed in overhead luggage I happened upon the pineapple. I had heard of our friend Jasager before and I decided it would be more enjoyable than a hoody... thus a friendship was born, in my hotel that night (not over wifi) I purchased some accessories for my fruity friend and made myself a little kit of sexyness. Now back in the comforts of my home I begun to configure my router buddy. Setting up usb storage and swap was a sinch and operating it from my nexus 7 (web / ssh) has been a breeze. Unfortunately I have noticed some problems. Firstly I seem to be able to install to USB, although it is an option in the pineapple bar; my little buddy always gets stuck at 75% downloaded. When I do opkg install -dest usb sslstrip over ssh he seems to happily go ahead and install things but I am not rewarded with a sexy tile on the interface. I am able to install things to the internal storage but that doesn't seem to work for sslstrip, nmpa, tcpdump, or anything except wifi manager, jammer, and status. I was really hoping to bring my little buddy on a trip with me next week and test...stuff.... I read on these forums that there are bugfixes, but I know not where to find them.

My little guy would sure appreciate any help he can get, thanks!

Link to comment
Share on other sites

While considering my choices of defcon swag, checking out sexy (overpriced) shirts / hoodies and lockpick sets that I wasn't sure were allowed in overhead luggage I happened upon the pineapple. I had heard of our friend Jasager before and I decided it would be more enjoyable than a hoody... thus a friendship was born, in my hotel that night (not over wifi) I purchased some accessories for my fruity friend and made myself a little kit of sexyness. Now back in the comforts of my home I begun to configure my router buddy. Setting up usb storage and swap was a sinch and operating it from my nexus 7 (web / ssh) has been a breeze. Unfortunately I have noticed some problems. Firstly I seem to be able to install to USB, although it is an option in the pineapple bar; my little buddy always gets stuck at 75% downloaded. When I do opkg install -dest usb sslstrip over ssh he seems to happily go ahead and install things but I am not rewarded with a sexy tile on the interface. I am able to install things to the internal storage but that doesn't seem to work for sslstrip, nmpa, tcpdump, or anything except wifi manager, jammer, and status. I was really hoping to bring my little buddy on a trip with me next week and test...stuff.... I read on these forums that there are bugfixes, but I know not where to find them.

My little guy would sure appreciate any help he can get, thanks!

Half of the things you said there arnt even bugs.

The sslstrip tile is an infusion you get from the Pineapple Bar

Link to comment
Share on other sites

Half of the things you said there arnt even bugs.

The sslstrip tile is an infusion you get from the Pineapple Bar

When I install it from the pineapple bar it gets stuck at 75% for an indefinite amount of time. Or I can install to internal storage in which case the tile appears and tells me sslstrip is not installed and gives me an option to install it which also hangs for an indefinite amount of time.

Link to comment
Share on other sites

A fixed Pineapple Bar has been pushed out.

Grab the update through the pineapple bar!

Best Regards,

Sebkinne

The update allows me to download to USB (including real USB activity!) but the tile still says "not installed" and when I click install to usb within the tile it now does nothing instead of hanging on "loading" (this is accompanied by no USB activity). Also this breaks installing wifimanager to internal storage.

Edited by sys
Link to comment
Share on other sites

The update allows me to download to USB but the tile still says "not installed" and when I click install to usb within the tile it now does nothing instead of hanging on "loading". Also this breaks installing wifimanager to internal storage.

That's an issue with the infusion, not with us.

I know that WhistleMaster has a fix for his infusions. He hasn't uploaded them yet though.

I also just installed WifiManager - no issues here. Try again?

Link to comment
Share on other sites

That's an issue with the infusion, not with us.

I know that WhistleMaster has a fix for his infusions. He hasn't uploaded them yet though.

I also just installed WifiManager - no issues here. Try again?

Yeah after a reboot it worked. I'm sure this has been reported but the pineapple doesn't consistently recognize my alfa-usb if its plugged into the hub at boot. If I unplug it and plug it back in it gets it though.

//edit: also disable ssid broadcast and enable wpa2 will cause the pineapple to be unable to have a wifi connection. Is there a place to report potential bugs?

Edited by sys
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...