Jump to content

Trouble connecting to Pineapple Mark IV's web-based control center on Mac OS X


Go to solution Solved by thesugarat,

Recommended Posts

I cannot connect to the Pineapple's web-based control center on a Mac OS X. I have followed the instructions provided by Chris Haralson's tutorial (link shown below), but, when I enter the ip address 172.16.42.1:1471, nothing happens! Can someone help me out?

Thanks in advance!

Link:

"How to: Configure a Wifi Pineapple for use with Mac OS X"

Steps:
(i) In the "Network" tab, I set the service order (wifi above the ethernet)
(ii) Manually configured the ethernet as
IPv4 address : 172.16.42.42
Subnet Mask : 255.255.255.0
Router: (blank)
Dns server:8.8.8.8

(iii). In the "Sharing" tab, i checked internet sharing with sharing from "wifi" to "ethernet"

(iv). Powered up the Pineapple Mark IV and connected it's PoE LAN port to my Mac OS X 10.8.4 64-bits kernel (Intel-based)

(v). Opened web browser (Safari Version 6.0.5) and entered the ip address 172.16.42.1:1471. Nothing happens here!

Edited by hanaokm
Link to post
Share on other sites

Use a different device to log onto the pineapples broadcasted WiFi. Go to the control page 172.16.42.1:1471 and look in the top right hand corner. If you have that configuration turned on for your Mac you should see an IP address in there like 192.168.2.X. Go back to Safari on your Mac and type in that IP address with a :1471 on the end. i.e. http:\\192.168.2.X:1471

That should get you to the control page. That video is misleading...

Link to post
Share on other sites

thesugarat,

first of all, thanks for your reply!

So here is what's going on:

(1) if I connect the Pineapple Mark IV to a PC with the ethernet cable hooked to the PoE LAN port, I'm able to access the Pineapple's web-based control center (PCC) from the same PC and from an another device (i.e Mac). Everything works flawlessly!

Now,

(2) if I connect the Pineapple to a Mac, I'm not able access the PCC. Not from the Mac, neither from an another device (PC).

Any clues?

Edited by hanaokm
Link to post
Share on other sites
  • Solution

Ok I don't understand number 2. Are you setting the Ethernet port on the Mac to the manual IP address of 171.16.42.42 hooked to the POE/LAN port and leaving out the Internet connection sharing part on the Mac? As long as you don't turn that on it should work. And having it in that configuration should not prevent you from using another device to connect to the pineapple's wifi.

Link to post
Share on other sites

Yeah you should be typing in http:\\172.16.42.1:1471 when using the POE LAN port.

The tricky part of using a Mac with the pineapple is when you turn on the ICS on the MAC.

Link to post
Share on other sites

Problem solved. Thanks again, thesugarat!!!

To all fellow Mac users, here are the steps to connect to Pineapple Mark IV's web-based control center:

(i) Open "System preferences"

(ii) In the "Network" tab, set the service order (wifi above the ethernet)
(iii) Manually configure the ethernet as
IPv4 address : 172.16.42.42
Subnet Mask : 255.255.255.0
Router: (blank)
Dns server:8.8.8.8

(iv) Power up the Pineapple Mark IV and connect it's PoE LAN port to your Mac's ethernet port

(v). Open a web browser (e.g. Safari) and enter the ip address 172.16.42.1:1471.

Link to post
Share on other sites

Glad I could help. I use a Mac as well and it works well for my needs.

Just so you know, your step (ii) is not needed. That step is in the video because he's trying to show how to do Internet connection sharing of the Macs Internet ( from its wifi card) to the pineapple. Which works, but again it's tricky. Happy hunting!

Link to post
Share on other sites
  • 4 weeks later...

I have similar problems, followed the instructions in the video and I can connect to http://172.16.42.1:1471/ from my mac(mountain lion). But then I turn on the internet sharing I can not connect to the pineapple anymore.

Then I tried with

# set

sudo defaults write /Library/Preferences/SystemConfiguration/com.apple.nat NAT -dict-add SharingNetworkNumberStart 172.16.42.0

and then I turn on the sharing still the same problem. I get the following from ipconfig(en1 is the thunderbolt connection):

en1: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
options=b<RXCSUM,TXCSUM,VLAN_HWTAGGING>
ether a8:20:66:27:d1:10
inet6 fe80::aa20:66ff:fe27:d110%en1 prefixlen 64 scopeid 0x6
media: autoselect (100baseTX <full-duplex,flow-control>)
status: active
bridge0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
ether ac:de:48:31:be:c1
inet 172.16.42.1 netmask 0xffffff00 broadcast 172.16.42.255
Configuration:
priority 0 hellotime 0 fwddelay 0 maxage 0
ipfilter disabled flags 0x2
member: en1 flags=3<LEARNING,DISCOVER>
port 6 priority 0 path cost 0
Any ideas what is wrong?
Edited by lodakai
Link to post
Share on other sites

Yes I know what is wrong.... This is a known issue with Mac ICS and is covered in my post titled "Mac Ics Works". It's also covered in the howto on the pineapples wiki under Mac ICS Option 2.

When you turn on ICS in Mountain Lion, under the hood, it changes the IP range to 192.168.2.X and does not tell you. Turn on ICS and use another device to connect to the Pineapples wifi AP and login to the Control Center from that device. In the Network settings tab (3.0.0) or the top right corner in 2.8.1 you'll see an IP address in the WAN/LAN section. It will look like 192.168.2.X because of the OSX ICS. Use that IP address while back on you Mac but with a :1471 at the end i.e. 192.168.2.5:1471 and that should get you access to the Pineapple Control Center without using another device. Then, in order to make ICS work properly you'll need to bridge the 192.168.2.x range to the 172.16.42.1 range using the Network Manager/WiFi Manager infusions ICS tab. Set it for ethX to br-lan... Essentially you need two different ICSs when dealing with OSX and the Pineapple. One on the Mac and one on the Pineapple.

Link to post
Share on other sites

I seem to recall Windows 7 having this issue, when you would set windows equivalent of eth0 to 172.16.42.42, then bridge/share with a wireless interface, it would change eth0 back to 192.168.1.137. Which isn't even my routers normal IP range, lol.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...