Jump to content

Connecting Mark IV disrupts laptop wifi connect


Recommended Posts

Hello, I'm running linux mint and have never had a problem connecting to a wireless access point on wlan0 and keeping the connection for hours.

However, once connected to the wireless access point and then plugging in the network cable that runs from the Mark IV with the most recent version of pineapple OS, my wireless connection is disrupted or disconnected altogether.

Any obvious reasons why this might happen?

I run the script wp4.sh and everything connects properly, but shortly thereafter I lose my wifi signal on the laptop.

An ifconfig still shows the wlan0 with the proper ip address from the wireless router, but I cannot ping anything or access the net.

Help appreciated.

Link to post
Share on other sites

Doesn't Mint use Wicd as the network manager? Try removing the Eth port from being managed in there. There are a few posts here about this issue.

Link to post
Share on other sites

Stupid/simple trick to try. In the network manager edit the eth0 connection and uncheck the box that says use that interface by default. Otherwise you will connect to your target WAP with wlan0 and have connectivity, but when you plug in or ifup eth0 the network manager will flip you over to that interface thereby breaking your wlan connection.

Right click on the network manager icon, select wired tab, select wired 1, click edit, uncheck "connect automagically".

kali_network_capture.jpg

Link to post
Share on other sites

Yeah, I'm sure this isn't new. It's just fresh on my mind because I ran into earlier this week with a fresh kali install. Took me 10 minutes of swearing and editing the interfaces file before I remembered to turn that off.

Link to post
Share on other sites

Okay I've unchecked that and it seems to be working properly. Thanks! Here's a stupid questions: what's the difference between "Automatic (DHCP)" and "Automatic (DHCP) addresses only" in the IPv4 settings tab? I can't slice the semantic differences here and can't find an answer through Google.

I was wondering if this might have something to do with the problem.

Thank you.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...