Jump to content

DNS redirection to Apache doesn't work


Etus
 Share

Recommended Posts

Hello,

I have a problem with my setup that i've been trying to fix for a few days now. After many searched on google, I wasn't able to fix my problem.

I'm testing DNSSpoofing. I'm running Kali Linux on VM, I setup an Apache2 server on it and cloned a website to put it on my /var/www folder.

I used dnsspoof to spoof the dns of the website I cloned on one of my computers over LAN.

The problem is this - when I try to enter the website using the local ip of the VM, it works.

But when I enter the URL, dnsspoof does detect the packet and does redirect the computer to the correct IP (I also tested it on the spoofed computer using nslookup), but then I get "server not found" error.

I could also see the spoofed ip address getting sent back to the victim on wireshark.

It worked a few days ago and I have no idea what changed.

I am, of course, doing arp poisioning(using arpspoof) on the target alongside with dnsspoof.

I tried to play with iptables to fix it but that didn't work. Port 80 isn't blocked since I can view the site using the local ip. I have no idea what could be the problem.

Any help appreciated!

Edited by Etus
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...