Jump to content

Problem Installing Infusions


Recommended Posts

OK...

When I goto the pineapple bar and click on

List available Infusions (aka modules)

I am then presented with a list of available infusions such as sslstrip etc...

Regardless of the infusion I choose... when I click on install (internal or USB) the page just hangs with the message

Please wait, the infusion is being downloaded and installed.
Depending on network speed and infusion size, this could take a while.

I've left it like this for hours but nothing ever installs.

Things to note...

When I first powered the device and update to 2.8.1 the Pineapple Bar worked perfectly but because I had no USB storage I was limited. The problem with the Pineapple bar only started after I configured a USB stick with a swap partition.

I have an 8GB USB stick configured for swap file and data... this all shows up correctly on both the USB & Resources pages.

I have reset & re-flashed to 2.8.1 several times but no joy.

Tried using the Pineapple Bar without having the USB configured but no joy.

I can putty(ssh) into the box and use opkg install --dest usb sslstrip and it does install, but nothing shows in the pineapple web interface.

The USB ext4 partitions were created in debian linux.

Does anyone have any ideas ??

Link to comment
Share on other sites

I recall an incident a while back similar to this that ended up being the users ISP filtering the wifipineapple.com domain, which is where the packages are downloaded from. Can you access that domain?

Are you saying you were able to install modules before you updated to 2.8.1?

Seb, might there be a manual install process?

Link to comment
Share on other sites

I was able to install modules fine with 2.8.1 it was only after setting up a USB stick (as per the manual) was I no longer able to install any modules to any location.

No amount of un-configuring the USB, system resetting or firmware re-flashing will fix the problem.

Link to comment
Share on other sites

Yeah that's most likely your problem....

http://forums.hak5.org/index.php?/topic/29319-usb-power-cable-not-enough-for-usb-sandisk/?hl= usb power

The pineapple can run from 5v 1a power but if you try to run it from that with a thumb drive with a heavy power requirement plugged in you get strange results... Try everything while the pineapple is plugged into the wall plug and see if it's stable.

This is also related to the Sandisk Cruzser on Pineapple Juice issue that Darren just recently resolved...

Link to comment
Share on other sites

Definitely NOT a power problem... I have found a way to install infusions manually via SSH.

If I paste the following into a text editor and replace $name with the name of the infusion and $version with the version of the infusion then copy and paste from the text editor into the ssh console then the infusion installs to my USB perfectly...

************************************************************************************************************************************

mkdir -p /usb/tmp/infusions
wget -O /usb/tmp/infusions/mk4-module-$name-$version.tar.gz "http://cloud.wifipineapple.com/index.php?downloads&downloadModule=$name&moduleVersion=$version"
mkdir -p /usb/infusions/
rm /pineapple/infusions/usbModules
ln -s /usb/infusions /pineapple/infusions/usbInfusions
tar -xzf /usb/tmp/infusions/mk4-module-$name-$version.tar.gz -C /usb/tmp/infusions/
config=$(cat /usb/tmp/infusions/mk4-module-$name-$version/module.conf)
confName=$(echo "$config" | grep -i name | awk '{split($0,array,"=")} END{print array[2]}')
confVersion=$(echo "$config" | grep -i version | awk '{split($0,array,"=")} END{print array[2]}')
confAuthor=$(echo "$config" | grep -i author | awk '{split($0,array,"=")} END{print array[2]}')
confStartPage=$(echo "$config" | grep -i startPage | awk '{split($0,array,"=")} END{print array[2]}')
confSupportLink=$(echo "$config" | grep -i supportLink | sed 's/supportLink=//g')
mv /usb/tmp/infusions/mk4-module-$name-$version/$confName /usb/infusions/
rm -rf /usb/tmp/infusions
echo "$confName|$confVersion|$dest|$confStartPage|$confSupportLink" >> /pineapple/infusions/moduleList
opkg update && opkg install $name --dest usb
*****************************************************************************************************************************************
The last line is only needed if a package is required for the infusion...
It seems to work fine for me but not an ideal solution.... when I get time I will investigate further as to why the whole procedure is not reaching this point...
Link to comment
Share on other sites

  • 2 weeks later...

I found the problem my end, basically when you access the pineapple from via your network and the Wan/Lan port on the pineapple installing infusions fails with the symptoms discussed above. If you connect via the PoE Lan port however and the 72.16.42.1:1471/ interface then all works as it should.

Not sure why we can't install and control the pineapples full feature set from a dhcp assigned ip on the Wan/Lan port.


Cheers,

Jay

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...