Jump to content

wps button and shell scripting, can't use screen! help!

Recommended Posts

My script works perfect if I execute it from ssh, but when I try to execute it via wps button everything works except using screen command so I can run tcpdump in the background and use screen to view progress later.

I have tried different methods, from executing the script on ssh from the wps button to putting the actual code in the wps button textfield (in the gui)

I have tried these different combination of switches


screen -d -m

screen -d -m -S

screen -S

screen -dm

screen -dmS

and still will not start screen windows if I do it via WPS buttong. Like I mentioned before if i do it within ssh, whether its bash ./script.sh or sh ./script.sh it runs just fine, and I don't know what to do. I want to make it independent so I don't have to have a tablet/laptop attached to it at all time. or briefly.

if anybody has any recommendations I would greatly appreciate it.

BTW I have been using this wifi connect script inside my script (it was a last minute type thing) http://forums.hak5.org/index.php?/topic/29487-wifi-connect-script-updated-v12/

Edited by demonjester
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...