Jump to content

ICS on Windows 7


Go to solution Solved by 3lohim,

Recommended Posts

Hello everyone. PLease for give me if I am asking a question that has already been posted. I have looked everywhere and can not find the answer. Everywhere = google and hak5 forum. Maybe I am not using the correct terminology. I am very new to this and thought a good first project would be setting up ics in windows 7. I have followed all of the guides I can find and nothing is working. Turned on shared connection on the wirless adapter ipv4 settings and changed the lan to 172.16.42.42. Please excuse me for my ignorance. Am I missing something? Is there something I should be configuring in the pineapple. Im not looking for a free ticket, I would like to learn how everything works with research. Could someone point me in the right direction of reading material. I am at a loss and have been trying to figure it out for days now.

Link to post
Share on other sites

What seems to be the problem? Can you ssh to 172.16.42.1 using Putty? Does your pineapple broadcast an AP called "Pineapple ##:##" when you turn it on? Are you making sure you connect using the POE/WAN port, not the other one? Are you connecting to http://172.16.42.1:1471 (or whatever the specific port is, i'm not 100% but I know it isn't 80).

Link to post
Share on other sites

What seems to be the problem? Can you ssh to 172.16.42.1 using Putty? Does your pineapple broadcast an AP called "Pineapple ##:##" when you turn it on? Are you making sure you connect using the POE/WAN port, not the other one? Are you connecting to http://172.16.42.1:1471 (or whatever the specific port is, i'm not 100% but I know it isn't 80).

It's 1471. Follow the instructions again on the Wiki.

-Foxtrot

Link to post
Share on other sites

If its just accessesing the web gui, as above. If its setting up ICS, sharing the internet on your computer via an ethernet cable connected to the pineapple, then make sure you have windows firewall on, wont work if its turned off. On the lan for the pineapple, make sure 255.255.255.0 subnet mask and 8.8.8.8 set for primary dns.

Also just after you enable sharing for the pineapple lan adapter on your internet facing adapter on your computer, go back and make sure 172.16.42.42, 255.255.255.0 subnet mask and 8.8.8.8 dns are still set as windows 7 will try to change these to 192.168.137.1 something if i remember correctly.

Link to post
Share on other sites
  • Solution

Hey everyone Thank you for your prompt replies. I have figured it out. I had to edit registry [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Parameters

and change IP address in “ScopeAddress”,”ScopeAddressBackup” to 172.16.42.42

found this here http://www.jpuddy.net/2009/changing-the-dhcp-range-for-internet-connection-sharing-in-windows-7/

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...