Jump to content

Clients CAN connect but CANNOT surf


Munch
 Share

Recommended Posts

hi

i just got my pineapple (so happy), anyways i set it up like how it says in the leaflet,

i follow the wp4.sh script and can get to the pineapples control gui no probs, basicly everything is ok

apart from clients can connect to the AP and get assigned an ip but CANNOT surf the net.

i ping the pineapple from my laptop and its replying so thats ok there...


my question is do i need to edit iptables at this point ?


how i got things setup

Laptop running backtrack 5

Laptop on wlan0 facing the net via my home network (will change to wlan1 awus-nha later)

Laptop Lan connected to pinapples Poe Lan


if its just a case of adding a rule to the iptables could someone paste the rule or rules please ?.


any help is much appreciated :)

Edited by Munch
Link to comment
Share on other sites

Do you have the Network Manager Infusion installed? Try the ICS tab in network manager and bridge wlan0 to br-lan or whatever eth port... That's probably the easiest way to get people that connect to the pineapple wifi connected internet provided to the pineapple...

Link to comment
Share on other sites

yeah im sure i have it installed cos when i goto pinapplebar it says "unpin from navbar" and "remove" so my guess is that its installed , when i click on network manager in navbar i get to the page but theres nothing there apart from where it says network manager. hmm

Link to comment
Share on other sites

*facepalm , think i have it now , i noticed firefox was blocking java for the page which has the controls, it seems to be working now but noticed only on wlan0 ?

i was feeding my laptop internet from wlan1 instead of wlan0 but when i goto network manager it will only show wlan0 ?

so i then redone the setup but this time use wlan0 and its running fine.

i want to use my awus-h antena and not laptops antena. hmm

thanx for replying btw :)

UPDATE: in ICS i put share from wlan0 to eth0 correct ?

its not working again, it was working for about 5 mins then i duno what hapend. its teething :(

Edited by Munch
Link to comment
Share on other sites

thanx for the replys... after reading around the forums here i decided to remove WICD (which for some reason it wont uninstall) and get network-manager-gnome, as system boots up wicd is still running so ive just used killall wicd cmd.
i got network-manager-gnome by following....

sudo apt-get install network-manager-gnome
cp /etc/network/interfaces {.stock}
echo "auto lo" > /etc/network/interfaces
echo "iface lo inet loopback" >> /etc/network/interfaces
then reboot:
sudo apt-get remove wicd (which didnt work for me as its still on my system) :(
rebooted again:
killall wicd
service network-manager start
nm-applet &
..
to start i connect to internet via network-manager-gnome wifi wlan0
then plug in pineapple to etho and run wp4.sh and follow the setup, the network manager auto connects the wifi connection to wired.
i then went in networkmanager gui on the pineapple and went into ICS and set
share internet from wlan0 to br-lan
..as it is now its running and has been for about an hr now all fine.
i will update this thread if i run into more critters.

UPDATE::

pineapples been running now in karma mode for over 4hrs now :)

im using a powerbank 5v 8000mah 2x usb ports and its holding up nicely (£17 from ebay)..

in the mean time i wrote a bash script to help things along in backtrack , fired it up and im now running sslstrip,ettercap,urlsnarf all from bt5 and have tested out the login pages etc and all it fine :)

right now im not running anything on the pineapple , just karma and wireless... i didnt realise i was away from backtrack aslong as i was lol , im still on BT5 R1

Edited by Munch
Link to comment
Share on other sites

back to square 1 , it was working all fine 1 day then the next day it dont let clients surf , once again it assigns ip etc but just no internet.

wicd dont even startup on bootup now even. i edited the conf

in pineapple networkmanager ICS i should have share from wlan0 to br-lan correct ?

once i plugin eth0 , the network manager says auto connecting to wlan0 , is this correct ?

in my network-manager-gnome settings i have both wireless and wired set to auto connect , is this correct ?

i end up with a network icon telling me "wired network connection auto eth0 is active.

i just cant see how it was all working with karma, sslstrip etc 1 night and then next time i booted up its gone back to how it was, im not doing nothing different.

hmm

UPDATE:

had a brain fart. in my connection manager on laptop i just needed to tell it NOT to autoconnect to wlan0 and im up and running again , sorry for the useless post as ive answered myself.

Edited by Munch
Link to comment
Share on other sites

  • 4 months later...

ok so ive finally updated to kali 1.05 .. now my problem is im getting these 2 lines when i run the wp4.sh script..

SIOCDELRT: No such process

SIOCDELRT: Netowork unreachable

The pineapple boots ok and i can surf to control panel and everything seems fine until i connect to the network using another pc , no internet but im connected to network ?

any help is appreciated.

its ok ive got it now.

Edited by Munch
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...