Jump to content

[Release][Stable] 2.8.1 - The Final 2.X Release!


Sebkinne
 Share

Recommended Posts

Hey everyone,

As most of you know, we have re-launched our beta testing system and it has been a great success! You, the community, has helped us iron out the issues we had in the last stable release and we are confident you will appreciate the fixes in this version.

The main issue we had was a bug in the WiFi driver causing some issues with Karma, monitor mode and client mode. These along with a few other issues have been resolved!

Changelog:

- Fixed Karma associations
- Fixed client mode issues
- Fixed monitor mode hopping
- Fixed USB network card issues
- Small bugfixes
- Included WhistleMaster's Phials script (renamed to phials instead of phials.sh). Thank you for this WhistleMaster!

We feel like most of the issues that have been cropping up lately have been fixed with this release.

Now, as the title says, this will be the last release in the 2.X version level. We are now fully focusing on the 3.0 release, so stay tuned for updates about that along the way.

Please also note, we have dropped official support for the AWUS036H. It works but has issues in some areas. We fully support the NHA which is sold from the hakshop!

Download: Over the air through the web-interface. (alternatively at http://wifipineapple.com)

MD5: 17e4384a79e7fef9c267f7da34ed4743
Note: If coming from a firmware version below 2.6.4, wait for the pineapple to fully boot back up after flashing then navigate to http://172.16.42.1:1471

As usual, please leave any feedback in this thread.

We hope you enjoy this release, we feel this is paving the final stones to 3.0!
-The Jasager Team

Link to comment
Share on other sites

  • Replies 54
  • Created
  • Last Reply

Top Posters In This Topic

Thank you all for the continued work! I have been hanging around the forums for a bit now, but only just registered, for whatever reason. (I started playing with the beta a few days ago, but will be flashing stable today at work...err, at lunch lol). It is very cool that WM's script has been rolled up as well.

This is one of the most interesting projects I have come across in the last year or so, and I just wanted to chime in to say that your time and effort is very much appreciated.

Edited by Status_Fugged
Link to comment
Share on other sites

Urp, looks like this update bricked mine :( Went from 2.8.0. Had USB drive plugged in, nothing turned on. I updated via the web page and it's been sitting there for ~2 hours. I can't ping/ssh/get to the web GUI anymore :(

How do I recover it?

Link to comment
Share on other sites

In my case, doing web based upgrade, It aked me to remove the USB, did the upgrade, asked me to re insert USB (to restore the back up) and voilla... All all ina ll about 10 minutes including two resets.. If it does not respond at all, after a while it will just kick you of the page, if not try to log in on another tab..

Link to comment
Share on other sites

I've never had luck with choosing the option to keep my infusions. It's always been easier to backup my infusions folder and moduleList. Now that Whistle Master wrote the phials script its painfully easy to just reinstall em. Doing a "phials -I usb" installs all the infusions in like 3 minutes. And if u like to keep them sorted in a particular order like me just keep a backup of your /pineapple/infusions/moduleList and copy it over after it's done.

Kyhwana try doing a factory reset via the button on the bottom of your Pineapple. If after that you still can't get the WPS light blinking when you boot up you're probly bricked and need a Serial/USB cable... If right now when u boot up the WPS light blinks u probly just need to resetup your ICS/IP settings.

Link to comment
Share on other sites

Oh, I chose not to keep my infusions.. it updated OK after I removed the USB drive, however now as soon as I plug the USB flash drive (correctly formatted and worked in 2.8.0) in it reboots and locks up. I have to remove the drive and reboot it :(

Will see if I can get some logs or something out of it..

Link to comment
Share on other sites

Upgraded to 2.8.1 last night and had some interesting results. I tried the option to Upgrade but Keep my Infusions and that just didn't work. It kept asking me to unplug my USB drive and replug it back in. I would do that but nothing would happen so I just upgraded it without the USB drive installed. I then erased the old infusion files from the USB partion and installed it back in the pineapple. I updated fstab and ran the mkswap command and rebooted. Looked to be working perfectly at that point. Then I proceeded to install all the insusions. Two went to Internal and the rest went to USB. After installing them I cliked on each one to perform the needed steps for each infusion. Like installing nmap to the USB drive. Some of the infusions worked correctly and some did not. The Reaver module gave me the most trouble. I'd hit Install and check the USB box and it would run but it would still say uninstalled. I got to the point that I tried to Unpin it from the navbar and uninstall and it appeared not to work because the list of installed infusions stayed the say and it kept saying it was installed but when I click on it it does not work. Also, the Network Manager infusion gave me similar problems. I tried to setup an ICS but once I hit save it gave a strange error on the screen about not having enough memory. I'm typing all this from memory so I'm just generalizing.... I'm going to erase the USB drive partitions tonight and install all of the infusions from scratch. I might try that phials script mentioned above if that doesn't work.

Link to comment
Share on other sites

  • 2 weeks later...

You guys shouldn't even be selling pineapple it's that badly implemented. Why don't you guys spend more money on your development than on your tv show production just a bit... surely u are making a crapload from ads.

I don't really see your problem. Feel free to elaborate.

Link to comment
Share on other sites

Sorcerer,

Try unplugging your AWUS036H and booting your pineapple. Once the pineapple is up plug in the 36H and setup for wifi jamming as you normally would.

Link to comment
Share on other sites

The manual upgrade does not work??? Why?

I downloaded the upgrade-2.8.1.bin

I placed the MD5 code into the window 17e4384a79e7fef9c267f7da34ed4743

clicked upgrade and nothing happens

My url changes to : http://172.16.42.1:1471/index.php?upgrade

And it just sits there for 15-20 mins and there is no progress bar or any indication that anything is happening on the pineapple device.

Any ideas? What to do next?

I tried checking for upgrades but always get a no connect error even though I'm connected.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...