Jump to content

"wireless" not re-enabling. please help.


Go to solution Solved by Foxtrot,

Recommended Posts

"wireless" is not re-enabling. please can somebody help me fix it without restoring to factory defaults as i have already installed all modules so i don't want to do it over again.

i think this started to occur once i selected "remove config", inside "networking tab".

Link to post
Share on other sites

"wireless" is not re-enabling. please can somebody help me fix it without restoring to factory defaults as i have already installed all modules so i don't want to do it over again.

i think this started to occur once i selected "remove config", inside "networking tab".

I am presuming you mean the Network Manager module... If so, just click in the right hand side where it says "Detect Automatically" or something like that...

Provide more details.

-Foxtrot

Link to post
Share on other sites

yes i mean the network manager tab inside of the mark 4 pineapple. detect automatically button did nothing new, that button is for when you plug in an alfa network card but i am not trying to use an external network card at the moment. My problem is in the "Network manager" logical interface will no longer enable and also if i go to the "status" tab the wireless button will no longer enable, both related and im 100% sure on that.

Edited by --nick--
Link to post
Share on other sites
  • Solution

Replace your /etc/config/network with the one below :

# Copyright © 2006 OpenWrt.org

config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr 172.16.42.1
option netmask 255.255.255.0
option gateway 172.16.42.42
option dns 8.8.8.8

config interface wan
option ifname eth1
option proto dhcp

config switch eth0
option enable_vlan 1

config switch_vlan
option device eth0
option vlan 1
option ports "0 1"

config interface usb
option ifname usb0
option proto dhcp

Then replace your /etc/config/wireless with this one :

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr '[REPLACE WITH YOUR MAC ADDRESS]'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'

config wifi-iface
option device 'radio0'
option mode 'ap'
option ssid "pineapple"
option network 'lan'
option hidden '0'

Edited by Foxtrot
Link to post
Share on other sites

i have a small problem now that i just noticed on the pineapple mk4. i can't get the internet to passthrough from my pc to the pineapple anymore. i have used ics on my windows pc and changed the ip to 172.16.42.42 like how i used to get the internet to work, except now it does not work. \

can somebody please tell me why the ics does not work on my windows 7 anymore?

or maybe what i can additionally try is to configure the ics setting inside of the pineapple mk4 gui itself? if so , change to what? brlan to wlan0?

Link to post
Share on other sites

well, the new modules show up in the gui for download, so there is internet up to the mk4 ui standpoint. However, when i connect a second laptop to my pineapple mk4 access point that was made with windows ics and try google in the browser there is no google connection displayed.

alternatively when i use windows bridging instead of ics it works. this is strange because i never had a problem with ics before. windows ics is how i was always doing this setup before.

Edited by --nick--
Link to post
Share on other sites

yes, in the poe/lan.

Try booting a live CD of Kali/backtrack/ubuntu and running the wp4.sh and make sure the network manager has "Automatically configure" turned off for your devices. See if it works that way.

Link to post
Share on other sites

Did you forget to fix the ICS settings in Network Manager after you fixed your config files? The problem could possibly be caused by 'Enable at Boot' being checked and 'none' in both of the drop downs

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...