Jump to content

can't load library 'libpcap.so.1.1'


pinepine
 Share

Recommended Posts

Hey guys,

My vesion of Mark IV is 2.7.7 . I installed nmap using opkg install nmap. When I wanted to run it I got an error "nmap: can't load library 'libpcap.so.1.3' " . So I removed this libpcap with opkg remove a installed newer one from repository (1.3). Nmap worked perfectly, but when I wanted to run dnsspoof wrote me down can't load library 'libpcap.so.1.1'

I was searching internets to get this .bin, but I couldn't find it.

Can anyone help me?

Thanks a lot!

Link to comment
Share on other sites

Hi all,

I'm a newcomer to the world of the Pineapple but I'm already having the same issue that pinepine mentioned. I updated the libpcap package using okpg, and that installed version 1.3. tcpdump works just fine, but lots of other infusions (dnsspoof, sslstrip, etc) no longer worked because libpcap 1.1 wasn't able to be found. After a bit of searching I found that the symlinks for libpcap.so.1.1 and libpcap.so.1.1.1 located in /overlay/usr/lib were invalid.

After a bit of digging around I found that libpcap.so.1.1.1 lived in the /rom/usr/lib/ folder. To resolve the issue I did the following:

# cd /overlay/usr/lib
# cp /rom/usr/lib/libpcap.so.1.1.1 .
# rm libpcap.so.1.1
# ln -s libpcap.so.1.1 libpcap.so.1.1.1

I did this because that's how all the references were set up for 1.3, so I just followed suit. From there I was able to run the other infusions without an issue. I hope that helps!

OJ

PS. It'd be great if the other infusions could be updated to the new version of libpcap so that Pineapple users don't have to worry about this.

Edited by TheColonial
Link to comment
Share on other sites

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...