Jump to content

I'm almost there with my MF820D 3G/4G dongle


Semtx
 Share

Recommended Posts

Hi All,

I've worked a lot on this, and have come so far that that the dongle connects. But it only lasts briefly, because it disconnects just after connect.

I've tried everything, and I hope someone here can verify my configuration.

This is the interesting part of /pineapple/3g/3g.sh:

*19d2:0167*|*19d2:0167*) echo "ZTE MF820D (Telia) detected. Attempting mode switch"
                uci delete network.wan2
                uci set network.wan2=interface
                uci set network.wan2.ifname=ppp0
                uci set network.wan2.proto=3g
                uci set network.wan2.service=umts
                uci set network.wan2.device=/dev/ttyUSB2
                uci set network.wan2.apn=www.internet.mtelia.dk
                uci set network.wan2.username=
                uci set network.wan2.password=
                uci set network.wan2.defaultroute=1
                uci commit network
                echo "Usb modeswitch"
                usb_modeswitch -v 19d2 -p 0166 -V 19d2 -P 0167 -M 55534243123456782400000080000685000000240000000000000000000000 -m 0x01 -n 0 -s 20
                echo "Removing usbserial mod"
                sleep 10; rmmod usbserial
                echo "Inseting usbserial mod"
                sleep 3; insmod usbserial vendor=0x19d2 product=0x0167
#               sleep 5; /etc/init.d/firewall disable; /etc/init.d/firewall stop
#               logger "3G: firewall stopped"
                echo "Setting up iptables"
                iptables -t nat -A POSTROUTING -s 172.16.42.0/24 -o 3g-wan2 -j MASQUERADE
                iptables -A FORWARD -s 172.16.42.0/24 -o 3g-wan2 -j ACCEPT
                iptables -A FORWARD -d 172.16.42.0/24 -m state --state ESTABLISHED,RELATED -i 3g-wan2 -j ACCEPT

                ;;

I've removed the firewall part as it fails anyways.

This is /etc/chatscripts/3g.chat:


ABORT   BUSY
ABORT   'NO CARRIER'
ABORT   ERROR
REPORT  CONNECT
TIMEOUT 10
""      "AT&F"
OK      "ATE1"
OK      'AT+CGDCONT=1,"IP","$USE_APN"'
ABORT   'NO CARRIER'
OK      "AT+ZSNT=0,0,0"
SAY     "Calling UMTS/GPRS"
TIMEOUT 20
OK      "ATD*99#"
CONNECT ' '

And lastly here is the interesting part of /etc/config/network:


config interface 'wan2'
        option ifname 'ppp0'
        option proto '3g'
        option service 'umts'
        option device '/dev/ttyUSB2'
        option apn 'www.internet.mtelia.dk'
        option defaultroute '1'

Probably as part of the new pineapple firmware, the dongle does a modechange, which took me a while to see.

So this happens automaticly at bootup:

Jan  1 00:00:41 Pineapple user.notice usb-modeswitch: 1-0:1.0: Manufacturer=Linux_3.7.9_ehci_hcd Product=Generic_Platform_EHCI_Controller Serial=ehci-platform
Jan  1 00:00:41 Pineapple user.notice usb-modeswitch: 1-1:1.0: Manufacturer=ZTE,Incorporated Product=ZTE_LTE_Technologies_MSM Serial=?
Jan  1 00:00:42 Pineapple user.notice usb-modeswitch: 1-1:1.1: Manufacturer=ZTE,Incorporated Product=ZTE_LTE_Technologies_MSM Serial=?
Jan  1 00:00:42 Pineapple user.notice usb-modeswitch: 1-1:1.2: Manufacturer=ZTE,Incorporated Product=ZTE_LTE_Technologies_MSM Serial=?
Jan  1 00:00:42 Pineapple user.notice usb-modeswitch: 1-1:1.3: Manufacturer=ZTE,Incorporated Product=ZTE_LTE_Technologies_MSM Serial=?
Jan  1 00:00:42 Pineapple user.notice usb-modeswitch: 1-1:1.4: Manufacturer=ZTE,Incorporated Product=ZTE_LTE_Technologies_MSM Serial=?

And the lsusb -v looks like this:


Bus 001 Device 003: ID 19d2:0167 ZTE WCDMA Technologies MSM
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0        64
  idVendor           0x19d2 ZTE WCDMA Technologies MSM
  idProduct          0x0167
  bcdDevice            0.00
  iManufacturer           3 ZTE,Incorporated
  iProduct                2 ZTE LTE Technologies MSM
  iSerial                 0
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength          138
    bNumInterfaces          5
    bConfigurationValue     1
    iConfiguration          1 ZTE Configuration
    bmAttributes         0xe0
      Self Powered
      Remote Wakeup
    MaxPower              500mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol    255 Vendor Specific Protocol
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval              32
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval              32
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol    255 Vendor Specific Protocol
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval              32
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval              32
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        2
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol    255 Vendor Specific Protocol
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval              32
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x03  EP 3 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval              32
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        3
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol    255 Vendor Specific Protocol
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x84  EP 4 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               5
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x85  EP 5 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval              32
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x04  EP 4 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval              32
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        4
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol    255 Vendor Specific Protocol
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x86  EP 6 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               5
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x87  EP 7 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval              32
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x05  EP 5 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval              32
Device Qualifier (for other device speed):
  bLength                10
  bDescriptorType         6
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0        64
  bNumConfigurations      1
Device Status:     0x0000
  (Bus Powered)

Here is how the log looks just after i run my 3g.sh script:

Jan  1 00:06:01 Pineapple user.notice root: 3G: Connection Script here, searching for modems
Jan  1 00:06:13 Pineapple kern.info kernel: [  373.150000] usbserial: USB Serial deregistering driver generic
Jan  1 00:06:13 Pineapple kern.info kernel: [  373.160000] usbcore: deregistering interface driver usbserial_generic
Jan  1 00:06:13 Pineapple kern.info kernel: [  373.160000] usbcore: deregistering interface driver usbserial
Jan  1 00:06:16 Pineapple kern.info kernel: [  376.210000] usbcore: registered new interface driver usbserial
Jan  1 00:06:16 Pineapple kern.info kernel: [  376.210000] usbcore: registered new interface driver usbserial_generic
Jan  1 00:06:16 Pineapple kern.info kernel: [  376.220000] usbserial: USB Serial support registered for generic
Jan  1 00:06:16 Pineapple kern.info kernel: [  376.220000] usbserial_generic 1-1:1.0: The "generic" usb-serial driver is only for testing and one-off prototypes.
Jan  1 00:06:16 Pineapple kern.info kernel: [  376.230000] usbserial_generic 1-1:1.0: Tell linux-usb@vger.kernel.org to add your device to a proper driver.
Jan  1 00:06:16 Pineapple kern.info kernel: [  376.240000] usbserial_generic 1-1:1.0: generic converter detected
Jan  1 00:06:16 Pineapple kern.info kernel: [  376.250000] usb 1-1: generic converter now attached to ttyUSB0
Jan  1 00:06:16 Pineapple kern.info kernel: [  376.260000] usbserial_generic 1-1:1.1: The "generic" usb-serial driver is only for testing and one-off prototypes.
Jan  1 00:06:16 Pineapple kern.info kernel: [  376.270000] usbserial_generic 1-1:1.1: Tell linux-usb@vger.kernel.org to add your device to a proper driver.
Jan  1 00:06:16 Pineapple kern.info kernel: [  376.280000] usbserial_generic 1-1:1.1: generic converter detected
Jan  1 00:06:16 Pineapple kern.info kernel: [  376.280000] usb 1-1: generic converter now attached to ttyUSB1
Jan  1 00:06:19 Pineapple daemon.notice pppd[1855]: pppd 2.4.5 started by root, uid 0
Jan  1 00:06:20 Pineapple local2.info chat[1859]: abort on (BUSY)
Jan  1 00:06:20 Pineapple local2.info chat[1859]: abort on (NO CARRIER)
Jan  1 00:06:20 Pineapple local2.info chat[1859]: abort on (ERROR)
Jan  1 00:06:20 Pineapple local2.info chat[1859]: report (CONNECT)
Jan  1 00:06:20 Pineapple local2.info chat[1859]: timeout set to 10 seconds
Jan  1 00:06:20 Pineapple local2.info chat[1859]: send (AT&F^M)
Jan  1 00:06:20 Pineapple local2.info chat[1859]: expect (OK)
Jan  1 00:06:20 Pineapple local2.info chat[1859]: AT&F^M^M
Jan  1 00:06:20 Pineapple local2.info chat[1859]: OK
Jan  1 00:06:20 Pineapple local2.info chat[1859]:  -- got it
Jan  1 00:06:20 Pineapple local2.info chat[1859]: send (ATE1^M)
Jan  1 00:06:20 Pineapple local2.info chat[1859]: expect (OK)
Jan  1 00:06:20 Pineapple local2.info chat[1859]: ^M
Jan  1 00:06:20 Pineapple local2.info chat[1859]: ATE1^M^M
Jan  1 00:06:20 Pineapple local2.info chat[1859]: OK
Jan  1 00:06:20 Pineapple local2.info chat[1859]:  -- got it
Jan  1 00:06:20 Pineapple local2.info chat[1859]: send (AT+CGDCONT=1,"IP","www.internet.mtelia.dk"^M)
Jan  1 00:06:21 Pineapple local2.info chat[1859]: abort on (NO CARRIER)
Jan  1 00:06:21 Pineapple local2.info chat[1859]: expect (OK)
Jan  1 00:06:21 Pineapple local2.info chat[1859]: ^M
Jan  1 00:06:21 Pineapple local2.info chat[1859]: AT+CGDCONT=1,"IP","www.internet.mtelia.dk"^M^M
Jan  1 00:06:21 Pineapple local2.info chat[1859]: OK
Jan  1 00:06:21 Pineapple local2.info chat[1859]:  -- got it
Jan  1 00:06:21 Pineapple local2.info chat[1859]: send (AT+ZSNT=0,0,0^M)
Jan  1 00:06:21 Pineapple local2.info chat[1859]: timeout set to 20 seconds
Jan  1 00:06:21 Pineapple local2.info chat[1859]: expect (OK)
Jan  1 00:06:21 Pineapple local2.info chat[1859]: ^M
Jan  1 00:06:21 Pineapple local2.info chat[1859]: AT+ZSNT=0,0,0^M^M
Jan  1 00:06:21 Pineapple local2.info chat[1859]: OK
Jan  1 00:06:21 Pineapple local2.info chat[1859]:  -- got it
Jan  1 00:06:21 Pineapple local2.info chat[1859]: send (ATD*99#^M)
Jan  1 00:06:21 Pineapple local2.info chat[1859]: expect (CONNECT)
Jan  1 00:06:21 Pineapple local2.info chat[1859]: ^M
Jan  1 00:06:21 Pineapple local2.info chat[1859]: ATD*99#^M^M
Jan  1 00:06:21 Pineapple local2.info chat[1859]: CONNECT
Jan  1 00:06:21 Pineapple local2.info chat[1859]:  -- got it
Jan  1 00:06:21 Pineapple local2.info chat[1859]: send ( ^M)
Jan  1 00:06:21 Pineapple daemon.info pppd[1855]: Serial connection established.
Jan  1 00:06:21 Pineapple daemon.info pppd[1855]: Using interface 3g-wan2
Jan  1 00:06:21 Pineapple daemon.notice pppd[1855]: Connect: 3g-wan2 <--> /dev/ttyUSB2
Jan  1 00:06:22 Pineapple daemon.warn pppd[1855]: Could not determine remote IP address: defaulting to 10.64.64.64
Jan  1 00:06:22 Pineapple daemon.notice pppd[1855]: local  IP address 10.234.118.8
Jan  1 00:06:22 Pineapple daemon.notice pppd[1855]: remote IP address 10.64.64.64
Jan  1 00:06:22 Pineapple daemon.notice pppd[1855]: primary   DNS address 62.44.166.197
Jan  1 00:06:22 Pineapple daemon.notice pppd[1855]: secondary DNS address 62.44.166.69
Jan  1 00:06:22 Pineapple daemon.notice netifd: Interface 'wan2' is now up
Jan  1 00:06:24 Pineapple daemon.info dnsmasq[1534]: reading /tmp/resolv.conf.auto
Jan  1 00:06:24 Pineapple daemon.info dnsmasq[1534]: using nameserver 62.44.166.197#53
Jan  1 00:06:24 Pineapple daemon.info dnsmasq[1534]: using nameserver 62.44.166.69#53
Jan  1 00:06:24 Pineapple daemon.info dnsmasq[1534]: using nameserver 8.8.8.8#53
Jan  1 00:06:24 Pineapple daemon.info dnsmasq[1534]: using local addresses only for domain lan
Jan  1 00:06:25 Pineapple kern.info kernel: [  384.950000] usb 1-1: USB disconnect, device number 3
Jan  1 00:06:25 Pineapple daemon.notice pppd[1855]: Modem hangup
Jan  1 00:06:25 Pineapple daemon.info pppd[1855]: Connect time 0.1 minutes.
Jan  1 00:06:25 Pineapple daemon.info pppd[1855]: Sent 204 bytes, received 0 bytes.
Jan  1 00:06:25 Pineapple daemon.notice pppd[1855]: Connection terminated.
Jan  1 00:06:25 Pineapple daemon.notice netifd: Interface 'wan2' has lost the connection
Jan  1 00:06:25 Pineapple kern.info kernel: [  384.960000] generic ttyUSB0: generic converter now disconnected from ttyUSB0
Jan  1 00:06:25 Pineapple kern.info kernel: [  384.960000] usbserial_generic 1-1:1.0: device disconnected
Jan  1 00:06:25 Pineapple kern.info kernel: [  384.970000] generic ttyUSB1: generic converter now disconnected from ttyUSB1
Jan  1 00:06:25 Pineapple kern.info kernel: [  384.980000] usbserial_generic 1-1:1.1: device disconnected
Jan  1 00:06:25 Pineapple kern.info kernel: [  384.980000] generic ttyUSB2: generic converter now disconnected from ttyUSB2
Jan  1 00:06:25 Pineapple kern.info kernel: [  384.990000] usbserial_generic 1-1:1.2: device disconnected
Jan  1 00:06:25 Pineapple kern.info kernel: [  384.990000] generic ttyUSB3: generic converter now disconnected from ttyUSB3
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.000000] usbserial_generic 1-1:1.3: device disconnected
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.010000] generic ttyUSB4: generic converter now disconnected from ttyUSB4
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.010000] usbserial_generic 1-1:1.4: device disconnected
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.300000] usb 1-1: new high-speed USB device number 4 using ehci-platform
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.450000] usbserial_generic 1-1:1.0: The "generic" usb-serial driver is only for testing and one-off prototypes.
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.460000] usbserial_generic 1-1:1.0: Tell linux-usb@vger.kernel.org to add your device to a proper driver.
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.470000] usbserial_generic 1-1:1.0: generic converter detected
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.480000] usb 1-1: generic converter now attached to ttyUSB0
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.480000] usbserial_generic 1-1:1.1: The "generic" usb-serial driver is only for testing and one-off prototypes.
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.490000] usbserial_generic 1-1:1.1: Tell linux-usb@vger.kernel.org to add your device to a proper driver.
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.500000] usbserial_generic 1-1:1.1: generic converter detected
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.510000] usb 1-1: generic converter now attached to ttyUSB1
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.510000] usbserial_generic 1-1:1.2: The "generic" usb-serial driver is only for testing and one-off prototypes.
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.520000] usbserial_generic 1-1:1.2: Tell linux-usb@vger.kernel.org to add your device to a proper driver.
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.530000] usbserial_generic 1-1:1.2: generic converter detected
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.540000] usb 1-1: generic converter now attached to ttyUSB2
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.550000] usbserial_generic 1-1:1.3: The "generic" usb-serial driver is only for testing and one-off prototypes.
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.560000] usbserial_generic 1-1:1.3: Tell linux-usb@vger.kernel.org to add your device to a proper driver.
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.570000] usbserial_generic 1-1:1.3: generic converter detected
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.570000] usb 1-1: generic converter now attached to ttyUSB3
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.580000] usbserial_generic 1-1:1.4: The "generic" usb-serial driver is only for testing and one-off prototypes.
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.590000] usbserial_generic 1-1:1.4: Tell linux-usb@vger.kernel.org to add your device to a proper driver.
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.600000] usbserial_generic 1-1:1.4: generic converter detected
Jan  1 00:06:25 Pineapple kern.info kernel: [  385.600000] usb 1-1: generic converter now attached to ttyUSB4
Jan  1 00:06:26 Pineapple daemon.info pppd[1855]: Terminating on signal 15
Jan  1 00:06:26 Pineapple daemon.info pppd[1855]: Exit.
Jan  1 00:06:26 Pineapple daemon.notice netifd: Interface 'wan2' is now down
Jan  1 00:06:27 Pineapple user.notice usb-modeswitch: 1-1:1.0: Manufacturer=ZTE,Incorporated Product=ZTE_LTE_Technologies_MSM Serial=?
Jan  1 00:06:27 Pineapple user.notice usb-modeswitch: 1-1:1.1: Manufacturer=ZTE,Incorporated Product=ZTE_LTE_Technologies_MSM Serial=?
Jan  1 00:06:27 Pineapple user.notice usb-modeswitch: 1-1:1.2: Manufacturer=ZTE,Incorporated Product=ZTE_LTE_Technologies_MSM Serial=?
Jan  1 00:06:28 Pineapple user.notice usb-modeswitch: 1-1:1.3: Manufacturer=ZTE,Incorporated Product=ZTE_LTE_Technologies_MSM Serial=?
Jan  1 00:06:28 Pineapple user.notice usb-modeswitch: 1-1:1.4: Manufacturer=ZTE,Incorporated Product=ZTE_LTE_Technologies_MSM Serial=?

So for me it looks like the modem resets after disconnect (and then gets switched back again). But i have no idea what actually happened.

I've tested the modem on a Mac and PC and i works fine.

I'm not hundred percent sure that its /dev/ttyUSB2 I'm supposed to use, but i've tried the other ones and ttyUSB2 seems to give the least critical errors.

Is there anything i've overlooked?

Thanks a bunch.

Link to comment
Share on other sites

Hey Semtx,

How are you powering your pineapple / 3G modem? It is possible that your specific modem is drawing too much power once it is actually connected and basically reboots itself. The pineapple seems to see a disconnect of a USB device, so this may be one possibility.

I am on my phone right now so I only looked over the logs quickly, I'll be back at a computer soon.

Best,

Sebkinne

Link to comment
Share on other sites

Does anyone know if a way to debug/listen in on what AT commands the dongle sends when I'm using it from my Mac/Win machine? Emulating this might help.

Also is there any USB device viewer/command-line tool i can use to find out what USB device to use, preferably on the device.

Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...