Jump to content

Can't associate to open Wi-Fi network. Alfa Card


TylerCPU
 Share

Recommended Posts

Hey guys. I can't connect my Alfa AWUS036NHA to a open Wi-Fi router. It's connected to my Wi-Fi Pineapple IV. 2.8.0 Firmware. I run ifconfig wlan1 up,iwconfig wlan1 mode managed, iwconfig wlan1 essid Guest, but I still can't associate to my network. It's an open one. This is what iwconfig looks like

root@Pineapple:~# iwconfig
lo        no wireless extensions.

wlan1     IEEE 802.11bgn  ESSID:"Guest"
          Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated
          Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

eth1      no wireless extensions.

wlan0     IEEE 802.11bgn  Mode:Master  Tx-Power=18 dBm
          RTS thr:off   Fragment thr:off
          Power Management:on

eth0      no wireless extensions.

br-lan    no wireless extensions.

root@Pineapple:~#

Am I missing something simple? I scoured the web for info, but I found nothing. Please help. Thanks.

Edited by TylerCPU
Link to comment
Share on other sites

Yes, that doesn't work. I tried just about every blog,forum,post/video. I always get stuck at iwconfig wlan1 essid "Guest" which is an open Wi-Fi network. It will not associate. The pineapple says,"You want to connect? Well, you can't hahah!"

Link to comment
Share on other sites

I tried the networkmanager module last night and still couldn't get that to work. So I looked deeper in the forums and I found one person that said that something was wrong with an older version of network manager. The problem was a tiny setting in /etc/config/wireless. I had to change under radio1 in config wifi-iface the option network lan to option network wan. Then it finally worked. I tried iwconfig wlan1 essid Guest and it worked! Now I'm associated so next I tried udhcpc -i wlan1 and I got an IP address. Yes! Then followed another guys tutorial on iptables for switching the default gateway from the PoE/Lan port to my alfa card. Yay! Now I can route traffic through my alfa card and instead of Internet > laptop > pineapple > Wi-Fi now I got Internet > Hotspot > Wi-Fi alfa > Pineapple > Wi-Fi out. Yay! I wonder why option network lan has to be set to wan?

TLDR, replace config in /etc/config/wireless with this.

Note: I removed my Mac address so replace with yours instead of xxxxxx.

config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11ng
option macaddr XXXXXX
option htmode HT20
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
#

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid "pineapple "
option encryption none

config wifi-device radio1
option type mac80211
option channel 11
option hwmode 11ng
option macaddr XXXXXX
option htmode HT20
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
#

config wifi-iface
option device radio1
option network wan
option mode ap
option ssid "pineapple "
option encryption none

Edited by TylerCPU
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...