Jump to content

Serial / UART Cable


thunder9861
 Share

Recommended Posts

Hello.

I need to perform a clean flash on my MK IV, and I just had a few questions about the cable.

I currently have a Serial -> 3.3v TTL cable that uses a MAX232 chip.

It is homebuilt, using this site:

http://sodoityourself.com/max232-serial-level-converter/

This cable works just fine on my Pogoplug, as well as my Fonera 2100 and Fonera 2200 (the MK III hardware).

I have not tried using it on the MK IV yet, because after searching around here, and on Mr. Protocol's wiki page, it says I need a UART cable.

The term UART is new to me, but does this mean that the cable I have is not the correct one?

This page uses the terms "UART" and "Serial TTL" almost interchangably:

http://wiki.openwrt.org/doc/hardware/port.serial

However this post claims the opposite (that they are indeed different):

http://forums.hak5.org/index.php?/topic/28820-pineapple-iv-clean-flash-cant-connect-with-com-help

I'm wondering if I am just getting the terminology mixed up.

I have looked at the Hakshop for the device I need:

http://hakshop.myshopify.com/products/serial-ttl-cable

Unfortunately it is sold out, however it is called both a "UART Cable" as well as a "Serial TTL cable".

Can someone clarify for me if the cable I have is correct?

I do not want to connect it until I have verification, because I am very afraid of frying the MK IV.

I am also aware that I should NOT connect the VDD pin on the MK IV.

Thank you for your help.

Edited by thunder9861
Link to comment
Share on other sites

If your cable works on the FON2100, FON2200 then the cable will work on the MK4.

Make sure to wire it up properly to not fry your device - you can find that info on the wiki / our website.

Note that the FON2200 wasn't the MK3, it was the MK2.

Best,

Sebkinne

Link to comment
Share on other sites

Well, I tried it out, but it doesn't seem to be working as I expected.

I first tried the TX/RX pins in the order shown on the Wiki. Nothing appeared on the screen when I plugged in the pineapple.

Next, I reversed the TX/RX wires and cycled power, but still nothing.

Finally, just out of curiousity, I attached only the RX pin, and I actually saw output on the screen.

It was timed properly with a typical boot sequence, however the output was all gibberish.

I double checked all my settings, however I am starting to wonder if my cable is not correct afterall.

Again, the cable works fine on the Fonera's, as well as my Pogoplug.

Any ideas?

Also, the cable in the hakshop is sold out:

http://hakshop.myshopify.com/products/serial-ttl-cable

Any ideas what the exact device is and where I could get it from?

I'm not opposed to buying one if it will help me fix my pineapple MK4.

Thanks again for your help, let me know if I need to include more information.

Link to comment
Share on other sites

It is made for 3.3 volts. I think I will be taking your advice though, and buying a premade one like the one in the hakshop. That should eliminate any unknown variables...

Thanks for your help.

EDIT:

Here is the schematic:

circuit_232.jpg​

Edited by thunder9861
Link to comment
Share on other sites

I just wanted to chime in with my results. I bought a CP2102 USB 2.0 to UART TTL 6 pin connector on Ebay, and it worked perfectly on my MK4. Hopefully this will help anyone who happens to have a similar problem. In the end, it appears that the cable I built that works with the Fonera 2100, 2200, and my Pogoplug is not the same as the UART required for the MK4.

Thank you for your help, I have successfully brought my MK4 back to life!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...