Jump to content

Hiding the fruit


Recommended Posts

You know that "wait...what if..." feeling you sometimes get? I had it about a week ago so I rolled up my sleeves and came up with this:


Still with me? cool! check it out:


The pineapple fits in a standard Lenovo hard-drive slot, albeit there is a significant amount of work involved to pull that off:

The biggest issue is height, namely that condenser (blue arrow) but that is an easy fix... just swap it out for one with similar specs and bend it a little. the other big issue are the ethernet ports.

Now the ethernet ports are a PITA to swap around and fit inside such a small enclosure, I purchased a pci-e ethernet card (didn't work on my lenovo, it would have been GLORIOUS if I could make everything but the antenna self-contained) off of which ended up just using the ethernet connector (red arrow), I hardwired everything and routed the cable under the metal part on the side of the enclosure.

The next height issue was the power connector which I didn't want to desolder (more on that later) so I just sanded off the extra-height with a rotary tool and its now a snug fit. (green arrow)

I did some reading and turns out SATA has a bunch of options when it comes to power: 5.5v, 12v, 3.3v, everything comes through that big sata power connector, so I decided to leverage on that. I got 5.5v from the sata and now the pineapple is pretty much self contained inside the laptop. Caveats? I'm not sure if it's the laptop or the cheesy hard drive tray, but I could never get any power from those wires that wasn't 5.5v, my multimeter said all the other power cables were dead, downside to that: that USB thumb drive is limited in size since it seems that any Sundisk Fit above 4gb (perhaps 8, I ordered one on amazon, I'll get back to you guys soon) requires more power than the 5.5v powered pineapple is willing to give it. (a 16gb worked sporadically, the 32Gb never worked at all) Im sure that if I could get 12v to it, it would be a different story.

Why didn't I want to desolder the power connector? because if power came solely from the sata connector there would be no way to reset the pineapple, I always need that external power source to push the button and power up :/

You'll notice that the WAN port is MIA (yellow arrow), it could certainly be salvaged and all the wires re-routed, but it would require some hacking on that sata connector (literal hacking, I'd have to saw off that mofo and figure out a way to keep it in place)

Comments, concerns and ideas for improvement are always welcome :)

Edited by sygo
Link to comment
Share on other sites

It's certainly enough if you can live with the storage. I personally don't have a problem with 4gb, whatever I do with the pineapple has to be encrypted ASAP, so whatever logs end up on the thumb drive will soon be on an encrypted filesystem. Small storage forces me to be disciplined when it comes to data sanitation. And $DIVINITY knows I need all the incentive I can get.

That being said, I do believe that the inconsistency with usb thumb drives is due to power contraints. I base this on the fact that if I plug that 16Gb Sundisk Fit directly into the pineapple it complains a good deal and fails to do anything with the device:

[  521.290000] usb 1-1: USB disconnect, device number 2
[  527.260000] usb 1-1: new high-speed USB device number 3 using ehci-platform
[  542.380000] usb 1-1: device descriptor read/64, error -145
[  557.610000] usb 1-1: device descriptor read/64, error -145
[  557.840000] usb 1-1: new high-speed USB device number 4 using ehci-platform
[  572.960000] usb 1-1: device descriptor read/64, error -145
[  588.190000] usb 1-1: device descriptor read/64, error -145
[  588.420000] usb 1-1: new high-speed USB device number 5 using ehci-platform
[  593.450000] usb 1-1: device descriptor read/8, error -145
[  598.580000] usb 1-1: device descriptor read/8, error -145
[  598.810000] usb 1-1: new high-speed USB device number 6 using ehci-platform
[  603.840000] usb 1-1: device descriptor read/8, error -145
[  608.970000] usb 1-1: device descriptor read/8, error -145
[  609.080000] hub 1-0:1.0: unable to enumerate USB device on port 1 

but if I plug in a powered USB hub into the pineapple and plug the same 16Gb in the hub, it's happiness all around:

[  976.970000] usb 1-1: new high-speed USB device number 7 using ehci-platform
[  977.120000] hub 1-1:1.0: USB hub found
[  977.120000] hub 1-1:1.0: 7 ports detected
[  977.420000] usb 1-1.2: new high-speed USB device number 8 using ehci-platform
[  977.550000] hub 1-1.2:1.0: USB hub found
[  977.550000] hub 1-1.2:1.0: 3 ports detected
[  977.830000] usb 1-1.2.1: new full-speed USB device number 9 using ehci-platform
[  978.050000] usb 1-1.2.2: new full-speed USB device number 10 using ehci-platform
[  978.430000] usb 1-1.2.3: new low-speed USB device number 11 using ehci-platform
[  982.520000] usb 1-1.1: new high-speed USB device number 12 using ehci-platform
[  982.660000] scsi1 : usb-storage 1-1.1:1.0
[  983.660000] scsi 1:0:0:0: Direct-Access     SanDisk  Cruzer Fit       1.26 PQ: 0 ANSI: 5
[  983.660000] sd 1:0:0:0: Attached scsi generic sg0 type 0
[  983.680000] sd 1:0:0:0: [sda] 31266816 512-byte logical blocks: (16.0 GB/14.9 GiB)
[  983.680000] sd 1:0:0:0: [sda] Write Protect is off
[  983.690000] sd 1:0:0:0: [sda] Mode Sense: 43 00 00 00
[  983.690000] sd 1:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[  983.710000]  sda: sda1 sda2
[  983.730000] sd 1:0:0:0: [sda] Attached SCSI removable disk
[  984.460000] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[  984.750000] Adding 953320k swap on /dev/sda2.  Priority:-1 extents:1 across:953320k 

again, I need to run a bunch more tests, I know that if I use my external battery juice pack to feed the pineapple (it's a Unu 11000mAh dual usb that feeds out 5v at 1A or 2.1A depending on the usb port you use) the 16Gb usb doesn't work either. So it doesn't seem to be an amp issue.

I need to run a multimeter on this hub and see what voltage it's feeding the usb ports, if it's above 5, that might just be it!

my theory might be flawed, I'm looking at the hardware for issues/solutions, but there's much i dont't know regarding the inner workings of HALs and such, it might just be a logical issue.

Link to comment
Share on other sites

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...