Jump to content

wifi pineapple no connection


xneox
 Share

Recommended Posts

Hi all

Iam trying to connect to the Internet through the pineapple but I can't connect the web page is not available also the pineapple bar is giving me an error connecting please make sure you have internet connection

I have set int ip gate way addresse to my wifi card

My o/s is Ubuntu

Any help please

Link to comment
Share on other sites

How-to Ask For Help With The Jasager

Before posting a question, read the firmware changelog.

In order to troubleshoot and improve overall experience with the WiFi Pineapple, there is criteria that should be supplied when asking for assistance. This gives developers feedback on making the Wifi Pineapple more user friendly and information to address issues that may currently exist.

Providing as much of the information below, if it applies, along with the issue will help the community better assist with the problem.

  • Pineapple Hardware Version (ex: Mark III, Mark IV, etc.):
  • Pineapple Software Version (ex: 2.5.0, 2.6.4):
  • OS used to connect to the pineapple:
  • Network layout of how your setup is connected (including IP information):
  • All the tools/options that are running on the pineapple when the issue happened:
  • Ping results from computer to pineapple:
  • Is the problem repeatable (Yes/No):
  • Steps taken which created the problem:
  • Error Messages:
  • Log file information:
  • Anything else that was attempted to 'fix' the problem:

Feel free to copy/paste the list to your post and fill out the information.

Link to comment
Share on other sites

Hi Xneox,

Please understand that people get anoyed when they get these very general questions. They are also thinking to themself " This guy can not even setup an internet connection, what is he doing with a pineapple ?" this is basic network stuff. Just do trouble shoting like you would with any PC ( ie can you ping, are your ip setup correct, make sure the cable is connected to the correct port and so on ).

The above video is realy well done and it is very clear just make sure you do everthing correct.

If you are doing this then give the output so people can analyse what you are doing wrong. Make a clear long description of your problem.

I know we all have to start at some point. But in order to get help you will need to give a more specific issue description

Typical beginner mistakes are not connecting to the pineapple POE port but to WAN port

and trying to reach pineaplle under old URL and not the new ( 172.16.42.1:1471 )

you say in first post " I have set int ip gate way addresse to my wifi card" The gateway is your router IP and not your WiFi card

anyway good luck

Edited by webdirector
Link to comment
Share on other sites

Hi I have downloaded the wifi pineapple script setup

I have installed the script I then ran sudo ./wp4.sh

I then get some options for setup

Pineapple netmask 255.255..255.0

Pineapple network 172.16.42.0/24

Interface between pc and pineapple eth0

Interface between pc and internet wlan0

Internet gateway 172.16.42.1 here I have put 192.168.0.5 which is my wlan0 inet address

Ip address of host pc 172.16.42.42

Ip address of pineapple 172.16.42.1

Siocdelrt no such process

Browse to http://172.16.42.1: happy hacking

Link to comment
Share on other sites

I question: I use Backtrack 5 R3 and my problem is:

Pineapple connected to eth0

Internet in Backtrack it´s in Wlan0

I connect to my router and then run ./wp4.sh.

All runs nice, but some minutes later, the connection lost, aparently because wicd make a auto connect to eth0 killing the wlan0 connection to internet.

I try make a wicd stop but nothing.

So, I read in the forum several problems with pineapple and wicd. There is a way to replace wicd with the network manager that appear in the video?

My backtrack is 5 R3 Gnome and runs in it´s own partition no Virtual.

Thanks a lot.

Edited by Boba Fett
Link to comment
Share on other sites

  • 3 months later...

I question: I use Backtrack 5 R3 and my problem is:

Pineapple connected to eth0

Internet in Backtrack it´s in Wlan0

I connect to my router and then run ./wp4.sh.

All runs nice, but some minutes later, the connection lost, aparently because wicd make a auto connect to eth0 killing the wlan0 connection to internet.

I try make a wicd stop but nothing.

So, I read in the forum several problems with pineapple and wicd. There is a way to replace wicd with the network manager that appear in the video?

My backtrack is 5 R3 Gnome and runs in it´s own partition no Virtual.

Thanks a lot.

I ran into this issue too. Wicd doesn't support concurrent connections. Since it is easier for me to manually configure eth0 than set up a WPA supplicant, etc, I went the route of simply telling wicd not to configure the ethernet connection for me. This is really simple. Under "Preferences, General Settings" in wicd, erase the interface name for the wired interface. This worked like a charm for me and made wicd forget about my ethernet.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...