Jump to content

Huawei E1550 MarkIV 2.7 USB Internet Problem


Go to solution Solved by HakSmack,

Recommended Posts

Hi

I realy need your guys help!

Having problem getting the Huawei E1550 working with the MarkIV 2.7.

I get the following:

00:48:40 Pineapple daemon.info pppd[8469]: Exit.
00:48:39 Pineapple daemon.notice pppd[8469]: Connection terminated.
00:48:33 Pineapple daemon.warn pppd[8469]: IPCP: timeout sending Config-Requests
00:47:59 Pineapple local2.info chat[8473]: timeout set to 30 seconds
00:47:59 Pineapple local2.info chat[8473]: send (ATD*99***1#^M)
00:47:59 Pineapple local2.info chat[8473]: send ( ^M)
00:47:59 Pineapple local2.info chat[8473]: expect (OK)
00:47:59 Pineapple local2.info chat[8473]: expect (CONNECT)
00:47:59 Pineapple local2.info chat[8473]: ^M
00:47:59 Pineapple local2.info chat[8473]: ^M
00:47:59 Pineapple local2.info chat[8473]: OK
00:47:59 Pineapple local2.info chat[8473]: CONNECT
00:47:59 Pineapple local2.info chat[8473]: ATD*99***1#^M^M
00:47:59 Pineapple local2.info chat[8473]: AT+CGDCONT=1,"IP","internet"^M^M
00:47:59 Pineapple local2.info chat[8473]: -- got it
00:47:59 Pineapple local2.info chat[8473]: -- got it
00:47:59 Pineapple daemon.notice pppd[8469]: Connect: 3g-wan2 <--> /dev/ttyUSB0
00:47:59 Pineapple daemon.info pppd[8469]: Using interface 3g-wan2
00:47:59 Pineapple daemon.info pppd[8469]: Serial connection established.
00:47:58 Pineapple local2.info chat[8473]: timeout set to 10 seconds
00:47:58 Pineapple local2.info chat[8473]: send (ATE1^M)
00:47:58 Pineapple local2.info chat[8473]: send (AT+CGDCONT=1,"IP","internet"^M)
00:47:58 Pineapple local2.info chat[8473]: send (AT&F^M)
00:47:58 Pineapple local2.info chat[8473]: report (CONNECT)
00:47:58 Pineapple local2.info chat[8473]: expect (OK)
00:47:58 Pineapple local2.info chat[8473]: expect (OK)
00:47:58 Pineapple local2.info chat[8473]: abort on (NO CARRIER)
00:47:58 Pineapple local2.info chat[8473]: abort on (ERROR)
00:47:58 Pineapple local2.info chat[8473]: abort on (BUSY)
00:47:58 Pineapple local2.info chat[8473]: ^M
00:47:58 Pineapple local2.info chat[8473]: OK
00:47:58 Pineapple local2.info chat[8473]: OK
00:47:58 Pineapple local2.info chat[8473]: ATE1^M^M
00:47:58 Pineapple local2.info chat[8473]: AT&F^M^M
00:47:58 Pineapple local2.info chat[8473]: -- got it
00:47:58 Pineapple local2.info chat[8473]: -- got it
00:47:57 Pineapple daemon.notice pppd[8469]: pppd 2.4.5 started by root, uid 0
00:47:57 Pineapple daemon.info dnsmasq[1087]: using nameserver 8.8.8.8#53
00:47:57 Pineapple daemon.info dnsmasq[1087]: using local addresses only for domain lan
00:47:57 Pineapple daemon.info dnsmasq[1087]: reading /tmp/resolv.conf.auto
00:47:54 Pineapple daemon.notice pppd[8419]: Modem hangup
00:47:54 Pineapple daemon.notice netifd: Interface 'wan2' is now down
00:47:54 Pineapple daemon.info pppd[8419]: Exit.
00:47:53 Pineapple daemon.notice pppd[8419]: Connection terminated.

My configuration are as:

*12d1:1001*) echo "Huawei E1550 detected. Attempting mode switch"
uci delete network.wan2
uci set network.wan2=interface
uci set network.wan2.ifname=ppp0
uci set network.wan2.proto=3g
uci set network.wan2.service=umts
uci set network.wan2.device=/dev/ttyUSB0
uci set network.wan2.apn=apn
uci set network.wan2.username=tmn
uci set network.wan2.password=tmn
uci set network.wan2.defaultroute=1
uci commit network
usb_modeswitch -v 12d1 -p 1001 -M 55534243123456780000000000000011060000000000000000000000000000
sleep 10; rmmod usbserial
sleep 3; insmod usbserial vendor=0x12d1 product=0x1001
sleep 5; /etc/init.d/firewall disable; /etc/init.d/firewall stop
logger "3G: firewall stopped"
iptables -t nat -A POSTROUTING -s 172.16.42.0/24 -o 3g-wan2 -j MASQUERADE
iptables -A FORWARD -s 172.16.42.0/24 -o 3g-wan2 -j ACCEPT
iptables -A FORWARD -d 172.16.42.0/24 -m state --state ESTABLISHED,RELATED -i 3g-wan2 -j ACCEPT

;;

I have tried changin the password= and username= to blank also changing apn to internet.

Realy appriciate any help i can get.

Thanks!

Link to post
Share on other sites

Thanks sorry yes it´s 2.7.7 :(

Hmm, sorry then, I'm afraid I don't know much about 3G modems as I don't use them much, however I would suggest tripple checking the APN, Username and passwords aswell as the vendor IDs.

Hope you the best;

-Foxtrot

Link to post
Share on other sites

As a novice to 3g it would seem your connection is been made but dropped straight away, firstly I would ask if you are definitely in a coverage area for your network provider, and secondly double check the settings as foxtrot has mentioned.

Link to post
Share on other sites
  • Solution

Ofcourse you guys were right i got it to work after looking more carefull in on the vendor settings APN

This works for me after a reboot:

*12d1:1001*) echo "Huawei E1550 detected. Attempting mode switch"
uci delete network.wan2
uci set network.wan2=interface
uci set network.wan2.ifname=ppp0
uci set network.wan2.proto=3g
uci set network.wan2.service=umts
uci set network.wan2.device=/dev/ttyUSB0
uci set network.wan2.apn=internet.telenor.se
uci set network.wan2.username=Telenor
uci set network.wan2.password=Telenor
uci set network.wan2.defaultroute=1
uci commit network
usb_modeswitch -v 12d1 -p 1001 -M 55534243123456780000000000000011060000000000000000000000000000
sleep 30; rmmod usbserial
sleep 3; insmod usbserial vendor=0x12d1 product=0x1001
sleep 5; /etc/init.d/firewall disable; /etc/init.d/firewall stop
logger "3G: firewall stopped"
iptables -t nat -A POSTROUTING -s 172.16.42.0/24 -o 3g-wan2 -j MASQUERADE
iptables -A FORWARD -s 172.16.42.0/24 -o 3g-wan2 -j ACCEPT
iptables -A FORWARD -d 172.16.42.0/24 -m state --state ESTABLISHED,RELATED -i 3g-wan2 -j ACCEPT

;;

Thanks for your support!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...