Jump to content

Internet Connection Sharing changes LAN IP


Zephyr
 Share

Recommended Posts

Just received my Pineapple today. Everything is up and running except for internet connection sharing. When I enable ICS I receive the message:

When Internet Connection Sharing is enabled, your LAN adapter will be set
to use IP address
192.168.137.1. Your computer may lose connectivity with
other computers on your network. If these other computers have static IP
addresses, you should set them to obtain their IP addresses automatically.
Are you sure you want to enable Internet Connection Sharing?

I click 'OK'

This of course causes my laptop to lose connection with my Pineapple. I'm running Win 7 and have never seen this message before. I don't know why it's doing this but I'm trying to figure out a work around. How can I enable ICS while retaining my LAN IP, which is set to the Pineapple, 172.16.42.42?

Edited by Zephyr
Link to comment
Share on other sites

Ok here is what seemed to work for me.

1. Go back to your LAN NIC, IPv4 properties, set to 'Obtain IP address automatically.'

2. Enable ICS on your internet connected adapter as usual (you should not get the 'your LAN adapter will be set' error this time).

3. Return to your LAN IPv4 settings once again and enter the usual information:

IP Address: 172.16.42.42

Subnet Mask: 255.255.255.0

Preferred DNS Server: 8.8.8.8

4. Reboot your computer.

Hopefully it will work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...