Jump to content

Karma starting on wlan0 and wlan1


comatose603
 Share

Recommended Posts

The reason karma starts on both interfaces is because AP mode is turned on on both cards. You will need to turn AP mode off in the /etc/conf/wireless for your wlan1 interface.

What firmware version are you running?

Ah, that make sense. The latest stable... 2.7.0 Considering people will expect the optional Alpha usb radio to just work when they buy it with the Pineapple shouldnt this be turned off by default?! Not everyone is smart enough to realize the Jammer module isnt working because some hostapd process is fighting wtih it.

Link to comment
Share on other sites

Ah, that make sense. The latest stable... 2.7.0 Considering people will expect the optional Alpha usb radio to just work when they buy it with the Pineapple shouldnt this be turned off by default?! Not everyone is smart enough to realize the Jammer module isnt working because some hostapd process is fighting wtih it.

Actually, it used to be the intended purpose. I suggest you upgrade to 2.7.5 as from 2.7.1+ there have been fixes for exactly that!

Link to comment
Share on other sites

Actually, it used to be the intended purpose. I suggest you upgrade to 2.7.5 as from 2.7.1+ there have been fixes for exactly that!

Just upgraded to 2.7.5. Having the same issue. Install Jammer. Pick wlan1. And the Pineapple reboots itself.

Another issue is autostart does not work with sslstrip (in 2.7.5 either I see). In order to get it working I had to add the full path to sslstrip in rc.local and the full path to python in autostart.sh.

Also, can I run sslstrip and urlsnarf at the same time in this release? That was another issue that, being new to the product and not knowing there was a confict, drove me insane at first.

Edited by comatose603
Link to comment
Share on other sites

Edit the wireless file in /etc/config/

Change

option mode ap under radio 1 to sta

Here is the radio 1 section of my file

config wifi-device radio1

option type mac80211

option channel 11

option macaddr 00:12:12:12:12:12

option hwmode 11ng

option htmode HT20

list ht_capab SHORT-GI-20

list ht_capab SHORT-GI-40

list ht_capab RX-STBC1

list ht_capab DSSS_CCK-40

# REMOVE THIS LINE TO ENABLE WIFI:

config wifi-iface

option device radio1

option network lan

option mode sta

option ssid OpenWrt

option encryption none

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...