Jump to content

Possible bricked pineapple?


andyrj82
 Share

Recommended Posts

Hello,

I recently purchased a wifi pineapple off of hak5's shop. I was setup and on the web interface and after installing a few infusions and testing out urlsnarf. I attempted to connect a freshly ext4 formatted usb drive to the pineapple. At that point it began to stop responding. I could no longer ping the device on 172.16.42.1, and when attempting to refresh wired connection as I normally had over the PoE/lan port, I was unable to get a valid address. When using a static ip of 172.16.42.x I was also unable to ping or connect to device using wp4.sh as per instructions.

At that point I tried the reset switch on the back figuring that flashing back to defaults should allow me to get back onto the device. I am still no longer able to get any interface or even ping the device through any port. I also cannot connect to the device's wireless ap that is open with any of my wireless devices, it just refuses to give out an ip, and even with a static assigned ip I have no connectivity to the devices address I assume to be 172.16.42.1. The wps light was flashing rapidly after I pressed the reset button but is now back to solid.

Any help? I do not have a usb to uart device and really don't want to have to buy something else just to use my wifi-pineapple :(. I have also tried the standard 30-30-30 reset I am used to with ddwrt/etc, to no avail.

Thanks in advance,

Andy

Link to comment
Share on other sites

Hey Andy, welcome to the forums!

First of all, 30-30-30 reset does nothing on our firmware. The correct way to do it is to boot up your pineapple (wait until the WPS light stops flashing) and then press the button for 5-10 seconds.

Anyway, in regards to your issue. Do you know what firmware version you are / were on?

Either way, make sure to unplug the USB from the pineapple. Power on your pineapple and wait until the WPS light is solid. Then try to SSH in. I ask because you don't state that you tried this. If you have, we need to debug it by other means.

Link to comment
Share on other sites

I have pressed the reset button for approx 10 seconds rebooted the pineapple, waited until the wps button stops flashing after reboot. Then plugged into PoE/Lan port with laptop and assigned myself ip 172.16.42.42, (if I wait for dhcp as was working initially I never get an address assigned), and attempted to ping and ssh with no luck. Below is the output on console relevant to connecting that I am aware of, I also have cleared my iptables just to be sure I wasn't blocking anything.
laptop-dv7% ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
link/ether c8:0a:a9:23:66:1d brd ff:ff:ff:ff:ff:ff
inet 172.16.42.42/24 brd 172.16.42.255 scope global enp3s0
inet6 fe80::ca0a:a9ff:fe23:661d/64 scope link
valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
link/ether c4:17:fe:71:e4:f5 brd ff:ff:ff:ff:ff:ff
inet 10.10.10.137/24 brd 10.10.10.255 scope global wlan0
inet6 fe80::c617:feff:fe71:e4f5/64 scope link
valid_lft forever preferred_lft forever
laptop-dv7% ping -c 3 172.16.42.1
PING 172.16.42.1 (172.16.42.1) 56(84) bytes of data.
From 172.16.42.42 icmp_seq=1 Destination Host Unreachable
From 172.16.42.42 icmp_seq=2 Destination Host Unreachable
From 172.16.42.42 icmp_seq=3 Destination Host Unreachable
--- 172.16.42.1 ping statistics ---
3 packets transmitted, 0 received, +3 errors, 100% packet loss, time 1999ms
pipe 3
laptop-dv7% ssh root@172.16.42.1
ssh: connect to host 172.16.42.1 port 22: No route to host

What should I try different?

Link to comment
Share on other sites

ok, small update. I am able to temporarily get an ssh connection to begin with the device during boot with the wps light still blinking. However as soon as it goes solid, I am no longer able to ping or ssh to the device.

below is a pastebin of pinging the device while it reboots. I also attempted to ssh to it but it froze when it completed reboot.

http://pastebin.com/VjJw4vEn

not really sure why I can't get the device to reset to a proper state again. :(

Link to comment
Share on other sites

  • 5 months later...

I am running in to exactly the same problem. The thing that really worries me is that this topic was unanswered since January...

I am considering sending back eveything to the HakShop now, since it appears that there is no solution to this problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...