Jump to content

USB sandisk 4gb is saying its write protected when trying to format


Recommended Posts

I have been trying to get my usb stick (the one from hak5 shop) to work with my pineapple and i went to reformat it and now its saying it write protected.

I have googled everywere and tried to the 'redgit' route and the ubuntu disk utility format but still i carnt do anything to the usb stick! has the pineapple broke it?

Link to comment
Share on other sites

Someone else was having issues. I believe that he was able to reformat it with Gparted.

Fire up Gparted, then in the top right select the USB drive from the dropdown. Then proceed to format the drive.

Try searching next time. The other thread is only about four down from this one...

Edited by ShadowBlade72
Link to comment
Share on other sites

i had already tried that without any luck at all :( i had seen that post aswell, i do try everything i can think of before i post here belive me! i would hate people to think i was a time waster.

To be honst i think the usb stick must be broken and that was why the pineapple could never use it the firs place and it needed formating so many times. Hopfully am wrong and sombody else here has a suggestion.

Link to comment
Share on other sites

I purchased the a 4gb Sandisk Fit when I got my pineapple a month ago. I was able to use it on battery power for the first few days, I used two battery sources the Pineapple Juice battery and I also tried an Anker3 battery. Then the usb drive wasn't being detected. I tried to format the usb drive on several different machines, linux and windows, none of the computers I used were able to format that little usb drive. So I contacted the resellers and they promptly sent out another 4gb usb, which now will only work correctly when plugged into ac power.

So at least in my experience my usb drive stopped working and had to return it for another.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...