Jump to content

Mint 14, mknod/udev


Infatuas
 Share

Recommended Posts

Hey All,

I was banging my head on an issue finally converted fully to mint, but setting up my USB-Serial adapter was a nightmare. At first I just plugged it in ran lsusb and I could see the adapter showing up then installed putty with but wasn't able to console. I then figured i'll try giving screen /dev/ttyUSB0 a shot and it worked immediately. I read that I should use "mknod /dev/ttyUSB0 -c 188 0" but still no luck. I then added my user to the dialout group then through the Properties GUI for Putty changed the permission to read/write for my user. That seemed to do the trick. I then reverted everything back to try and duplicate the original problem to see what exacly fixed it.

I would have thought something like udev would have automatically configured the device and there was no need for mknod. Could it just have been the permission to the application. Simply changing my user permission on the putty application from read to read/write fixed the problem?

Any input would be greatly appreciated as I'm trying to acquire an in-depth understanding of this glorious OS.

Respectfully,

Infatuas

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...